28 lines
899 B
Diff
28 lines
899 B
Diff
From 83b9ac91fbd68f0361280460e9e1928f45b71d12 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Mular <omular@redhat.com>
|
|
Date: Wed, 12 Jul 2017 13:40:12 +0200
|
|
Subject: [PATCH] fix for new setuptools
|
|
|
|
---
|
|
Makefile | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 0e4dff4..10934ec 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -100,7 +100,9 @@ pcsd_fonts = \
|
|
|
|
install:
|
|
# make Python interpreter execution sane (via -Es flags)
|
|
- echo -e "[build]\nexecutable = $(PYTHON) -Es\n" > setup.cfg
|
|
+ # in fedora 26 setuptools uses parameter executable from install section
|
|
+ # instead of setup
|
|
+ echo -e "[install]\nexecutable = $(PYTHON) -Es\n" > setup.cfg
|
|
$(PYTHON) setup.py install --root=$(or ${DESTDIR}, /) ${EXTRA_SETUP_OPTS}
|
|
# fix excessive script interpreting "executable" quoting with old setuptools:
|
|
# https://github.com/pypa/setuptools/issues/188
|
|
--
|
|
2.9.4
|
|
|