Resolves: rhbz#2167471
- Fixed broken filtering in create resource/fence device wizards in the web interface - Added BuildRequires: pam - needed for tier0 tests during build
This commit is contained in:
parent
16dd3a675d
commit
f93843e2c6
67
bz2167471-01-fix-broken-typeahead-component.patch
Normal file
67
bz2167471-01-fix-broken-typeahead-component.patch
Normal file
@ -0,0 +1,67 @@
|
||||
From c51faf31a1abc08e26e5ccb4492c1a46f101a22a Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Devat <idevat@redhat.com>
|
||||
Date: Tue, 13 Dec 2022 12:58:00 +0100
|
||||
Subject: [PATCH] fix agents filter in resource/fence device create
|
||||
|
||||
---
|
||||
.../cluster/fenceDevices/task/create/NameTypeTypeSelect.tsx | 4 ++--
|
||||
.../view/cluster/resources/task/create/NameTypeTypeSelect.tsx | 4 ++--
|
||||
src/app/view/share/form/Select.tsx | 2 +-
|
||||
3 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/app/view/cluster/fenceDevices/task/create/NameTypeTypeSelect.tsx b/src/app/view/cluster/fenceDevices/task/create/NameTypeTypeSelect.tsx
|
||||
index 80327801..8d623e2b 100644
|
||||
--- a/src/app/view/cluster/fenceDevices/task/create/NameTypeTypeSelect.tsx
|
||||
+++ b/src/app/view/cluster/fenceDevices/task/create/NameTypeTypeSelect.tsx
|
||||
@@ -38,13 +38,13 @@ export const NameTypeTypeSelect = ({
|
||||
return (
|
||||
<Select
|
||||
variant="typeahead"
|
||||
- typeAheadAriaLabel="Select a fence device"
|
||||
+ typeAheadAriaLabel="Select a fence device agent"
|
||||
+ placeholderText="Select a fence device agent"
|
||||
onSelect={onSelect}
|
||||
onClear={onClear}
|
||||
onFilter={onFilter}
|
||||
selections={agentName}
|
||||
isGrouped
|
||||
- hasInlineFilter
|
||||
customBadgeText={agentName.length > 0 ? agentName : undefined}
|
||||
optionsValues={filteredFenceAgentList}
|
||||
data-test="fence-device-agent"
|
||||
diff --git a/src/app/view/cluster/resources/task/create/NameTypeTypeSelect.tsx b/src/app/view/cluster/resources/task/create/NameTypeTypeSelect.tsx
|
||||
index bd7807d8..b531e825 100644
|
||||
--- a/src/app/view/cluster/resources/task/create/NameTypeTypeSelect.tsx
|
||||
+++ b/src/app/view/cluster/resources/task/create/NameTypeTypeSelect.tsx
|
||||
@@ -52,13 +52,13 @@ export const NameTypeTypeSelect = ({
|
||||
return (
|
||||
<Select
|
||||
variant="typeahead"
|
||||
- typeAheadAriaLabel="Select a state"
|
||||
+ typeAheadAriaLabel="Select a resource agent"
|
||||
+ placeholderText="Select a resource agent"
|
||||
onSelect={onSelect}
|
||||
onClear={onClear}
|
||||
onFilter={onFilter}
|
||||
selections={agentName}
|
||||
isGrouped
|
||||
- hasInlineFilter
|
||||
customBadgeText={agentName.length > 0 ? agentName : undefined}
|
||||
data-test="resource-agent"
|
||||
>
|
||||
diff --git a/src/app/view/share/form/Select.tsx b/src/app/view/share/form/Select.tsx
|
||||
index d73f126c..e2b81ce2 100644
|
||||
--- a/src/app/view/share/form/Select.tsx
|
||||
+++ b/src/app/view/share/form/Select.tsx
|
||||
@@ -31,7 +31,7 @@ export const Select = (
|
||||
const filter = onFilter
|
||||
? (_event: React.ChangeEvent<HTMLInputElement> | null, value: string) => {
|
||||
onFilter(value);
|
||||
- return null as unknown as React.ReactElement[];
|
||||
+ return undefined;
|
||||
}
|
||||
: null;
|
||||
|
||||
--
|
||||
2.39.0
|
||||
|
14
pcs.spec
14
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.11.4
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPL-2.0-only: pcs
|
||||
@ -117,7 +117,7 @@ Patch8: bz2158790-01-fix-stonith-watchdog-timeout-validation.patch
|
||||
Patch9: bz2166249-01-fix-stonith-watchdog-timeout-offline-update.patch
|
||||
|
||||
# ui patches: >200
|
||||
# Patch201: bzNUMBER-01-name.patch
|
||||
Patch201: bz2167471-01-fix-broken-typeahead-component.patch
|
||||
|
||||
# git for patches
|
||||
BuildRequires: git-core
|
||||
@ -154,6 +154,9 @@ BuildRequires: rubygem-test-unit
|
||||
BuildRequires: diffstat
|
||||
# for post, preun and postun macros
|
||||
BuildRequires: systemd
|
||||
# pam is used for authentication inside daemon (python ctypes)
|
||||
# needed for tier0 tests during build
|
||||
BuildRequires: pam
|
||||
BuildRequires: make
|
||||
# Red Hat logo for creating symlink of favicon
|
||||
BuildRequires: redhat-logos
|
||||
@ -293,7 +296,7 @@ update_times_patch(){
|
||||
# patch web-ui sources
|
||||
%autosetup -D -T -b 100 -a 101 -S git -n %{ui_src_name} -N
|
||||
%autopatch -p1 -m 201
|
||||
# update_times_patch %%{PATCH201}
|
||||
update_times_patch %{PATCH201}
|
||||
|
||||
# patch pcs sources
|
||||
%autosetup -S git -n %{pcs_source_name} -N
|
||||
@ -541,6 +544,11 @@ run_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Mon Feb 13 2023 Michal Pospisil <mpospisi@redhat.com> - 0.11.4-6
|
||||
- Fixed broken filtering in create resource/fence device wizards in the web interface
|
||||
- Added BuildRequires: pam - needed for tier0 tests during build
|
||||
- Resolves: rhbz#2167471
|
||||
|
||||
* Thu Feb 02 2023 Michal Pospisil <mpospisi@redhat.com> - 0.11.4-5
|
||||
- Fixed enabling/disabling sbd when cluster is not running
|
||||
- Resolves: rhbz#2166249
|
||||
|
Loading…
Reference in New Issue
Block a user