Rebased to latest upstream sources (see CHANGELOG.md)
- Updated pcs-web-ui - Updated bundled python dependency: dacite - Changed BuildRequires from git to git-core - Added conditional (Build)Requires: rubygem(rexml) - Added conditional Requires: rubygem(webrick)
This commit is contained in:
parent
7247eb7cfb
commit
eff9068c43
4
.gitignore
vendored
4
.gitignore
vendored
@ -75,3 +75,7 @@
|
||||
/pcs-web-ui-0.1.3.tar.gz
|
||||
/pcs-web-ui-node-modules-0.1.3.tar.xz
|
||||
/pcs-0.10.7.tar.gz
|
||||
/dacite-1.6.0.tar.gz
|
||||
/pcs-0.10.8.tar.gz
|
||||
/pcs-web-ui-0.1.5.tar.gz
|
||||
/pcs-web-ui-node-modules-0.1.5.tar.xz
|
||||
|
@ -1,52 +0,0 @@
|
||||
From 9f7c50b9bfaafd5d8368eeb34014e65655318ac0 Mon Sep 17 00:00:00 2001
|
||||
From: Ondrej Mular <omular@redhat.com>
|
||||
Date: Wed, 25 Nov 2020 10:16:26 +0100
|
||||
Subject: [PATCH] fix getting type hints annotations in python 3.10
|
||||
|
||||
In Python 3.10 a postponed evaluation of type hint annotations [1] will
|
||||
be a default [2]. To access annotated types as objects instead of
|
||||
strings, we need to use function `typing.get_type_hints(...)`
|
||||
|
||||
[1]: https://www.python.org/dev/peps/pep-0563/
|
||||
[2]: https://docs.python.org/3.10/whatsnew/3.10.html#pep-563-postponed-evaluation-of-annotations-becomes-default
|
||||
---
|
||||
pcs/cli/reports/messages.py | 11 +++++++----
|
||||
1 file changed, 7 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/pcs/cli/reports/messages.py b/pcs/cli/reports/messages.py
|
||||
index ecf74561..7582aec0 100644
|
||||
--- a/pcs/cli/reports/messages.py
|
||||
+++ b/pcs/cli/reports/messages.py
|
||||
@@ -1,4 +1,5 @@
|
||||
from typing import (
|
||||
+ get_type_hints,
|
||||
Any,
|
||||
Dict,
|
||||
Mapping,
|
||||
@@ -44,7 +45,7 @@ class CliReportMessageCustom(CliReportMessage):
|
||||
|
||||
def __init__(self, dto_obj: dto.ReportItemMessageDto) -> None:
|
||||
super().__init__(dto_obj)
|
||||
- self._obj = self.__class__.__annotations__.get("_obj")( # type: ignore
|
||||
+ self._obj = get_type_hints(self.__class__).get("_obj")( # type: ignore
|
||||
**dto_obj.payload
|
||||
)
|
||||
|
||||
@@ -446,9 +447,11 @@ def _create_report_msg_map() -> Dict[str, type]:
|
||||
result: Dict[str, type] = {}
|
||||
for report_msg_cls in get_all_subclasses(CliReportMessageCustom):
|
||||
# pylint: disable=protected-access
|
||||
- code = report_msg_cls.__annotations__.get(
|
||||
- "_obj", item.ReportItemMessage
|
||||
- )._code
|
||||
+ code = (
|
||||
+ get_type_hints(report_msg_cls)
|
||||
+ .get("_obj", item.ReportItemMessage)
|
||||
+ ._code
|
||||
+ )
|
||||
if code:
|
||||
if code in result:
|
||||
raise AssertionError()
|
||||
--
|
||||
2.27.0
|
||||
|
27
pcs.spec
27
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.10.7
|
||||
Release: 4%{?dist}
|
||||
Version: 0.10.8
|
||||
Release: 1%{?dist}
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPLv2: pcs
|
||||
# MIT: ember, handlebars, jquery, jquery-ui
|
||||
@ -13,13 +13,13 @@ Summary: Pacemaker Configuration System
|
||||
%global pcs_source_name %{name}-%{version_or_commit}
|
||||
|
||||
# ui_commit can be determined by hash, tag or branch
|
||||
%global ui_commit 0.1.3
|
||||
%global ui_commit 0.1.5
|
||||
%global ui_src_name pcs-web-ui-%{ui_commit}
|
||||
|
||||
%global pcs_snmp_pkg_name pcs-snmp
|
||||
|
||||
%global pyagentx_version 0.4.pcs.2
|
||||
%global dacite_version 1.5.1
|
||||
%global dacite_version 1.6.0
|
||||
|
||||
# bundled libraries for old web-ui
|
||||
%global ember_version 1.4.0
|
||||
@ -47,11 +47,11 @@ Source44: https://github.com/konradhalas/dacite/archive/v%{dacite_version}/dacit
|
||||
Source100: https://github.com/idevat/pcs-web-ui/archive/%{ui_commit}/%{ui_src_name}.tar.gz
|
||||
Source101: https://github.com/idevat/pcs-web-ui/releases/download/%{ui_commit}/pcs-web-ui-node-modules-%{ui_commit}.tar.xz
|
||||
|
||||
Patch0: fix-getting-type-hints-annotations-in-python-3.10.patch
|
||||
# Patch0: name.patch
|
||||
|
||||
# git for patches
|
||||
BuildRequires: make
|
||||
BuildRequires: git
|
||||
BuildRequires: git-core
|
||||
#printf from coreutils is used in makefile
|
||||
BuildRequires: coreutils
|
||||
# python for pcs
|
||||
@ -74,7 +74,9 @@ BuildRequires: rubygem-open4
|
||||
BuildRequires: rubygem-rack
|
||||
BuildRequires: rubygem-rack-protection
|
||||
BuildRequires: rubygem-rack-test
|
||||
%if 0%{?fedora} >= 34 || 0%{?eln} || 0%{?rhel} >= 9
|
||||
BuildRequires: rubygem(rexml)
|
||||
%endif
|
||||
BuildRequires: rubygem-sinatra
|
||||
BuildRequires: rubygem-tilt
|
||||
# ruby libraries for tests
|
||||
@ -112,7 +114,10 @@ Requires: rubygem-open4
|
||||
Requires: rubygem-rack
|
||||
Requires: rubygem-rack-protection
|
||||
Requires: rubygem-rack-test
|
||||
%if 0%{?fedora} >= 34 || 0%{?eln} || 0%{?rhel} >= 9
|
||||
Requires: rubygem(rexml)
|
||||
Requires: rubygem(webrick)
|
||||
%endif
|
||||
Requires: rubygem-sinatra
|
||||
Requires: rubygem-tilt
|
||||
# ruby and gems for pcsd-ruby
|
||||
@ -210,7 +215,7 @@ update_times_patch(){
|
||||
update_times ${patch_file_name} `diffstat -p1 -l ${patch_file_name}`
|
||||
}
|
||||
|
||||
update_times_patch %{PATCH0}
|
||||
# update_times_patch %%{PATCH0}
|
||||
|
||||
# prepare dirs/files necessary for building web ui
|
||||
# inside SOURCE100 is only directory %%{ui_src_name}
|
||||
@ -397,6 +402,14 @@ remove_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Thu Feb 04 2021 Miroslav Lisik <mlisik@redhat.com> - 0.10.8-1
|
||||
- Rebased to latest upstream sources (see CHANGELOG.md)
|
||||
- Updated pcs-web-ui
|
||||
- Updated bundled python dependency: dacite
|
||||
- Changed BuildRequires from git to git-core
|
||||
- Added conditional (Build)Requires: rubygem(rexml)
|
||||
- Added conditional Requires: rubygem(webrick)
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
8
sources
8
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (pyagentx-0.4.pcs.2.tar.gz) = d4194fec9a3e5fefe3793d49b7fec1feafef294c7e613a06046c2993daeefc5cb39d7c5b2b402ff83e49b2d976953f862264288c758c0be09d997b5323cc558a
|
||||
SHA512 (dacite-1.5.1.tar.gz) = ac1a3ffcd7e75fe99e6a3baf8623d3caee8940f0d2a8e455f86d71f71e1ff76b0bfad0c112a2ebdf2a81d4be9c9bd99adea94603f674c28e68959cb299d0039d
|
||||
SHA512 (pcs-web-ui-0.1.3.tar.gz) = caf28046e11d75f77ab96ab27fe3eb8b09bf767a0daee0155dbc7999ede2ae80f937328cc7fd6c0620caafbb6fda61d8076ec30ed2e2911fbf5dc6a0e1eb915b
|
||||
SHA512 (pcs-web-ui-node-modules-0.1.3.tar.xz) = 61cb28e7a6fe1253da24537101d502b3116d148db6eb81512067a0d6bdbafb7a93e3c546fb020515921ee846254be20dabbab79198c6e9bcfc3a18e7ebb5fdca
|
||||
SHA512 (pcs-0.10.7.tar.gz) = c76a11fa162258ee311dcceca50674d7638396880596a826a711d944aab421ed06a6c4eb41f9dc997c01b72bce73c98c4f7be3fcd8fafb8ae16902f6a1e0c521
|
||||
SHA512 (dacite-1.6.0.tar.gz) = 034255f095589d309fe5805413d8b148f430cd20a0de305b7954083b530d516da1d8f3f00ebb5264a8cfb77f2b2a76f1e2d863e78bd191f1d85021c5553815da
|
||||
SHA512 (pcs-0.10.8.tar.gz) = 8b9ba62279431e481d062e804d24480d2a274d2f4897a82149df6116ff3df2394d97a3ee77a6dee4c563d915bab0142124a8942524fcc4e894912086e865353c
|
||||
SHA512 (pcs-web-ui-0.1.5.tar.gz) = ec4adf8ca5858c1f1f82e8f58e36864805bedc6dc10674fab83498aff5422a0497703ecd96fda17b4c1f6beffa64fe5a80a82fb4f75b2102fe1a4753a5d057e9
|
||||
SHA512 (pcs-web-ui-node-modules-0.1.5.tar.xz) = cf1ef7e9280e7a0e864407e15f33edb98dce72e93d6917b74d5833ba184be248d87f6f309a2667bb2cbba0f33d1afde6a706832473505df87ed65835512da82c
|
||||
|
Loading…
Reference in New Issue
Block a user