Re-synced to upstream sources
This commit is contained in:
parent
3ebb60a9cd
commit
bea4b7df86
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/pcs-withgems-0.9.115.tar.gz
|
||||
/pcs-withgems-0.9.139.tar.gz
|
||||
/pcs-withgems-0.9.140.tar.gz
|
||||
/pcs-withgems-0.9.141.tar.gz
|
||||
|
96
fedfix.patch
96
fedfix.patch
@ -1,62 +1,70 @@
|
||||
From 43b366e92113c63926fd372e081bb633cee3ba31 Mon Sep 17 00:00:00 2001
|
||||
From ec05be119b13fbbbea22052a79d61a8da883c16f Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Jelinek <tojeline@redhat.com>
|
||||
Date: Fri, 5 Jun 2015 14:29:03 +0200
|
||||
Date: Tue, 23 Jun 2015 16:29:02 +0200
|
||||
Subject: [PATCH] fedfix patch
|
||||
|
||||
---
|
||||
pcsd/Gemfile | 16 ++++++++--------
|
||||
pcsd/Gemfile.lock | 10 ----------
|
||||
pcsd/Gemfile | 8 --------
|
||||
pcsd/Gemfile.lock | 21 ---------------------
|
||||
pcsd/Makefile | 2 +-
|
||||
pcsd/pcsd.conf | 1 +
|
||||
pcsd/pcsd.rb | 22 ++++++++++++----------
|
||||
5 files changed, 22 insertions(+), 29 deletions(-)
|
||||
3 files changed, 1 insertion(+), 30 deletions(-)
|
||||
|
||||
diff --git a/pcsd/Gemfile b/pcsd/Gemfile
|
||||
index db98546..3658683 100644
|
||||
index db98546..e412e12 100644
|
||||
--- a/pcsd/Gemfile
|
||||
+++ b/pcsd/Gemfile
|
||||
@@ -1,16 +1,16 @@
|
||||
@@ -1,16 +1,8 @@
|
||||
source 'https://rubygems.org'
|
||||
|
||||
-gem 'sinatra'
|
||||
+#gem 'sinatra'
|
||||
gem 'sinatra-contrib'
|
||||
-gem 'rack'
|
||||
-gem 'rack-protection'
|
||||
-gem 'tilt'
|
||||
-gem 'eventmachine'
|
||||
-gem 'rack-test'
|
||||
+#gem 'rack'
|
||||
+#gem 'rack-protection'
|
||||
+#gem 'tilt'
|
||||
+#gem 'eventmachine'
|
||||
+#gem 'rack-test'
|
||||
gem 'backports'
|
||||
gem 'sinatra-sugar'
|
||||
gem 'monkey-lib'
|
||||
gem 'rpam-ruby19'
|
||||
-gem 'multi_json'
|
||||
-gem 'open4'
|
||||
+#gem 'multi_json'
|
||||
+#gem 'open4'
|
||||
gem 'orderedhash'
|
||||
diff --git a/pcsd/Gemfile.lock b/pcsd/Gemfile.lock
|
||||
index 6eb3d03..af1d77a 100644
|
||||
index 848758e..4ea6796 100644
|
||||
--- a/pcsd/Gemfile.lock
|
||||
+++ b/pcsd/Gemfile.lock
|
||||
@@ -2,11 +2,9 @@ GEM
|
||||
@@ -2,22 +2,10 @@ GEM
|
||||
remote: https://rubygems.org/
|
||||
specs:
|
||||
backports (3.6.4)
|
||||
- eventmachine (1.0.7)
|
||||
monkey-lib (0.5.4)
|
||||
backports
|
||||
multi_json (1.11.0)
|
||||
- multi_json (1.11.1)
|
||||
- open4 (1.3.4)
|
||||
orderedhash (0.0.6)
|
||||
rack (1.5.3)
|
||||
rack-protection (1.5.3)
|
||||
@@ -35,16 +33,8 @@ PLATFORMS
|
||||
- rack (1.6.4)
|
||||
- rack-protection (1.5.3)
|
||||
- rack
|
||||
- rack-test (0.6.3)
|
||||
- rack (>= 1.0)
|
||||
rpam-ruby19 (1.2.1)
|
||||
- sinatra (1.4.6)
|
||||
- rack (~> 1.4)
|
||||
- rack-protection (~> 1.4)
|
||||
- tilt (>= 1.3, < 3)
|
||||
sinatra-contrib (1.4.4)
|
||||
backports (>= 2.0)
|
||||
multi_json
|
||||
@@ -28,23 +16,14 @@ GEM
|
||||
sinatra-sugar (0.5.1)
|
||||
monkey-lib (~> 0.5.0)
|
||||
sinatra (~> 1.0)
|
||||
- tilt (1.4.1)
|
||||
|
||||
PLATFORMS
|
||||
ruby
|
||||
|
||||
DEPENDENCIES
|
||||
backports
|
||||
@ -86,48 +94,6 @@ index 0d28b58..d320162 100644
|
||||
|
||||
# RHEL6 needs special rpam-ruby19 gem to work with 1.8.7
|
||||
build_gems_rhel6:
|
||||
diff --git a/pcsd/pcsd.conf b/pcsd/pcsd.conf
|
||||
index 69c4022..f596d59 100644
|
||||
--- a/pcsd/pcsd.conf
|
||||
+++ b/pcsd/pcsd.conf
|
||||
@@ -1,3 +1,4 @@
|
||||
# pcsd configuration file
|
||||
# Set PCSD_DEBUG to true for advanced pcsd debugging information
|
||||
PCSD_DEBUG=false
|
||||
+RACK_ENV=production
|
||||
diff --git a/pcsd/pcsd.rb b/pcsd/pcsd.rb
|
||||
index 82d3fcd..bb137a4 100644
|
||||
--- a/pcsd/pcsd.rb
|
||||
+++ b/pcsd/pcsd.rb
|
||||
@@ -39,16 +39,18 @@ use Rack::Session::Cookie,
|
||||
|
||||
#use Rack::SSL
|
||||
|
||||
-Dir["wizards/*.rb"].each {|file| also_reload file}
|
||||
-also_reload 'resource.rb'
|
||||
-also_reload 'remote.rb'
|
||||
-also_reload 'fenceagent.rb'
|
||||
-also_reload 'cluster.rb'
|
||||
-also_reload 'config.rb'
|
||||
-also_reload 'pcs.rb'
|
||||
-also_reload 'auth.rb'
|
||||
-also_reload 'wizard.rb'
|
||||
-also_reload 'cfgsync.rb'
|
||||
+if development?
|
||||
+ Dir["wizards/*.rb"].each {|file| also_reload file}
|
||||
+ also_reload 'resource.rb'
|
||||
+ also_reload 'remote.rb'
|
||||
+ also_reload 'fenceagent.rb'
|
||||
+ also_reload 'cluster.rb'
|
||||
+ also_reload 'config.rb'
|
||||
+ also_reload 'pcs.rb'
|
||||
+ also_reload 'auth.rb'
|
||||
+ also_reload 'wizard.rb'
|
||||
+ also_reload 'cfgsync.rb'
|
||||
+end
|
||||
|
||||
before do
|
||||
$session = session
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
14
pcs.spec
14
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.9.140
|
||||
Release: 2%{?dist}
|
||||
Version: 0.9.141
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
URL: http://github.com/feist/pcs
|
||||
Group: System Environment/Base
|
||||
@ -17,6 +17,13 @@ Requires: python-clufter
|
||||
Requires: rubygem-sinatra rubygem-rack rubygem-rack-protection rubygem-tilt
|
||||
Requires: rubygem-eventmachine rubygem-rack-test rubygem-multi_json rubygem-json rubygem-open4
|
||||
|
||||
Provides: bundled(rubygem-backports) = 3.6.4
|
||||
Provides: bundled(rubygem-monkey-lib) = 0.5.4
|
||||
Provides: bundled(rubygem-orderedhash) = 0.0.6
|
||||
Provides: bundled(rubygem-rpam-ruby19) = 1.2.1
|
||||
Provides: bundled(rubygem-sinatra-contrib) = 1.4.4
|
||||
Provides: bundled(rubygem-sinatra-sugar) = 0.5.1
|
||||
|
||||
%description
|
||||
pcs is a corosync and pacemaker configuration tool. It permits users to
|
||||
easily view, modify and created pacemaker based clusters.
|
||||
@ -68,6 +75,9 @@ chmod 755 $RPM_BUILD_ROOT/%{python_sitelib}/pcs/pcs.py
|
||||
%doc COPYING README
|
||||
|
||||
%changelog
|
||||
* Tue Jun 23 2015 Tomas Jelinek <tojeline@redhat.com> - 0.9.141-1
|
||||
- Re-synced to upstream sources
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.140-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user