Resolves: rhbz#2210855
- Fixed a regression causing crash in `pcs resource move` command (broken since pcs-0.11.5)
This commit is contained in:
parent
e834de45bd
commit
aa4f1fd980
64
bz2210855-01-fix-resource-move-regression.patch
Normal file
64
bz2210855-01-fix-resource-move-regression.patch
Normal file
@ -0,0 +1,64 @@
|
||||
From 835939b80f3e75616eb585bb1e17dec0a6083a88 Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Jelinek <tojeline@redhat.com>
|
||||
Date: Tue, 30 May 2023 13:07:47 +0200
|
||||
Subject: [PATCH] fix resource move regression
|
||||
|
||||
---
|
||||
CHANGELOG.md | 3 +++
|
||||
pcs/lib/pacemaker/live.py | 5 ++++-
|
||||
pcs_test/tools/custom_mock.py | 2 +-
|
||||
3 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CHANGELOG.md b/CHANGELOG.md
|
||||
index c7661929..0c56758c 100644
|
||||
--- a/CHANGELOG.md
|
||||
+++ b/CHANGELOG.md
|
||||
@@ -27,6 +27,8 @@
|
||||
Pacemaker-2.1.5-rc1 ([rhbz#2177996])
|
||||
- Make `pcs resource disable --simulate --brief` documentation clearer
|
||||
([rhbz#2109852])
|
||||
+- Fixed a regression causing crash in `pcs resource move` command (broken since
|
||||
+ pcs-0.11.5) ([rhbz#2210855])
|
||||
|
||||
### Changed
|
||||
- Commands for displaying cluster configuration have been slightly updated:
|
||||
@@ -50,6 +52,7 @@
|
||||
[rhbz#2175881]: https://bugzilla.redhat.com/show_bug.cgi?id=2175881
|
||||
[rhbz#2177996]: https://bugzilla.redhat.com/show_bug.cgi?id=2177996
|
||||
[rhbz#2179388]: https://bugzilla.redhat.com/show_bug.cgi?id=2179388
|
||||
+[rhbz#2210855]: https://bugzilla.redhat.com/show_bug.cgi?id=2210855
|
||||
|
||||
|
||||
## [0.11.5] - 2023-03-01
|
||||
diff --git a/pcs/lib/pacemaker/live.py b/pcs/lib/pacemaker/live.py
|
||||
index c2ba5d60..5a4bfec2 100644
|
||||
--- a/pcs/lib/pacemaker/live.py
|
||||
+++ b/pcs/lib/pacemaker/live.py
|
||||
@@ -384,7 +384,10 @@ def simulate_cib_xml(runner, cib_xml):
|
||||
string cib_xml -- CIB XML to simulate
|
||||
"""
|
||||
try:
|
||||
- with tools.get_tmp_file() as new_cib_file, tools.get_tmp_file() as transitions_file:
|
||||
+ with (
|
||||
+ tools.get_tmp_file(None) as new_cib_file,
|
||||
+ tools.get_tmp_file(None) as transitions_file,
|
||||
+ ):
|
||||
cmd = [
|
||||
__exec("crm_simulate"),
|
||||
"--simulate",
|
||||
diff --git a/pcs_test/tools/custom_mock.py b/pcs_test/tools/custom_mock.py
|
||||
index 9380afce..90f12abd 100644
|
||||
--- a/pcs_test/tools/custom_mock.py
|
||||
+++ b/pcs_test/tools/custom_mock.py
|
||||
@@ -101,7 +101,7 @@ class TmpFileMock:
|
||||
except StopIteration:
|
||||
pass
|
||||
|
||||
- def _mock_side_effect(self, data=None, binary=False):
|
||||
+ def _mock_side_effect(self, data, binary=False):
|
||||
def _seek_callback(offset):
|
||||
if offset != 0:
|
||||
raise AssertionError(
|
||||
--
|
||||
2.40.1
|
||||
|
10
pcs.spec
10
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.11.5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPL-2.0-only: pcs
|
||||
@ -11,7 +11,7 @@ Release: 1%{?dist}
|
||||
# BSD-2-Clause or Ruby: ruby2_keywords
|
||||
# BSD-3-Clause: puma
|
||||
# BSD-3-Clause and MIT: ffi
|
||||
License: GPL-2.0-only AND Apache-2.0 AND MIT AND BSD-2-Clause AND BSD-3-Clause AND (BSD-2-Clause OR Ruby) AND (BSD-2-Clause OR GPL-2.0-or-later)
|
||||
License: GPL-2.0-only AND Apache-2.0 AND MIT AND BSD-3-Clause AND (BSD-2-Clause OR Ruby) AND (BSD-2-Clause OR GPL-2.0-or-later)
|
||||
URL: https://github.com/ClusterLabs/pcs
|
||||
Group: System Environment/Base
|
||||
Summary: Pacemaker/Corosync Configuration System
|
||||
@ -101,6 +101,7 @@ Source101: https://github.com/ClusterLabs/pcs-web-ui/releases/download/%{ui_comm
|
||||
# pcs patches: <= 200
|
||||
# Patch0: bzNUMBER-01-name.patch
|
||||
Patch0: do-not-support-cluster-setup-with-udp-u-transport.patch
|
||||
Patch1: bz2210855-01-fix-resource-move-regression.patch
|
||||
|
||||
# ui patches: >200
|
||||
# Patch201: bzNUMBER-01-name.patch
|
||||
@ -291,6 +292,7 @@ update_times_patch(){
|
||||
%autopatch -p1 -M 200
|
||||
# update_times_patch %%{PATCH0}
|
||||
update_times_patch %{PATCH0}
|
||||
update_times_patch %{PATCH1}
|
||||
|
||||
# generate .tarball-version if building from an untagged commit, not a released version
|
||||
# autogen uses git-version-gen which uses .tarball-version for generating version number
|
||||
@ -527,6 +529,10 @@ run_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Wed May 31 2023 Michal Pospisil <mpospisi@redhat.com> - 0.11.5-2
|
||||
- Fixed a regression causing crash in `pcs resource move` command (broken since pcs-0.11.5)
|
||||
- Resolves: rhbz#2210855
|
||||
|
||||
* Mon May 22 2023 Michal Pospisil <mpospisi@redhat.com> - 0.11.5-1
|
||||
- Rebased to the latest upstream sources (see CHANGELOG.md)
|
||||
- Updated pcs-web-ui
|
||||
|
Loading…
Reference in New Issue
Block a user