Resolves: rhbz#2102663
- Fixed 'pcs resource restart' traceback
This commit is contained in:
parent
b6114e416d
commit
a6938416c6
24
bz2102663-01-fix-pcs-resource-restart-traceback.patch
Normal file
24
bz2102663-01-fix-pcs-resource-restart-traceback.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From eeeaac9a46f3568e0a116048068ff99d0dccf25c Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Jelinek <tojeline@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 14:49:16 +0200
|
||||
Subject: [PATCH] fix 'pcs resource restart' traceback
|
||||
|
||||
---
|
||||
pcs/resource.py | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/pcs/resource.py b/pcs/resource.py
|
||||
index eb59d703..8d402c22 100644
|
||||
--- a/pcs/resource.py
|
||||
+++ b/pcs/resource.py
|
||||
@@ -2596,7 +2596,6 @@ def resource_restart(
|
||||
Options:
|
||||
* --wait
|
||||
"""
|
||||
- del lib
|
||||
modifiers.ensure_only_supported("--wait")
|
||||
if not argv:
|
||||
utils.err("You must specify a resource to restart")
|
||||
--
|
||||
2.35.3
|
||||
|
17
pcs.spec
17
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.11.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPLv2: pcs
|
||||
@ -110,6 +110,7 @@ Source101: https://github.com/ClusterLabs/pcs-web-ui/releases/download/%{ui_comm
|
||||
|
||||
# pcs patches: <= 200
|
||||
Patch1: do-not-support-cluster-setup-with-udp-u-transport.patch
|
||||
Patch2: bz2102663-01-fix-pcs-resource-restart-traceback.patch
|
||||
|
||||
# ui patches: >200
|
||||
# Patch201: bzNUMBER-01-name.patch
|
||||
@ -289,22 +290,12 @@ update_times_patch(){
|
||||
%autosetup -D -T -b 100 -a 101 -S git -n %{ui_src_name} -N
|
||||
%autopatch -p1 -m 201
|
||||
# update_times_patch %%{PATCH201}
|
||||
update_times_patch %{PATCH201}
|
||||
update_times_patch %{PATCH202}
|
||||
|
||||
# patch pcs sources
|
||||
%autosetup -S git -n %{pcs_source_name} -N
|
||||
%autopatch -p1 -M 200
|
||||
update_times_patch %{PATCH1}
|
||||
update_times_patch %{PATCH2}
|
||||
update_times_patch %{PATCH3}
|
||||
update_times_patch %{PATCH4}
|
||||
update_times_patch %{PATCH5}
|
||||
update_times_patch %{PATCH6}
|
||||
update_times_patch %{PATCH7}
|
||||
update_times_patch %{PATCH8}
|
||||
update_times_patch %{PATCH9}
|
||||
update_times_patch %{PATCH10}
|
||||
|
||||
# prepare dirs/files necessary for building all bundles
|
||||
# -----------------------------------------------------
|
||||
@ -542,6 +533,10 @@ run_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Tue Jul 12 2022 Miroslav Lisik <mlisik@redhat.com> - 0.11.3-2
|
||||
- Fixed 'pcs resource restart' traceback
|
||||
- Resolves: rhbz#2102663
|
||||
|
||||
* Fri Jun 24 2022 Miroslav Lisik <mlisik@redhat.com> - 0.11.3-1
|
||||
- Rebased to latest upstream sources (see CHANGELOG.md)
|
||||
- Updated pcs-web-ui
|
||||
|
Loading…
Reference in New Issue
Block a user