- Fixed gem building
- Re-synced to upstream sources
This commit is contained in:
parent
274eea6d37
commit
a6211c32e4
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/pcs-0.9.32.tar.gz
|
||||
/pcs-0.9.33.tar.gz
|
||||
/pcs-0.9.36.tar.gz
|
||||
/pcs-0.9.39.tar.gz
|
||||
|
22
fedfix.patch
22
fedfix.patch
@ -1,26 +1,20 @@
|
||||
Index: pcs/pcs-0.9.36/pcsd/Makefile
|
||||
===================================================================
|
||||
--- pcs.orig/pcs-0.9.36/pcsd/Makefile
|
||||
+++ pcs/pcs-0.9.36/pcsd/Makefile
|
||||
@@ -1,11 +1,12 @@
|
||||
--- pcs-0.9.39/pcsd/Makefile.fedfix 2013-03-13 18:21:24.000000000 -0500
|
||||
+++ pcs-0.9.39/pcsd/Makefile 2013-04-19 17:02:21.965509809 -0500
|
||||
@@ -1,10 +1,11 @@
|
||||
-PCSD_GEMS=sinatra sinatra-contrib json highline rack rack-protection tilt eventmachine rack-test backports sinatra-sugar monkey-lib rpam-ruby19
|
||||
+PCSD_GEMS=
|
||||
+PCSD_GEMS=rpam-ruby19
|
||||
|
||||
tarball:
|
||||
rm -f dist/pcsd.tar.gz
|
||||
tar -C .. -czvf dist/pcsd.tar.gz --exclude ".*" --exclude .git --exclude --exclude=gemhome/* --exclude=dist --exclude=assets --exclude=jquery-ui pcs-gui
|
||||
|
||||
build_gems:
|
||||
- mkdir -p gems; cd gems; gem install --local -i ../gemhome ${PCSD_GEMS}
|
||||
+ echo "No gems to build"
|
||||
+# mkdir -p gems; cd gems; gem install --local -i ../gemhome ${PCSD_GEMS}
|
||||
+# echo "No gems to build"
|
||||
mkdir -p gems; cd gems; gem install --local -i ../gemhome ${PCSD_GEMS}
|
||||
|
||||
get_gems:
|
||||
mkdir -p gems; cd gems; gem fetch ${PCSD_GEMS}
|
||||
Index: pcs/pcs-0.9.36/pcsd/pcsd.rb
|
||||
===================================================================
|
||||
--- pcs.orig/pcs-0.9.36/pcsd/pcsd.rb
|
||||
+++ pcs/pcs-0.9.36/pcsd/pcsd.rb
|
||||
--- pcs-0.9.39/pcsd/pcsd.rb.fedfix 2013-03-19 18:04:53.000000000 -0500
|
||||
+++ pcs-0.9.39/pcsd/pcsd.rb 2013-04-19 17:01:32.958053089 -0500
|
||||
@@ -1,5 +1,5 @@
|
||||
require 'sinatra'
|
||||
-require 'sinatra/reloader' if development? #require 'rack/ssl'
|
||||
|
14
pcs.spec
14
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.9.36
|
||||
Release: 4%{?dist}
|
||||
Version: 0.9.39
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2
|
||||
URL: http://github.com/feist/pcs
|
||||
Group: System Environment/Base
|
||||
@ -8,6 +8,7 @@ BuildRequires: python2-devel ruby ruby-devel pam-devel rubygem-sinatra rubygem-j
|
||||
Summary: Pacemaker Configuration System
|
||||
Source0: http://people.redhat.com/cfeist/pcs/pcs-%{version}.tar.gz
|
||||
Patch0: fedfix.patch
|
||||
Patch1: updateerror.patch
|
||||
Requires: pacemaker ruby rubygem-sinatra rubygem-json rubygem-rack-test
|
||||
|
||||
%description
|
||||
@ -16,7 +17,8 @@ easily view, modify and created pacemaker based clusters.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p2 -b .fedfix
|
||||
%patch0 -p1 -b .fedfix
|
||||
%patch1 -p1 -b .updateerror
|
||||
|
||||
%build
|
||||
|
||||
@ -24,7 +26,7 @@ easily view, modify and created pacemaker based clusters.
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
pwd
|
||||
make install DESTDIR=$RPM_BUILD_ROOT PYTHON_SITELIB=%{python_sitelib}
|
||||
make install_pcsd DESTDIR=$RPM_BUILD_ROOT PYTHON_SITELIB=%{python_sitelib}
|
||||
make install_pcsd DESTDIR=$RPM_BUILD_ROOT PYTHON_SITELIB=%{python_sitelib} hdrdir="%{_includedir}" rubyhdrdir="%{_includedir}" includedir="%{_includedir}"
|
||||
chmod 755 $RPM_BUILD_ROOT/%{python_sitelib}/pcs/pcs.py
|
||||
|
||||
%files
|
||||
@ -40,6 +42,10 @@ chmod 755 $RPM_BUILD_ROOT/%{python_sitelib}/pcs/pcs.py
|
||||
%doc COPYING README
|
||||
|
||||
%changelog
|
||||
* Fri Apr 19 2013 Chris Feist <cfeist@redhat.com> - 0.9.39-1
|
||||
- Fixed gem building
|
||||
- Re-synced to upstream sources
|
||||
|
||||
* Mon Mar 25 2013 Chris Feist <cfeist@rehdat.com> - 0.9.36-4
|
||||
- Don't try to build gems at all
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
6b16990c85c658ba3098a553bedf7923 pcs-0.9.36.tar.gz
|
||||
438384a4fd7f3807fe24c17d13189b2e pcs-0.9.39.tar.gz
|
||||
|
21
updateerror.patch
Normal file
21
updateerror.patch
Normal file
@ -0,0 +1,21 @@
|
||||
commit 5ba79c28c3759e298b780751b1b3314f7f071839
|
||||
Author: Chris Feist <cfeist@redhat.com>
|
||||
AuthorDate: Fri Apr 19 17:06:20 2013 -0500
|
||||
Commit: Chris Feist <cfeist@redhat.com>
|
||||
CommitDate: Fri Apr 19 17:06:20 2013 -0500
|
||||
|
||||
Fixed error in updateToken error output
|
||||
|
||||
diff --git a/pcs/utils.py b/pcs/utils.py
|
||||
index 0e47423..d64cb5c 100644
|
||||
--- a/pcs/utils.py
|
||||
+++ b/pcs/utils.py
|
||||
@@ -30,7 +30,7 @@ def updateToken(node,username,password):
|
||||
data = urllib.urlencode({'username':username, 'password':password})
|
||||
out = sendHTTPRequest(node, 'remote/auth', data, False)
|
||||
if out[0] != 0:
|
||||
- err("unable to connect to pcsd on %s\n" % node + out)
|
||||
+ err("unable to connect to pcsd on %s\n" % node + out[1])
|
||||
token = out[1]
|
||||
if token == "":
|
||||
err("Username and/or password is incorrect")
|
Loading…
Reference in New Issue
Block a user