Start bundling rubygem-tilt

- Started bundling rubygem-tilt (rubygem-tilt is orphaned in fedora due to rubygem-prawn dependency)
- Enabled passing tests
This commit is contained in:
Ivan Devat 2018-08-31 14:18:36 +02:00
parent af67efa0f5
commit a504446fc1
5 changed files with 79 additions and 252 deletions

1
.gitignore vendored
View File

@ -54,3 +54,4 @@
/pcs-0.10.0.alpha.1.tar.gz
/sinatra-contrib-2.0.3.gem
/pcs-0.10.0.alpha.2.tar.gz
/tilt-2.0.8.gem

View File

@ -1,59 +0,0 @@
From 911d2d37e44842d2341f052df1ff0546278c04e0 Mon Sep 17 00:00:00 2001
From: Ivan Devat <idevat@redhat.com>
Date: Mon, 19 Feb 2018 17:54:35 +0100
Subject: [PATCH 1/2] adapt working with ruby gems to fedora
---
pcsd/Makefile | 36 ++----------------------------------
1 file changed, 2 insertions(+), 34 deletions(-)
diff --git a/pcsd/Makefile b/pcsd/Makefile
index 2067560..604f74d 100644
--- a/pcsd/Makefile
+++ b/pcsd/Makefile
@@ -1,40 +1,8 @@
FFI_VERSION="1.9.25"
FFI_C_DIR=vendor/bundle/ruby/gems/ffi-${FFI_VERSION}/ext/ffi_c
-build_gems: get_gems
- bundle install --local --deployment
- #ffi makes symlink with absolute path. Let's change it to relative path.
- for fname in `ls ${FFI_C_DIR}/libffi-*/include/ffitarget.h`; do \
- if [[ -L "$$fname" ]]; then \
- target=$$(readlink $$fname | sed "s~.*/${FFI_C_DIR}\(/libffi/src/[^/]\+/ffitarget.h\)~../..\1~"); \
- rm $$fname; \
- ln -s $$target $$fname; \
- fi; \
- done;
-
-build_gems_without_bundler:
- mkdir -p vendor/bundle/ruby
- gem install --verbose --no-rdoc --no-ri -l --ignore-dependencies -i vendor/bundle/ruby \
- vendor/cache/activesupport-5.2.0.gem \
- vendor/cache/backports-3.11.3.gem \
- vendor/cache/concurrent-ruby-1.0.5.gem \
- vendor/cache/ethon-0.11.0.gem \
- vendor/cache/ffi-${FFI_VERSION}.gem \
- vendor/cache/i18n-1.0.1.gem \
- vendor/cache/json-2.1.0.gem \
- vendor/cache/minitest-5.11.3.gem \
- vendor/cache/multi_json-1.13.1.gem \
- vendor/cache/musterman-1.0.2.gem \
- vendor/cache/open4-1.3.4.gem \
- vendor/cache/rack-2.0.5.gem \
- vendor/cache/rack-protection-2.0.3.gem \
- vendor/cache/rack-test-1.0.0.gem \
- vendor/cache/sinatra-2.0.3.gem \
- vendor/cache/sinatra-contrib-2.0.3.gem \
- vendor/cache/thread_safe-0.3.6.gem \
- vendor/cache/tilt-2.0.8.gem \
- vendor/cache/tzinfo-1.2.5.gem \
- -- '--with-ldflags="-Wl,-z,now -Wl,-z,relro"'
+build_gems:
+ echo "no gems"
get_gems:
bundle package
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 259942f3d5cc6d908422ef793213dd9f310a9fbc Mon Sep 17 00:00:00 2001
From 458f280e60d564adbc51a9eda406b014edeea23d Mon Sep 17 00:00:00 2001
From: Ivan Devat <idevat@redhat.com>
Date: Tue, 17 Jul 2018 12:59:17 +0200
Subject: [PATCH 2/2] disable gui
Subject: [PATCH] disable gui
---
pcs/daemon/run.py | 17 +++++++++--------

266
pcs.spec
View File

@ -1,6 +1,6 @@
Name: pcs
Version: 0.10.0.alpha.2
Release: 2%{?dist}
Release: 3%{?dist}
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
# GPLv2: pcs
# ASL 2.0: tornado
@ -11,9 +11,14 @@ Summary: Pacemaker Configuration System
%global pcs_snmp_pkg_name pcs-snmp
%global pyagentx_version 0.4.pcs.2
%global tornado_version 5.0.2
%global bundled_src_dir pcs/bundled
%global pyagentx_version 0.4.pcs.2
%global tornado_version 5.0.2
%global rubygem_tilt_version 2.0.8
%global bundled_src_dir pcs/bundled
%global rubygem_cache_dir pcsd/vendor/cache
%global rubygem_bundle_dir pcsd/vendor/bundle/ruby
# https://fedoraproject.org/wiki/Changes/Avoid_usr_bin_python_in_RPM_Build#Python_bytecompilation
# Enforce python3 because bytecompilation of tornado produced warnings:
# DEPRECATION WARNING: python2 invoked with /usr/bin/python.
@ -26,13 +31,12 @@ Summary: Pacemaker Configuration System
Source0: %{url}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
Source1: pcsd-bundle-config-1
Source11: https://rubygems.org/downloads/tilt-%{rubygem_tilt_version}.gem
Source41: https://github.com/ondrejmular/pyagentx/archive/v%{pyagentx_version}.tar.gz#/pyagentx-%{pyagentx_version}.tar.gz
Source42: https://github.com/tornadoweb/tornado/archive/v%{tornado_version}.tar.gz#/tornado-%{tornado_version}.tar.gz
Patch0: adapt-working-with-ruby-gems-to-fedora.patch
Patch1: disable-gui.patch
Patch2: add-support-for-instalation-without-bundled-gems.patch
Patch3: do-not-use-bundled-ruby-gems.patch
Patch0: disable-gui.patch
# git for patches
BuildRequires: git
@ -61,7 +65,6 @@ BuildRequires: rubygem-rack
BuildRequires: rubygem-rack-protection
BuildRequires: rubygem-rack-test
BuildRequires: rubygem-sinatra
BuildRequires: rubygem-tilt
# ruby libraries for tests
BuildRequires: rubygem-test-unit
# for UpdateTimestamps sanitization function
@ -84,7 +87,11 @@ BuildRequires: pacemaker-cli
# - nothing provides libcib.so.4()(64bit) needed by sbd-1.2.1-4.fc28.1.x86_64
# """
# BuildRequires: fence-agents-all
# BuildRequires: fence-virt
# Use only necessary fence agents
BuildRequires: fence-virt
BuildRequires: fence-agents-apc
BuildRequires: fence-agents-scsi
BuildRequires: fence-agents-ipmilan
BuildRequires: booth-site
# pcsd fonts and font management tools for creating symlinks to fonts
BuildRequires: fontconfig
@ -109,7 +116,6 @@ Requires: rubygem-rack
Requires: rubygem-rack-protection
Requires: rubygem-rack-test
Requires: rubygem-sinatra
Requires: rubygem-tilt
# for killall
Requires: psmisc
# for working with certificates (validation etc.)
@ -128,6 +134,7 @@ Requires: liberation-sans-fonts
Requires: overpass-fonts
Provides: bundled(tornado) = %{tornado_version}
Provides: bundled(rubygem-tilt) = %{rubygem_tilt_version}
%description
pcs is a corosync and pacemaker configuration tool. It permits users to
@ -175,33 +182,53 @@ UpdateTimestamps() {
%patch0 -p1
UpdateTimestamps -p1 %{PATCH0}
UpdateTimestamps -p1 %{PATCH1}
UpdateTimestamps -p1 %{PATCH2}
UpdateTimestamps -p1 %{PATCH3}
# prepare dirs/files necessary for building all bundles
# -----------------------------------------------------
# 1) configuration for rubygems
mkdir -p pcsd/.bundle
cp -f %SOURCE1 pcsd/.bundle/config
# 2) rubygems sources
mkdir -p %{rubygem_cache_dir}
cp -f %SOURCE11 %{rubygem_cache_dir}
# 3) dir for python bundles
mkdir -p %{bundled_src_dir}
# 4) sources for pyagentx
tar -xzf %SOURCE41 -C %{bundled_src_dir}
mv %{bundled_src_dir}/pyagentx-%{pyagentx_version} %{bundled_src_dir}/pyagentx
cp %{bundled_src_dir}/pyagentx/LICENSE.txt pyagentx_LICENSE.txt
cp %{bundled_src_dir}/pyagentx/CONTRIBUTORS.txt pyagentx_CONTRIBUTORS.txt
cp %{bundled_src_dir}/pyagentx/README.md pyagentx_README.md
# 5) sources for tornado
tar -xzf %SOURCE42 -C %{bundled_src_dir}
mv %{bundled_src_dir}/tornado-%{tornado_version} %{bundled_src_dir}/tornado
cp %{bundled_src_dir}/tornado/LICENSE tornado_LICENSE
cp %{bundled_src_dir}/tornado/README.rst tornado_README.rst
%build
%define debug_package %{nil}
%install
rm -rf $RPM_BUILD_ROOT
pwd
# build bundled rubygems (in main install it is disabled by BUILD_GEMS=false)
# comment from 9b7a65231 Mamoru TASAKA:
# So it seems that with rubygems 2.7.3 --install-dir option always
# needs --no-user-install???
mkdir -p %{rubygem_bundle_dir}
gem install \
--force --verbose --no-rdoc --no-ri -l --no-user-install \
-i %{rubygem_bundle_dir} \
%{rubygem_cache_dir}/tilt-%{rubygem_tilt_version}.gem \
# main pcs install
make install \
DESTDIR=$RPM_BUILD_ROOT \
PREFIX=%{PCS_PREFIX} \
@ -210,11 +237,15 @@ make install \
BASH_COMPLETION_DIR=/usr/share/bash-completion/completions \
BUNDLE_PYAGENTX_SRC_DIR=`readlink -f %{bundled_src_dir}/pyagentx` \
BUNDLE_TORNADO_SRC_DIR=`readlink -f %{bundled_src_dir}/tornado` \
BUILD_GEMS=false \
SYSTEMCTL_OVERRIDE=true \
hdrdir="%{_includedir}" \
rubyhdrdir="%{_includedir}" \
includedir="%{_includedir}"
#after the ruby gem compilation we do not need ruby gems in the cache
rm -r -v $RPM_BUILD_ROOT%{PCS_PREFIX}/lib/%{rubygem_cache_dir}
%check
# In the building environment LC_CTYPE is set to C which causes tests to fail
# due to python prints a warning about it to stderr. The following environment
@ -229,7 +260,6 @@ export PYTHONCOERCECLOCALE=0
run_all_tests(){
#prepare environmet for tests
sitelib=$RPM_BUILD_ROOT%{python3_sitelib}
pcsd_dir=$RPM_BUILD_ROOT%{PCS_PREFIX}/lib/pcsd
export PYTHONPATH="${PYTHONPATH}:${sitelib}"
#run pcs tests and remove them, we do not distribute them in the rpm
@ -247,18 +277,6 @@ run_all_tests(){
# not provide valid metadata: error: crm_abort: systemd_unit_exec:
# Triggered fatal assert at systemd.c:728 : systemd_init(), use --force to
# override
# pcs.lib.commands.test.test_resource_agent.DescribeAgentUtf8.test_describe
# For a unknwon reason this test is passing outside the mock environment.
# TODO: Investigate the issue
# all others:
# resource agents metadata have been changed lately, units (seconds) have
# been added to the intervals etc. (e.g.: interval="10" => interval="10s")
#
# All tests that requires fence-agents-all have been disabled.
# See notes above the BuildRequires: fence-agents-all
#
# Tests after pcs.common.test.test_node_communicator.RequestDataUrlEncodeTest.test_with_data
# contains some issues with current pacemaker version
# ======================================================================
# FAIL: test_with_data (pcs.common.test.test_node_communicator.RequestDataUrlEncodeTest)
# ----------------------------------------------------------------------
@ -298,7 +316,9 @@ run_all_tests(){
# + 'has_errors': True}
# ? ^^^
# ======================================================================
# THE SAME CASES:
# FAIL: test_error_if_files_with_bad_content (pcs.daemon.test.test_ssl.Pair)
# FAIL: test_raises_when_ssl_files_are_damaged (pcs.daemon.test.test_ssl.PcsdSSLTest)
# ----------------------------------------------------------------------
# Traceback (most recent call last):
# File "/builddir/build/BUILDROOT/pcs-0.10.0.alpha.1-1.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/daemon/test/test_ssl.py", line 46, in test_error_if_files_with_bad_content
@ -320,27 +340,27 @@ run_all_tests(){
# + "'PEM routines:PEM_read_bio:no start line'"]
# ? ^^^^^ ^^ ^^^
# ======================================================================
# FAIL: test_raises_when_ssl_files_are_damaged (pcs.daemon.test.test_ssl.PcsdSSLTest)
# THE SAME CASES:
# FAIL: test_error_when_not_valid_agent (pcs.test.cib_resource.test_stonith_create.PlainStonith)
# FAIL: test_warning_when_not_valid_agent (pcs.test.cib_resource.test_stonith_create.PlainStonith)
# FAIL: test_nonextisting_agent (pcs.test.test_stonith.StonithDescribeTest)
# FAIL: testStonithCreation (pcs.test.test_stonith.StonithTest)
# ----------------------------------------------------------------------
# Traceback (most recent call last):
# File "/builddir/build/BUILDROOT/pcs-0.10.0.alpha.1-1.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/daemon/test/test_ssl.py", line 81, in test_raises_when_ssl_files_are_damaged
# self.assertEqual(ctx_manager.exception.args, DAMAGED_SSL_FILES_ERRORS)
# AssertionError: Tuples differ: ("Inv[155 chars]ines:get_name:no start line'", "Invalid SSL ke[160 chars]ne'") != ("Inv[155 chars]ines:PEM_read_bio:no start line'", "Invalid SS[168 chars]ne'")
# First differing element 0:
# "Inva[124 chars]ources/daemon.cert': 'PEM routines:get_name:no start line'"
# "Inva[124 chars]ources/daemon.cert': 'PEM routines:PEM_read_bio:no start line'"
# ('Invalid SSL certificate '
# "'/builddir/build/BUILDROOT/pcs-0.10.0.alpha.1-1.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/test/resources/daemon.cert': "
# - "'PEM routines:get_name:no start line'",
# ? ^ ^ ^^^^
# + "'PEM routines:PEM_read_bio:no start line'",
# ? ^^^^^ ^^ ^^^
# 'Invalid SSL key '
# "'/builddir/build/BUILDROOT/pcs-0.10.0.alpha.1-1.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/test/resources/daemon.key': "
# - "'PEM routines:get_name:no start line'")
# ? ^ ^ ^^^^
# + "'PEM routines:PEM_read_bio:no start line'")
# ? ^^^^^ ^^ ^^^
# File "/builddir/build/BUILDROOT/pcs-0.10.0.alpha.2-3.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/test/cib_resource/test_stonith_create.py", line 66, in test_error_when_not_valid_agent
# "$", re.MULTILINE
# File "/builddir/build/BUILDROOT/pcs-0.10.0.alpha.2-3.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/test/tools/assertions.py", line 87, in assert_pcs_fail
# returncode=1
# File "/builddir/build/BUILDROOT/pcs-0.10.0.alpha.2-3.fc29.x86_64/usr/lib/python3.7/site-packages/pcs/test/tools/assertions.py", line 158, in assert_pcs_result
# stdout=stdout,
# AssertionError: Stdout does not match the expected regexp
# command: stonith create S absent
# regexp:
# ^Error: Agent 'absent' is not installed or does not provide valid metadata: Metadata query for stonith:absent failed: (-5|Input/output error), use --force to override
# $ (flags: MULTILINE, UNICODE)
# Full stdout:
# Error: Agent 'absent' is not installed or does not provide valid metadata: Agent absent not found or does not support meta-data: Invalid argument (22)
# Metadata query for stonith:absent failed: Input/output error, use --force to override
# ======================================================================
# FAIL: testLSBResource (pcs.test.test_resource.ResourceTest)
# ----------------------------------------------------------------------
@ -361,159 +381,16 @@ run_all_tests(){
# + Error: invalid resource option 'foo', there are no options allowed, use --force to override
# Full stdout:
# Error: Agent 'lsb:network' is not installed or does not provide valid metadata: Metadata query for lsb:network failed: Input/output error, use --force to override
# ----------------------------------------------------------------------
BUNDLED_LIB_LOCATION=$RPM_BUILD_ROOT%{PCS_PREFIX}/lib/pcs/bundled/packages \
%{__python3} ${sitelib}/pcs/test/suite.py -v --vanilla --all-but \
pcs.test.test_cluster.ClusterTest.testUIDGID \
pcs.test.cib_resource.test_create.Success.test_base_create_with_agent_name_including_systemd_instance \
pcs.lib.commands.test.test_resource_agent.DescribeAgentUtf8.test_describe \
pcs.test.cib_resource.test_create.Bundle.test_success \
pcs.test.cib_resource.test_create.FailOrWarnGroup.test_fail_when_try_use_id_of_another_element \
pcs.test.cib_resource.test_create.Success.test_base_create \
pcs.test.cib_resource.test_create.Success.test_base_create_with_default_ops \
pcs.test.cib_resource.test_create.Success.test_create_disabled \
pcs.test.cib_resource.test_create.Success.test_create_with_trace_options \
pcs.test.cib_resource.test_create.Success.test_with_clone \
pcs.test.cib_resource.test_create.Success.test_with_clone_options \
pcs.test.cib_resource.test_create.Success.test_with_master \
pcs.test.cib_resource.test_create.SuccessClone.test_clone_does_not_overshadow_meta_options \
pcs.test.cib_resource.test_create.SuccessClone.test_clone_does_not_overshadow_operations \
pcs.test.cib_resource.test_create.SuccessClone.test_clone_places_disabled_correctly \
pcs.test.cib_resource.test_create.SuccessGroup.test_with_existing_group \
pcs.test.cib_resource.test_create.SuccessGroup.test_with_group \
pcs.test.cib_resource.test_create.SuccessGroup.test_with_group_with_after \
pcs.test.cib_resource.test_create.SuccessGroup.test_with_group_with_before \
pcs.test.cib_resource.test_create.SuccessMaster.test_disable_is_on_master_element \
pcs.test.cib_resource.test_create.SuccessMaster.test_do_not_steal_primitive_meta_options \
pcs.test.cib_resource.test_create.SuccessMaster.test_put_options_after_master_as_its_meta_fix_1 \
pcs.test.cib_resource.test_create.SuccessOperations.test_completing_monitor_operation \
pcs.test.cib_resource.test_create.SuccessOperations.test_default_ops_only \
pcs.test.cib_resource.test_create.SuccessOperations.test_merging_default_ops_explictly_specified \
pcs.test.cib_resource.test_create.SuccessOperations.test_warn_on_forced_unknown_operation \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_manage_monitor \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_manage_monitor_disabled \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_manage_more \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_manage_nonexistent \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_manage_one \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_unmanage_monitor \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_unmanage_monitor_enabled \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_unmanage_more \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_unmanage_nonexistent \
pcs.test.cib_resource.test_manage_unmanage.ManageUnmanage.test_unmanage_one \
pcs.test.cib_resource.test_operation_add.OperationAdd.test_add_with_OCF_CHECK_LEVEL \
pcs.test.cib_resource.test_operation_add.OperationAdd.test_base_add \
pcs.test.cib_resource.test_operation_add.OperationAdd.test_can_multiple_operation_add \
pcs.test.cib_resource.test_operation_add.OperationAdd.test_id_specified \
pcs.test.test_cluster.ClusterTest.testRemoteNode \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_disallowed_option_appear \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_guest_node_conflicts_with_existing_guest \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_guest_node_conflicts_with_existing_id \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_guest_node_conflicts_with_existing_remote \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_guest_node_name_conflicts_with_existing_remote \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_invalid_interval_appear \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_invalid_port_appear \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_fail_when_option_remote_node_specified \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_success \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_success_when_guest_node_matches_with_existing_guest \
pcs.test.test_cluster_pcmk_remote.NodeAddGuest.test_success_with_options \
pcs.test.test_cluster_pcmk_remote.NodeRemoveGuest.test_success_remove_by_node_name \
pcs.test.test_cluster_pcmk_remote.NodeRemoveGuest.test_success_remove_by_resource_host \
pcs.test.test_cluster_pcmk_remote.NodeRemoveGuest.test_success_remove_by_resource_id \
pcs.test.test_resource.CloneMasterUpdate.test_no_op_allowed_in_clone_update \
pcs.test.test_resource.CloneMasterUpdate.test_no_op_allowed_in_master_update \
pcs.test.test_resource.ResourceTest.testAddOperation \
pcs.test.test_resource.ResourceTest.testAddResourcesLargeCib \
pcs.test.test_resource.ResourceTest.testCloneMaster \
pcs.test.test_resource.ResourceTest.testCloneRemove \
pcs.test.test_resource.ResourceTest.testClonedGroup \
pcs.test.test_resource.ResourceTest.testClonedMasteredGroup \
pcs.test.test_resource.ResourceTest.testGroupRemoveTest \
pcs.test.test_resource.ResourceTest.testGroupRemoveWithConstraints2 \
pcs.test.test_resource.ResourceTest.testMSGroup \
pcs.test.test_resource.ResourceTest.testMasteredGroup \
pcs.test.test_resource.ResourceTest.testNoMoveMSClone \
pcs.test.test_resource.ResourceTest.testOPOption \
pcs.test.test_resource.ResourceTest.testResourceCloneId \
pcs.test.test_resource.ResourceTest.testResourceCloneUpdate \
pcs.test.test_resource.ResourceTest.testResourceEnable \
pcs.test.test_resource.ResourceTest.testResourceEnableClone \
pcs.test.test_resource.ResourceTest.testResourceMasterId \
pcs.test.test_resource.ResourceTest.testResourceMissingValues \
pcs.test.test_resource.ResourceTest.testUnclone \
pcs.test.test_resource.ResourceTest.testUpdateOperation \
pcs.test.cib_resource.test_stonith_create.PlainStonith.test_base_with_agent_that_provides_unfencing \
pcs.test.cib_resource.test_stonith_create.PlainStonith.test_debug_and_verbose_allowed \
pcs.test.cib_resource.test_stonith_create.PlainStonith.test_error_when_not_valid_agent \
pcs.test.cib_resource.test_stonith_create.PlainStonith.test_warning_when_not_valid_agent \
pcs.test.cib_resource.test_stonith_create.WithMeta.test_base_with_agent_that_provides_unfencing_with_meta_provides \
pcs.test.test_status.StonithWarningTest.test_stonith_warnings \
pcs.test.test_status.StonithWarningTest.test_warning_stonith_action \
pcs.test.test_status.StonithWarningTest.test_warning_stonith_method_cycle \
pcs.test.test_stonith.LevelAdd.test_add_bad_level \
pcs.test.test_stonith.LevelAdd.test_add_level_leading_zero \
pcs.test.test_stonith.LevelAdd.test_add_more_devices \
pcs.test.test_stonith.LevelAdd.test_add_more_devices_old_syntax \
pcs.test.test_stonith.LevelAdd.test_add_node \
pcs.test.test_stonith.LevelAdd.test_add_node_attribute \
pcs.test.test_stonith.LevelAdd.test_add_node_pattern \
pcs.test.test_stonith.LevelAdd.test_nonexistant_devices \
pcs.test.test_stonith.LevelAdd.test_nonexistant_node \
pcs.test.test_stonith.LevelAddTargetUpgradesCib.test_attribute \
pcs.test.test_stonith.LevelAddTargetUpgradesCib.test_regexp \
pcs.test.test_stonith.LevelClear.test_clear_all \
pcs.test.test_stonith.LevelClear.test_clear_attribute \
pcs.test.test_stonith.LevelClear.test_clear_device \
pcs.test.test_stonith.LevelClear.test_clear_devices \
pcs.test.test_stonith.LevelClear.test_clear_node \
pcs.test.test_stonith.LevelClear.test_clear_nonexistant_devices \
pcs.test.test_stonith.LevelClear.test_clear_nonexistant_node_or_device \
pcs.test.test_stonith.LevelClear.test_clear_pattern \
pcs.test.test_stonith.LevelClear.test_pattern_is_not_device \
pcs.test.test_stonith.LevelConfig.test_all_posibilities \
pcs.test.test_stonith.LevelRemove.test_nonexisting_level \
pcs.test.test_stonith.LevelRemove.test_nonexisting_level_node_device \
pcs.test.test_stonith.LevelRemove.test_nonexisting_level_pattern_device \
pcs.test.test_stonith.LevelRemove.test_remove_level \
pcs.test.test_stonith.LevelRemove.test_remove_level_attrib \
pcs.test.test_stonith.LevelRemove.test_remove_level_attrib_device \
pcs.test.test_stonith.LevelRemove.test_remove_level_device \
pcs.test.test_stonith.LevelRemove.test_remove_level_devices \
pcs.test.test_stonith.LevelRemove.test_remove_level_devices_old_syntax \
pcs.test.test_stonith.LevelRemove.test_remove_level_node \
pcs.test.test_stonith.LevelRemove.test_remove_level_node_device \
pcs.test.test_stonith.LevelRemove.test_remove_level_pattern \
pcs.test.test_stonith.LevelRemove.test_remove_level_pattern_device \
pcs.test.test_stonith.LevelVerify.test_errors \
pcs.test.test_stonith.LevelVerify.test_success \
pcs.test.test_stonith.StonithDescribeTest.test_full \
pcs.test.test_stonith.StonithDescribeTest.test_nonextisting_agent \
pcs.test.test_stonith.StonithDescribeTest.test_success \
pcs.test.test_stonith.StonithTest.testNoStonithWarning \
pcs.test.test_stonith.StonithTest.testPcmkHostAllowsMissingPort \
pcs.test.test_stonith.StonithTest.testPcmkHostList \
pcs.test.test_stonith.StonithTest.testStonithCreation \
pcs.test.test_stonith.StonithTest.testStonithDeleteRemovesLevel \
pcs.test.test_stonith.StonithTest.test_stonith_create_action \
pcs.test.test_stonith.StonithTest.test_stonith_create_action_empty \
pcs.test.test_stonith.StonithTest.test_stonith_create_provides_unfencing \
pcs.test.test_stonith.StonithTest.test_stonith_update_action \
pcs.daemon.test.test_app_gui.Login.test_get_uses_wrapper \
pcs.daemon.test.test_app_gui.Login.test_login_attempt_failed \
pcs.daemon.test.test_app_gui.Login.test_login_attempt_failed_ajax \
pcs.daemon.test.test_app_gui.Login.test_login_attempt_succeeded \
pcs.daemon.test.test_app_gui.Login.test_login_attempt_succeeded_ajax \
pcs.daemon.test.test_app_gui.LoginStatus.test_authenticated \
pcs.daemon.test.test_app_gui.LoginStatus.test_not_authenticated \
pcs.daemon.test.test_app_gui.Logout.test_no_ajax \
pcs.daemon.test.test_app_gui.Logout.test_with_ajax \
pcs.daemon.test.test_app_gui.SinatraAjaxProtected.test_deal_without_ajax \
pcs.daemon.test.test_app_gui.SinatraAjaxProtected.test_deal_without_authentication \
pcs.daemon.test.test_app_gui.SinatraAjaxProtected.test_take_result_from_ruby \
pcs.daemon.test.test_app_gui.SinatraGuiProtected.test_no_logged_redirects_to_login \
pcs.daemon.test.test_app_gui.SinatraGuiProtected.test_take_result_from_ruby \
pcs.daemon.test.test_app_gui.Static.test_css \
pcs.common.test.test_node_communicator.RequestDataUrlEncodeTest.test_with_data \
pcs.daemon.test.test_env.Prepare.test_report_invalid_ssl_ciphers \
pcs.daemon.test.test_ssl.Pair.test_error_if_files_with_bad_content \
@ -526,8 +403,8 @@ run_all_tests(){
find ${sitelib}/pcs -name test -type d -print0|xargs -0 rm -r -v --
#run pcsd tests and remove them
#GEM_HOME is not needed anymore since all required gems are in fedora
ruby \
pcsd_dir=$RPM_BUILD_ROOT%{PCS_PREFIX}/lib/pcsd
GEM_HOME=$RPM_BUILD_ROOT%{PCS_PREFIX}%{rubygem_bundle_dir} ruby \
-I${pcsd_dir} \
-I${pcsd_dir}/test \
${pcsd_dir}/test/test_all_suite.rb
@ -608,6 +485,9 @@ run_all_tests
/usr/share/snmp/mibs/PCMK-PCS*-MIB.txt
%{_mandir}/man8/pcs_snmp_agent.*
%config(noreplace) /etc/sysconfig/pcs_snmp_agent
# The creation of /var/log/pcs is removed in the upstream (/var/log/pcsd is used
# instead) but this change is not in this build yet. If your build fails
# because of missing /var/log/pcs feel free to remove it.
%dir /var/log/pcs
%doc CHANGELOG.md
%doc pyagentx_CONTRIBUTORS.txt
@ -616,6 +496,10 @@ run_all_tests
%license pyagentx_LICENSE.txt
%changelog
* Fri Aug 31 2018 Ivan Devát <idevat@redhat.com> - 0.10.0.alpha.2-3
- Started bundling rubygem-tilt (rubygem-tilt is orphaned in fedora due to rubygem-prawn dependency)
- Enabled passing tests
* Sat Aug 25 2018 Ivan Devát <idevat@redhat.com> - 0.10.0.alpha.2-2
- Fixed error with missing rubygem location during pcsd start
- Resolves: rhbz#1618911

View File

@ -2,3 +2,4 @@ SHA512 (pcsd-bundle-config-1) = f2a2df2dab39c2012cc6a91517716dde8f5a48788d1069c4
SHA512 (pyagentx-0.4.pcs.2.tar.gz) = d4194fec9a3e5fefe3793d49b7fec1feafef294c7e613a06046c2993daeefc5cb39d7c5b2b402ff83e49b2d976953f862264288c758c0be09d997b5323cc558a
SHA512 (tornado-5.0.2.tar.gz) = 8e6d2757ef4179fc8f23efa63f6b22e5c303a8a1da1efda6a8df4a2acc22f0e67bed2ca504eac82c491c5bd0a087f9dcc76c4b6bd27afdf2fdc8c988f1dc1096
SHA512 (pcs-0.10.0.alpha.2.tar.gz) = da840a9b06cec6e0d0dc4aa1f8bf9180603470ffb62f94dc6c21112a44dcee70cc22ebd01a414c9614590faba724abf25cc0ec0718635d775316f0817f016bd1
SHA512 (tilt-2.0.8.gem) = 1767f2e5ce45afe95d84d32de7c2b6fe24ff7cb6f7ee8485d84344820b2f6e969ae60a6fbaa7141f7fe135c6540d96fa5b27fd8010b95c0ded5d049a315001d5