Resolves: rhbz#1975440 rhbz#1922302

- Rebased to latest upstream sources (see CHANGELOG.md)
- Fixed web-ui build
- Fixed tests for pacemaker 2.1
This commit is contained in:
Miroslav Lisik 2021-07-20 17:39:21 +02:00
parent 344f9d3a5e
commit 7f6f36fe26
6 changed files with 44 additions and 197 deletions

2
.gitignore vendored
View File

@ -137,3 +137,5 @@
/pcs-web-ui-node-modules-0.1.6.tar.xz
/pcs-web-ui-0.1.6.tar.gz
/pcs-0.10.8.181-47e9.tar.gz
/pcs-web-ui-node-modules-0.1.6-fips-fix.tar.xz
/pcs-0.10.8.210-9862.tar.gz

View File

@ -1,13 +1,12 @@
From ce297f2852fc1b67ac37d4074c1d2a646d7e8bd1 Mon Sep 17 00:00:00 2001
From e6541ff3ef4ae54f48331cde70a75f49b5bc526d Mon Sep 17 00:00:00 2001
From: Tomas Jelinek <tojeline@redhat.com>
Date: Mon, 14 Jun 2021 11:39:14 +0200
Subject: [PATCH 1/2] remove clufter commands
---
.gitlab-ci.yml | 1 -
Makefile.am | 4 +-
README.md | 2 -
configure.ac | 5 -
configure.ac | 9 +-
mypy.ini | 6 -
pcs/cli/common/parse_args.py | 4 -
pcs/cli/routing/config.py | 14 -
@ -20,22 +19,10 @@ Subject: [PATCH 1/2] remove clufter commands
pcsd/Makefile.am | 1 -
pcsd/test/cluster.conf | 27 --
rpm/pcs.spec.in | 15 -
16 files changed, 1 insertion(+), 490 deletions(-)
15 files changed, 3 insertions(+), 491 deletions(-)
delete mode 100644 pcs_test/resources/cluster.conf
delete mode 100644 pcsd/test/cluster.conf
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 8a36b509..6602ea46 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -5,7 +5,6 @@ variables:
python3-cryptography
python3-dateutil
python3-devel
- python3-distro
python3-lxml
python3-pip
python3-pycurl
diff --git a/Makefile.am b/Makefile.am
index 6a7cc553..cba77d8d 100644
--- a/Makefile.am
@ -75,21 +62,25 @@ index efca6deb..85ab1099 100644
fonts-liberation2)
* overpass fonts (package overpass-fonts)
diff --git a/configure.ac b/configure.ac
index 39ce5f36..60605c08 100644
index a86f04a2..e82024ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,11 +304,6 @@ if test "$PYTHON_VERSION" = "3.6"; then
PCS_CHECK_PYMOD([dataclasses], [], [yes])
fi
@@ -316,13 +316,8 @@ if test "x$tests_only" != "xyes"; then
PCS_CHECK_PYMOD([dataclasses], [], [yes])
fi
-# python 3.8+ needs distro as well (removed from upstream lib)
-if printf '%s\n%s\n' "3.8" "$PYTHON_VERSION" | sort -V -C; then
- PCS_CHECK_PYMOD([distro], [], [yes])
-fi
- # python 3.8+ needs distro as well (removed from upstream lib)
- if printf '%s\n%s\n' "3.8" "$PYTHON_VERSION" | sort -V -C; then
- PCS_CHECK_PYMOD([distro], [], [yes])
- fi
-
# special case, because we need to download from github
AC_PIP_MODULE([pyagentx])
- # special case, because we need to download from github
- AC_PIP_MODULE([pyagentx])
+# special case, because we need to download from github
+AC_PIP_MODULE([pyagentx])
if test "x$HAVE_PIPMOD_PYAGENTX" = "xno" && test "x$local_build" != "xyes"; then
AC_MSG_ERROR([Python module pyagentx not found])
diff --git a/mypy.ini b/mypy.ini
index 33d1e469..f3246735 100644
--- a/mypy.ini
@ -158,7 +149,7 @@ index 5d2663bd..7f878f4d 100644
["config"],
default_cmd="show",
diff --git a/pcs/config.py b/pcs/config.py
index 8e37fc4b..521af8fd 100644
index 71b28c13..a0290499 100644
--- a/pcs/config.py
+++ b/pcs/config.py
@@ -7,7 +7,6 @@ from io import BytesIO
@ -564,10 +555,10 @@ index 8e37fc4b..521af8fd 100644
- )
- sys.exit(1 if result is None else result)
diff --git a/pcs/pcs.8.in b/pcs/pcs.8.in
index 205fdc4e..b72c2197 100644
index f9b5014a..6347a9d5 100644
--- a/pcs/pcs.8.in
+++ b/pcs/pcs.8.in
@@ -1382,5 +1382,3 @@ http://clusterlabs.org/doc/
@@ -1427,5 +1427,3 @@ http://clusterlabs.org/doc/
.BR boothd (8),
.BR sbd (8)
@ -588,10 +579,10 @@ index 6df12997..68b18a53 100644
pacemaker_local_state_dir = os.path.join(
"/", "@PCMKLOCALSTATEDIR@", "lib/pacemaker"
diff --git a/pcs_test/Makefile.am b/pcs_test/Makefile.am
index 7cd077f3..b73eb40c 100644
index 242feee0..4c4eb532 100644
--- a/pcs_test/Makefile.am
+++ b/pcs_test/Makefile.am
@@ -23,7 +23,6 @@ EXTRA_DIST = \
@@ -16,7 +16,6 @@ EXTRA_DIST = \
resources/cib-largefile.xml \
resources/cib-large.xml \
resources/cib-tags.xml \

View File

@ -1,4 +1,4 @@
From 720dc101a5038870b47492f2f6735e93ba2b20fb Mon Sep 17 00:00:00 2001
From 28ea2d88ffd6f67e9ef96afa3d38ef252148947e Mon Sep 17 00:00:00 2001
From: Ivan Devat <idevat@redhat.com>
Date: Tue, 20 Nov 2018 15:03:56 +0100
Subject: [PATCH 2/2] do not support cluster setup with udp(u) transport in
@ -11,10 +11,10 @@ Subject: [PATCH 2/2] do not support cluster setup with udp(u) transport in
3 files changed, 6 insertions(+)
diff --git a/pcs/pcs.8.in b/pcs/pcs.8.in
index b72c2197..020d669c 100644
index 6347a9d5..5279c4ca 100644
--- a/pcs/pcs.8.in
+++ b/pcs/pcs.8.in
@@ -420,6 +420,8 @@ By default, encryption is enabled with cipher=aes256 and hash=sha256. To disable
@@ -426,6 +426,8 @@ By default, encryption is enabled with cipher=aes256 and hash=sha256. To disable
Transports udp and udpu:
.br
@ -24,10 +24,10 @@ index b72c2197..020d669c 100644
.br
Transport options are: ip_version, netmtu
diff --git a/pcs/usage.py b/pcs/usage.py
index cec99ef2..45e0ebed 100644
index 2b967e6b..ac543502 100644
--- a/pcs/usage.py
+++ b/pcs/usage.py
@@ -853,6 +853,7 @@ Commands:
@@ -863,6 +863,7 @@ Commands:
hash=sha256. To disable encryption, set cipher=none and hash=none.
Transports udp and udpu:

View File

@ -1,151 +0,0 @@
From e5781d95faae560f46ea56525d67eeb36b244a36 Mon Sep 17 00:00:00 2001
From: Ivan Devat <idevat@redhat.com>
Date: Thu, 10 Jun 2021 14:52:15 +0200
Subject: [PATCH 1/3] fix wrong name for library command
---
pcs/cli/common/lib_wrapper.py | 8 ++++----
pcs/cli/constraint_colocation/command.py | 2 +-
pcs/cli/constraint_order/command.py | 4 +++-
pcs/cli/constraint_ticket/command.py | 4 ++--
pcs_test/tier0/cli/common/test_lib_wrapper.py | 6 +++---
pcs_test/tier0/cli/constraint_ticket/test_command.py | 8 ++++----
6 files changed, 17 insertions(+), 15 deletions(-)
diff --git a/pcs/cli/common/lib_wrapper.py b/pcs/cli/common/lib_wrapper.py
index d9a6bd26..c41ce875 100644
--- a/pcs/cli/common/lib_wrapper.py
+++ b/pcs/cli/common/lib_wrapper.py
@@ -230,7 +230,7 @@ def load_module(env, middleware_factory, name):
env,
middleware.build(middleware_factory.cib),
{
- "set": constraint_colocation.create_with_set,
+ "create_with_set": constraint_colocation.create_with_set,
"show": constraint_colocation.show,
},
)
@@ -240,7 +240,7 @@ def load_module(env, middleware_factory, name):
env,
middleware.build(middleware_factory.cib),
{
- "set": constraint_order.create_with_set,
+ "create_with_set": constraint_order.create_with_set,
"show": constraint_order.show,
},
)
@@ -250,9 +250,9 @@ def load_module(env, middleware_factory, name):
env,
middleware.build(middleware_factory.cib),
{
- "set": constraint_ticket.create_with_set,
+ "create_with_set": constraint_ticket.create_with_set,
"show": constraint_ticket.show,
- "add": constraint_ticket.create,
+ "create": constraint_ticket.create,
"remove": constraint_ticket.remove,
},
)
diff --git a/pcs/cli/constraint_colocation/command.py b/pcs/cli/constraint_colocation/command.py
index f5cf91ab..10539aa6 100644
--- a/pcs/cli/constraint_colocation/command.py
+++ b/pcs/cli/constraint_colocation/command.py
@@ -18,7 +18,7 @@ def create_with_set(lib, argv, modifiers):
"""
modifiers.ensure_only_supported("-f", "--force")
command.create_with_set(
- lib.constraint_colocation.set,
+ lib.constraint_colocation.create_with_set,
argv,
modifiers,
)
diff --git a/pcs/cli/constraint_order/command.py b/pcs/cli/constraint_order/command.py
index 04a49c8e..7251a4a7 100644
--- a/pcs/cli/constraint_order/command.py
+++ b/pcs/cli/constraint_order/command.py
@@ -17,7 +17,9 @@ def create_with_set(lib, argv, modifiers):
* -f - CIB file
"""
modifiers.ensure_only_supported("--force", "-f")
- command.create_with_set(lib.constraint_order.set, argv, modifiers)
+ command.create_with_set(
+ lib.constraint_order.create_with_set, argv, modifiers
+ )
def show(lib, argv, modifiers):
diff --git a/pcs/cli/constraint_ticket/command.py b/pcs/cli/constraint_ticket/command.py
index 7823981e..b4cd2bcd 100644
--- a/pcs/cli/constraint_ticket/command.py
+++ b/pcs/cli/constraint_ticket/command.py
@@ -20,7 +20,7 @@ def create_with_set(lib, argv, modifiers):
"""
modifiers.ensure_only_supported("--force", "-f")
command.create_with_set(
- lib.constraint_ticket.set,
+ lib.constraint_ticket.create_with_set,
argv,
modifiers,
)
@@ -50,7 +50,7 @@ def add(lib, argv, modifiers):
if resource_role:
options["rsc-role"] = resource_role
- lib.constraint_ticket.add(
+ lib.constraint_ticket.create(
ticket,
resource_id,
options,
diff --git a/pcs_test/tier0/cli/common/test_lib_wrapper.py b/pcs_test/tier0/cli/common/test_lib_wrapper.py
index 3a8188c6..33538685 100644
--- a/pcs_test/tier0/cli/common/test_lib_wrapper.py
+++ b/pcs_test/tier0/cli/common/test_lib_wrapper.py
@@ -25,8 +25,8 @@ class LibraryWrapperTest(TestCase):
mock_middleware_factory.cib = dummy_middleware
mock_middleware_factory.corosync_conf_existing = dummy_middleware
mock_env = mock.MagicMock()
- Library(mock_env, mock_middleware_factory).constraint_order.set(
- "first", second="third"
- )
+ Library(
+ mock_env, mock_middleware_factory
+ ).constraint_order.create_with_set("first", second="third")
mock_order_set.assert_called_once_with(lib_env, "first", second="third")
diff --git a/pcs_test/tier0/cli/constraint_ticket/test_command.py b/pcs_test/tier0/cli/constraint_ticket/test_command.py
index 118bfa22..ca4835c3 100644
--- a/pcs_test/tier0/cli/constraint_ticket/test_command.py
+++ b/pcs_test/tier0/cli/constraint_ticket/test_command.py
@@ -24,12 +24,12 @@ class AddTest(TestCase):
)
lib = mock.MagicMock()
lib.constraint_ticket = mock.MagicMock()
- lib.constraint_ticket.add = mock.MagicMock()
+ lib.constraint_ticket.create = mock.MagicMock()
command.add(lib, ["argv"], _modifiers())
mock_parse_add.assert_called_once_with(["argv"])
- lib.constraint_ticket.add.assert_called_once_with(
+ lib.constraint_ticket.create.assert_called_once_with(
"ticket",
"resource_id",
{"loss-policy": "fence"},
@@ -60,12 +60,12 @@ class AddTest(TestCase):
)
lib = mock.MagicMock()
lib.constraint_ticket = mock.MagicMock()
- lib.constraint_ticket.add = mock.MagicMock()
+ lib.constraint_ticket.create = mock.MagicMock()
command.add(lib, ["argv"], _modifiers())
mock_parse_add.assert_called_once_with(["argv"])
- lib.constraint_ticket.add.assert_called_once_with(
+ lib.constraint_ticket.create.assert_called_once_with(
"ticket",
"resource_id",
{"loss-policy": "fence", "rsc-role": "resource_role"},
--
2.31.1

View File

@ -1,6 +1,6 @@
Name: pcs
Version: 0.10.8
Release: 9%{?dist}
Release: 10%{?dist}
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
# GPLv2: pcs
@ -19,13 +19,13 @@ Summary: Pacemaker Configuration System
ExclusiveArch: i686 x86_64 s390x ppc64le aarch64
# %%global version_or_commit %%{version}
%global version_or_commit %{version}.181-47e9
%global version_or_commit %{version}.210-9862
%global pcs_source_name %{name}-%{version_or_commit}
# ui_commit can be determined by hash, tag or branch
%global ui_commit 0.1.6
%global ui_modules_version 0.1.6
%global ui_modules_version 0.1.6-fips-fix
%global ui_src_name pcs-web-ui-%{ui_commit}
%global pcs_snmp_pkg_name pcs-snmp
@ -104,15 +104,14 @@ Source96: https://rubygems.org/downloads/ruby2_keywords-%{version_rubygem_ruby2_
Source97: https://rubygems.org/downloads/webrick-%{version_rubygem_webrick}.gem
Source100: https://github.com/idevat/pcs-web-ui/archive/%{ui_commit}/%{ui_src_name}.tar.gz
Source101: https://github.com/idevat/pcs-web-ui/releases/download/%{ui_modules_version}/pcs-web-ui-node-modules-%{ui_modules_version}.tar.xz
Source101: https://github.com/idevat/pcs-web-ui/releases/download/%{ui_commit}/pcs-web-ui-node-modules-%{ui_modules_version}.tar.xz
# Patches from upstream.
# They should come before downstream patches to avoid unnecessary conflicts.
# Z-streams are exception here: they can come from upstream but should be
# applied at the end to keep z-stream changes as straightforward as possible.
# Patch1: bzNUMBER-01-name.patch
Patch1: fix-wrong-name-for-library-command.patch
Patch2: bz1881064-01-remove-clufter-commands.patch
Patch1: bz1881064-01-remove-clufter-commands.patch
# Downstream patches do not come from upstream. They adapt pcs for specific
# RHEL needs.
@ -303,7 +302,6 @@ update_times_patch(){
}
update_times_patch %{PATCH1}
update_times_patch %{PATCH2}
update_times_patch %{PATCH101}
cp -f %SOURCE1 %{pcsd_public_dir}/images
@ -347,7 +345,8 @@ cp -f %SOURCE44 rpm/
%define debug_package %{nil}
./autogen.sh
%{configure} --enable-local-build --enable-use-local-cache-only PYTHON=%{__python3}
# TODO: use --enable-individual-bundling when fixed in upstream
%{configure} --enable-local-build --enable-use-local-cache-only --enable-invidual-bundling PYTHON=%{__python3}
make all
%install
@ -556,6 +555,12 @@ remove_all_tests
%license pyagentx_LICENSE.txt
%changelog
* Tue Jul 20 2021 Miroslav Lisik <mlisik@redhat.com> - 0.10.8-10
- Rebased to latest upstream sources (see CHANGELOG.md)
- Fixed web-ui build
- Fixed tests for pacemaker 2.1
- Resolves: rhbz#1975440 rhbz#1922302
* Tue Jun 22 2021 Mohan Boddu <mboddu@redhat.com> - 0.10.8-9
- Rebuilt for RHEL 9 BETA for openssl 3.0
Related: rhbz#1971065

View File

@ -1,6 +1,5 @@
SHA512 (pyagentx-0.4.pcs.2.tar.gz) = d4194fec9a3e5fefe3793d49b7fec1feafef294c7e613a06046c2993daeefc5cb39d7c5b2b402ff83e49b2d976953f862264288c758c0be09d997b5323cc558a
SHA512 (open4-1.3.4-1.gem) = 838a18efcd093d55d9589ff9d5c11054618abef863224c2d9b31445dc735218c2f96d954040e2d3f8d5aab0140e54b627fcc4a1b01c17e59267402a2abdd8efb
SHA512 (pcs-web-ui-node-modules-0.1.6.tar.xz) = 30e9d2aa65e199e05a756ed01b549f33766cd28eaaeda40ed5218f791cbfdefc16bdcc6c9a309bddecf750c562de571634680ce39af3fb4e6045294061d789bf
SHA512 (pcs-web-ui-0.1.6.tar.gz) = d5361155e943330d489fbc69442777a0c45d6fec12894a6b2158e0ad583d2fd2307a13615d39a770352c4c37473919b5e13c8d13e84cd4b778ac719de51c6c20
SHA512 (daemons-1.3.1.gem) = eede065019b5e251e5b7d0959251c8591ec8c38ada6861a1c41cf85959666a4865efc69178f63bf2acfc1e993c8222d581ac5d689be439744ee3cef0ca6f5138
SHA512 (eventmachine-1.2.7.gem) = fdbcf9fc933e2414e70f8f48153e9ba6ed7a0029cdf49cdcb4ab72ab26683e727a36c099f017f20681f9c361179461743e501278ca9bd5612e693e26867cc516
@ -19,4 +18,5 @@ SHA512 (tornado-6.1.0.tar.gz) = bd161a1c30f40f983d608297bca113735cb4baad255de713
SHA512 (dacite-1.6.0.tar.gz) = 034255f095589d309fe5805413d8b148f430cd20a0de305b7954083b530d516da1d8f3f00ebb5264a8cfb77f2b2a76f1e2d863e78bd191f1d85021c5553815da
SHA512 (webrick-1.7.0.gem) = 5f242b50300046fe7c22ecd1640a73e5815e05a72bedfebe6bc39c24c92bd61abdd180860de0d194c0eebbc640b507b6892de181d3b577c5372ace0ca6faf2a3
SHA512 (rexml-3.2.5.gem) = 1e3838d4a5befa76137fb8fea6a20195490645aa2b1c5d14d1eeca6c093d7f64eb405f07fd07b00fcafa9606dc78f9f0a488012338f81414623feb6e8cb83931
SHA512 (pcs-0.10.8.181-47e9.tar.gz) = 8a2e6109690f74363d964ba5a046d56b3c99e21e119bccfdf926e27db7be196e90e699ad8c7a80c3eba26e6fef91c8048c4afc7b10657cb1ef30731e88ba3f72
SHA512 (pcs-web-ui-node-modules-0.1.6-fips-fix.tar.xz) = a209c3acac3a992627c146c75e9ebdbc735b38ba8f98935377694b8c13e4318ee5059c75833962cf188fc963ecefe68a6762daf7b4499c54538b1493cc0d712e
SHA512 (pcs-0.10.8.210-9862.tar.gz) = 195f568f96c32019910d35e11141f987c0b3547cc6dd9135a1e5d045d91429685150ee68f4bd5f66285f2d4ab0bc19cb986bd9f2bbdfb52787890e41b684f74f