Resolves: rhbz#1991957
- Rebased to latest upstream sources (see CHANGELOG.md)
This commit is contained in:
parent
82387e7266
commit
75118b25a4
1
.gitignore
vendored
1
.gitignore
vendored
@ -139,3 +139,4 @@
|
||||
/pcs-0.10.8.181-47e9.tar.gz
|
||||
/pcs-web-ui-node-modules-0.1.6-fips-fix.tar.xz
|
||||
/pcs-0.10.8.210-9862.tar.gz
|
||||
/pcs-0.10.9.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From e6541ff3ef4ae54f48331cde70a75f49b5bc526d Mon Sep 17 00:00:00 2001
|
||||
From 5a117f6dc584ce42150c24375491c043959664bb Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Jelinek <tojeline@redhat.com>
|
||||
Date: Mon, 14 Jun 2021 11:39:14 +0200
|
||||
Subject: [PATCH 1/2] remove clufter commands
|
||||
@ -62,7 +62,7 @@ index efca6deb..85ab1099 100644
|
||||
fonts-liberation2)
|
||||
* overpass fonts (package overpass-fonts)
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a86f04a2..e82024ff 100644
|
||||
index ab92f780..5fd89a92 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -316,13 +316,8 @@ if test "x$tests_only" != "xyes"; then
|
||||
@ -82,10 +82,10 @@ index a86f04a2..e82024ff 100644
|
||||
if test "x$HAVE_PIPMOD_PYAGENTX" = "xno" && test "x$local_build" != "xyes"; then
|
||||
AC_MSG_ERROR([Python module pyagentx not found])
|
||||
diff --git a/mypy.ini b/mypy.ini
|
||||
index 33d1e469..f3246735 100644
|
||||
index 66d9109c..2d9cb7e8 100644
|
||||
--- a/mypy.ini
|
||||
+++ b/mypy.ini
|
||||
@@ -123,15 +123,9 @@ ignore_errors = True
|
||||
@@ -127,15 +127,9 @@ ignore_errors = True
|
||||
|
||||
|
||||
# External libraries
|
||||
@ -102,10 +102,10 @@ index 33d1e469..f3246735 100644
|
||||
ignore_errors = True
|
||||
ignore_missing_imports = True
|
||||
diff --git a/pcs/cli/common/parse_args.py b/pcs/cli/common/parse_args.py
|
||||
index e3c829c7..767fdf7f 100644
|
||||
index fa6c0a8a..ce28f58b 100644
|
||||
--- a/pcs/cli/common/parse_args.py
|
||||
+++ b/pcs/cli/common/parse_args.py
|
||||
@@ -27,8 +27,6 @@ PCS_LONG_OPTIONS = [
|
||||
@@ -28,8 +28,6 @@ PCS_LONG_OPTIONS = [
|
||||
"fullhelp",
|
||||
"force",
|
||||
"skip-offline",
|
||||
@ -114,7 +114,7 @@ index e3c829c7..767fdf7f 100644
|
||||
"autodelete",
|
||||
"simulate",
|
||||
"all",
|
||||
@@ -464,8 +462,6 @@ class InputModifiers:
|
||||
@@ -476,8 +474,6 @@ class InputModifiers:
|
||||
# used only in deprecated 'pcs resource|stonith show'
|
||||
"--groups": "--groups" in options,
|
||||
"--hide-inactive": "--hide-inactive" in options,
|
||||
@ -555,10 +555,10 @@ index 71b28c13..a0290499 100644
|
||||
- )
|
||||
- sys.exit(1 if result is None else result)
|
||||
diff --git a/pcs/pcs.8.in b/pcs/pcs.8.in
|
||||
index f9b5014a..6347a9d5 100644
|
||||
index ac093d69..0428f81c 100644
|
||||
--- a/pcs/pcs.8.in
|
||||
+++ b/pcs/pcs.8.in
|
||||
@@ -1427,5 +1427,3 @@ http://clusterlabs.org/doc/
|
||||
@@ -1430,5 +1430,3 @@ http://clusterlabs.org/doc/
|
||||
|
||||
.BR boothd (8),
|
||||
.BR sbd (8)
|
||||
@ -579,7 +579,7 @@ index 6df12997..68b18a53 100644
|
||||
pacemaker_local_state_dir = os.path.join(
|
||||
"/", "@PCMKLOCALSTATEDIR@", "lib/pacemaker"
|
||||
diff --git a/pcs_test/Makefile.am b/pcs_test/Makefile.am
|
||||
index 242feee0..4c4eb532 100644
|
||||
index 708e9658..cfe53a40 100644
|
||||
--- a/pcs_test/Makefile.am
|
||||
+++ b/pcs_test/Makefile.am
|
||||
@@ -16,7 +16,6 @@ EXTRA_DIST = \
|
||||
@ -624,7 +624,7 @@ index 19889712..00000000
|
||||
- </rm>
|
||||
-</cluster>
|
||||
diff --git a/pcs_test/tier0/cli/common/test_parse_args.py b/pcs_test/tier0/cli/common/test_parse_args.py
|
||||
index 493461bd..2739a9d3 100644
|
||||
index 9dbe2394..745433ea 100644
|
||||
--- a/pcs_test/tier0/cli/common/test_parse_args.py
|
||||
+++ b/pcs_test/tier0/cli/common/test_parse_args.py
|
||||
@@ -603,8 +603,6 @@ class InputModifiersTest(TestCase):
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 28ea2d88ffd6f67e9ef96afa3d38ef252148947e Mon Sep 17 00:00:00 2001
|
||||
From 359e786e6f5036a581db9786352325bd1cd0bfef Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Devat <idevat@redhat.com>
|
||||
Date: Tue, 20 Nov 2018 15:03:56 +0100
|
||||
Subject: [PATCH 2/2] do not support cluster setup with udp(u) transport in
|
||||
@ -11,10 +11,10 @@ Subject: [PATCH 2/2] do not support cluster setup with udp(u) transport in
|
||||
3 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/pcs/pcs.8.in b/pcs/pcs.8.in
|
||||
index 6347a9d5..5279c4ca 100644
|
||||
index 0428f81c..d49f51e4 100644
|
||||
--- a/pcs/pcs.8.in
|
||||
+++ b/pcs/pcs.8.in
|
||||
@@ -426,6 +426,8 @@ By default, encryption is enabled with cipher=aes256 and hash=sha256. To disable
|
||||
@@ -429,6 +429,8 @@ By default, encryption is enabled with cipher=aes256 and hash=sha256. To disable
|
||||
|
||||
Transports udp and udpu:
|
||||
.br
|
||||
@ -24,10 +24,10 @@ index 6347a9d5..5279c4ca 100644
|
||||
.br
|
||||
Transport options are: ip_version, netmtu
|
||||
diff --git a/pcs/usage.py b/pcs/usage.py
|
||||
index 2b967e6b..ac543502 100644
|
||||
index 38e21ed9..ff81d607 100644
|
||||
--- a/pcs/usage.py
|
||||
+++ b/pcs/usage.py
|
||||
@@ -863,6 +863,7 @@ Commands:
|
||||
@@ -872,6 +872,7 @@ Commands:
|
||||
hash=sha256. To disable encryption, set cipher=none and hash=none.
|
||||
|
||||
Transports udp and udpu:
|
||||
|
15
pcs.spec
15
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.10.8
|
||||
Release: 11%{?dist}
|
||||
Version: 0.10.9
|
||||
Release: 1%{?dist}
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPLv2: pcs
|
||||
@ -18,8 +18,8 @@ Summary: Pacemaker Configuration System
|
||||
#building only for architectures with pacemaker and corosync available
|
||||
ExclusiveArch: i686 x86_64 s390x ppc64le aarch64
|
||||
|
||||
# %%global version_or_commit %%{version}
|
||||
%global version_or_commit %{version}.210-9862
|
||||
%global version_or_commit %{version}
|
||||
# %%global version_or_commit %%{version}.210-9862
|
||||
|
||||
%global pcs_source_name %{name}-%{version_or_commit}
|
||||
|
||||
@ -345,8 +345,7 @@ cp -f %SOURCE44 rpm/
|
||||
%define debug_package %{nil}
|
||||
|
||||
./autogen.sh
|
||||
# TODO: use --enable-individual-bundling when fixed in upstream
|
||||
%{configure} --enable-local-build --enable-use-local-cache-only --enable-invidual-bundling PYTHON=%{__python3}
|
||||
%{configure} --enable-local-build --enable-use-local-cache-only --enable-individual-bundling PYTHON=%{__python3}
|
||||
make all
|
||||
|
||||
%install
|
||||
@ -555,6 +554,10 @@ remove_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Miroslav Lisik <mlisik@redhat.com> - 0.10.9-1
|
||||
- Rebased to latest upstream sources (see CHANGELOG.md)
|
||||
- Resolves: rhbz#1991957
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.10.8-11
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
2
sources
2
sources
@ -19,4 +19,4 @@ SHA512 (dacite-1.6.0.tar.gz) = 034255f095589d309fe5805413d8b148f430cd20a0de305b7
|
||||
SHA512 (webrick-1.7.0.gem) = 5f242b50300046fe7c22ecd1640a73e5815e05a72bedfebe6bc39c24c92bd61abdd180860de0d194c0eebbc640b507b6892de181d3b577c5372ace0ca6faf2a3
|
||||
SHA512 (rexml-3.2.5.gem) = 1e3838d4a5befa76137fb8fea6a20195490645aa2b1c5d14d1eeca6c093d7f64eb405f07fd07b00fcafa9606dc78f9f0a488012338f81414623feb6e8cb83931
|
||||
SHA512 (pcs-web-ui-node-modules-0.1.6-fips-fix.tar.xz) = a209c3acac3a992627c146c75e9ebdbc735b38ba8f98935377694b8c13e4318ee5059c75833962cf188fc963ecefe68a6762daf7b4499c54538b1493cc0d712e
|
||||
SHA512 (pcs-0.10.8.210-9862.tar.gz) = 195f568f96c32019910d35e11141f987c0b3547cc6dd9135a1e5d045d91429685150ee68f4bd5f66285f2d4ab0bc19cb986bd9f2bbdfb52787890e41b684f74f
|
||||
SHA512 (pcs-0.10.9.tar.gz) = ced62db86f42427474b0ae97009f09bed0d0f4bae5ab1188fc58aace0b598863ac80ab443a8555b5d414f8332422144a3e1ef810ef46b9b3e1a5c8b2ef09985e
|
||||
|
Loading…
Reference in New Issue
Block a user