pcs-0.12.0-1.el10
- Rebased pcs to the latest sources (see CHANGELOG.md) Resolves: RHEL-44421 - Updated HA Cluster Management add-on to 0.1.22 - Improved directions pointing from pcs-web-ui to HA Cluster Management add-on Resolves: RHEL-68363
This commit is contained in:
parent
7b5f1708d0
commit
52fe547310
3
.gitignore
vendored
3
.gitignore
vendored
@ -48,3 +48,6 @@
|
|||||||
/pcs-web-ui-node-modules-0.1.21.tar.xz
|
/pcs-web-ui-node-modules-0.1.21.tar.xz
|
||||||
/pcs-1353dfbb3af82d77f4de17a3fa4cbde185bb2b2d.tar.gz
|
/pcs-1353dfbb3af82d77f4de17a3fa4cbde185bb2b2d.tar.gz
|
||||||
/pcs-web-ui-34372d1268f065ed186546f55216aaa2d7e76b54.tar.gz
|
/pcs-web-ui-34372d1268f065ed186546f55216aaa2d7e76b54.tar.gz
|
||||||
|
/pcs-web-ui-0.1.22.tar.gz
|
||||||
|
/pcs-web-ui-node-modules-0.1.22.tar.xz
|
||||||
|
/pcs-0.12.0.tar.gz
|
||||||
|
29
pcs.spec
29
pcs.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pcs
|
Name: pcs
|
||||||
Version: 0.12.0~b1
|
Version: 0.12.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||||
# GPL-2.0-only: pcs
|
# GPL-2.0-only: pcs
|
||||||
@ -23,27 +23,27 @@ ExclusiveArch: x86_64 s390x ppc64le aarch64
|
|||||||
|
|
||||||
# To build an official pcs release, comment out branch_or_commit
|
# To build an official pcs release, comment out branch_or_commit
|
||||||
# Use long commit hash or branch name to build an unreleased version
|
# Use long commit hash or branch name to build an unreleased version
|
||||||
%global branch_or_commit 1353dfbb3af82d77f4de17a3fa4cbde185bb2b2d
|
# %%global branch_or_commit 1353dfbb3af82d77f4de17a3fa4cbde185bb2b2d
|
||||||
%if "x{?branch_or_commit}" == "x"
|
%if 0%{?branch_or_commit:1}
|
||||||
%global version_or_commit %{clean_version}
|
|
||||||
%else
|
|
||||||
%global version_or_commit %{branch_or_commit}
|
%global version_or_commit %{branch_or_commit}
|
||||||
|
%else
|
||||||
|
%global version_or_commit %{clean_version}
|
||||||
%endif
|
%endif
|
||||||
%global pcs_source_name %{name}-%{version_or_commit}
|
%global pcs_source_name %{name}-%{version_or_commit}
|
||||||
|
|
||||||
# To build an official pcs-web-ui release, comment out ui_branch_or_commit
|
# To build an official pcs-web-ui release, comment out ui_branch_or_commit
|
||||||
# Last tagged version, also used as fallback version for untagged tarballs
|
# Last tagged version, also used as fallback version for untagged tarballs
|
||||||
%global ui_version 0.1.21
|
%global ui_version 0.1.22
|
||||||
# Use long commit hash or branch name to build an unreleased version
|
# Use long commit hash or branch name to build an unreleased version
|
||||||
%global ui_branch_or_commit 34372d1268f065ed186546f55216aaa2d7e76b54
|
# %%global ui_branch_or_commit 34372d1268f065ed186546f55216aaa2d7e76b54
|
||||||
%if "x{?ui_branch_or_commit}" == "x"
|
%if 0%{?ui_branch_or_commit:1}
|
||||||
%global ui_version_or_commit %{ui_version}
|
|
||||||
%else
|
|
||||||
%global ui_version_or_commit %{ui_branch_or_commit}
|
%global ui_version_or_commit %{ui_branch_or_commit}
|
||||||
|
%else
|
||||||
|
%global ui_version_or_commit %{ui_version}
|
||||||
%endif
|
%endif
|
||||||
%global ui_src_name pcs-web-ui-%{ui_version_or_commit}
|
%global ui_src_name pcs-web-ui-%{ui_version_or_commit}
|
||||||
|
|
||||||
%global ui_modules_version 0.1.21
|
%global ui_modules_version 0.1.22
|
||||||
|
|
||||||
%global dacite_version 1.8.1
|
%global dacite_version 1.8.1
|
||||||
%global pyagentx_version 0.4.pcs.2
|
%global pyagentx_version 0.4.pcs.2
|
||||||
@ -151,7 +151,7 @@ BuildRequires: python3-pip
|
|||||||
BuildRequires: python3-pyparsing
|
BuildRequires: python3-pyparsing
|
||||||
# pcs build backend is setuptools
|
# pcs build backend is setuptools
|
||||||
BuildRequires: python3-setuptools
|
BuildRequires: python3-setuptools
|
||||||
Buildrequires: python3-tornado
|
BuildRequires: python3-tornado
|
||||||
# for building bundled python packages
|
# for building bundled python packages
|
||||||
BuildRequires: python3-wheel
|
BuildRequires: python3-wheel
|
||||||
# gcc for compiling custom rubygems and python extensions
|
# gcc for compiling custom rubygems and python extensions
|
||||||
@ -178,6 +178,8 @@ BuildRequires: systemd
|
|||||||
BuildRequires: pam
|
BuildRequires: pam
|
||||||
# for working with qdevice certificates (certutil) - used in configure.ac
|
# for working with qdevice certificates (certutil) - used in configure.ac
|
||||||
BuildRequires: nss-tools
|
BuildRequires: nss-tools
|
||||||
|
# pcs now provides a pc file
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
|
||||||
# cluster stack packages for pkg-config
|
# cluster stack packages for pkg-config
|
||||||
# corosync has different package names on distributions but all provide
|
# corosync has different package names on distributions but all provide
|
||||||
@ -186,7 +188,6 @@ BuildRequires: nss-tools
|
|||||||
BuildRequires: corosync-devel >= 3.0
|
BuildRequires: corosync-devel >= 3.0
|
||||||
BuildRequires: pacemaker-libs-devel >= %{required_pacemaker_version}
|
BuildRequires: pacemaker-libs-devel >= %{required_pacemaker_version}
|
||||||
BuildRequires: pkgconfig(booth)
|
BuildRequires: pkgconfig(booth)
|
||||||
BuildRequires: pkgconfig(corosync-qdevice)
|
|
||||||
BuildRequires: pkgconfig(sbd)
|
BuildRequires: pkgconfig(sbd)
|
||||||
|
|
||||||
# for validating cockpit-ha-cluster metainfo
|
# for validating cockpit-ha-cluster metainfo
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 6e7fa90fc265063b65e3192ed513d0a52b000a2c Mon Sep 17 00:00:00 2001
|
From 264b69c1eedae035bbb1bcf345403978ebe5a222 Mon Sep 17 00:00:00 2001
|
||||||
From: Ivan Devat <idevat@redhat.com>
|
From: Ivan Devat <idevat@redhat.com>
|
||||||
Date: Tue, 5 Nov 2024 16:35:02 +0100
|
Date: Tue, 5 Nov 2024 16:35:02 +0100
|
||||||
Subject: [PATCH] show info page instead of webui
|
Subject: [PATCH] show info page instead of webui
|
||||||
@ -8,12 +8,12 @@ Subject: [PATCH] show info page instead of webui
|
|||||||
pcs/daemon/app/webui_info_handler.py | 31 ++++++++++++++++++++++++++++
|
pcs/daemon/app/webui_info_handler.py | 31 ++++++++++++++++++++++++++++
|
||||||
pcs/daemon/run.py | 4 +++-
|
pcs/daemon/run.py | 4 +++-
|
||||||
pcs_test/smoke.sh.in | 4 ++--
|
pcs_test/smoke.sh.in | 4 ++--
|
||||||
pcsd/public/ui_instructions.html | 26 ++++++++---------------
|
pcsd/public/ui_instructions.html | 26 ++++++++++-------------
|
||||||
5 files changed, 46 insertions(+), 20 deletions(-)
|
5 files changed, 48 insertions(+), 18 deletions(-)
|
||||||
create mode 100644 pcs/daemon/app/webui_info_handler.py
|
create mode 100644 pcs/daemon/app/webui_info_handler.py
|
||||||
|
|
||||||
diff --git a/pcs/Makefile.am b/pcs/Makefile.am
|
diff --git a/pcs/Makefile.am b/pcs/Makefile.am
|
||||||
index 28244dd7..4d4401fa 100644
|
index 7a734dc1..45d5801f 100644
|
||||||
--- a/pcs/Makefile.am
|
--- a/pcs/Makefile.am
|
||||||
+++ b/pcs/Makefile.am
|
+++ b/pcs/Makefile.am
|
||||||
@@ -206,6 +206,7 @@ EXTRA_DIST = \
|
@@ -206,6 +206,7 @@ EXTRA_DIST = \
|
||||||
@ -62,7 +62,7 @@ index 00000000..3ab8275b
|
|||||||
+ (r"/ui/.*", _WebuiInfoHandler, dict(path=path)),
|
+ (r"/ui/.*", _WebuiInfoHandler, dict(path=path)),
|
||||||
+ ]
|
+ ]
|
||||||
diff --git a/pcs/daemon/run.py b/pcs/daemon/run.py
|
diff --git a/pcs/daemon/run.py b/pcs/daemon/run.py
|
||||||
index b555bc18..10e394eb 100644
|
index e0090fc1..e80eecfe 100644
|
||||||
--- a/pcs/daemon/run.py
|
--- a/pcs/daemon/run.py
|
||||||
+++ b/pcs/daemon/run.py
|
+++ b/pcs/daemon/run.py
|
||||||
@@ -35,6 +35,7 @@ from pcs.daemon.app import capabilities as capabilities_app
|
@@ -35,6 +35,7 @@ from pcs.daemon.app import capabilities as capabilities_app
|
||||||
@ -73,7 +73,7 @@ index b555bc18..10e394eb 100644
|
|||||||
)
|
)
|
||||||
|
|
||||||
try:
|
try:
|
||||||
@@ -141,7 +142,8 @@ def configure_app(
|
@@ -142,7 +143,8 @@ def configure_app(
|
||||||
# Even with disabled (standalone) webui the following routes must be
|
# Even with disabled (standalone) webui the following routes must be
|
||||||
# provided because they can be used via unix socket from cockpit.
|
# provided because they can be used via unix socket from cockpit.
|
||||||
routes.extend(
|
routes.extend(
|
||||||
@ -101,10 +101,10 @@ index fdfe8be2..a9bb8344 100755
|
|||||||
echo "Unexpected response from https://localhost:2224/ui/ - http code: '${webui_http_code_response}'"
|
echo "Unexpected response from https://localhost:2224/ui/ - http code: '${webui_http_code_response}'"
|
||||||
exit 1
|
exit 1
|
||||||
diff --git a/pcsd/public/ui_instructions.html b/pcsd/public/ui_instructions.html
|
diff --git a/pcsd/public/ui_instructions.html b/pcsd/public/ui_instructions.html
|
||||||
index a120ed3d..5f9214d0 100644
|
index a120ed3d..ac0117c8 100644
|
||||||
--- a/pcsd/public/ui_instructions.html
|
--- a/pcsd/public/ui_instructions.html
|
||||||
+++ b/pcsd/public/ui_instructions.html
|
+++ b/pcsd/public/ui_instructions.html
|
||||||
@@ -1,27 +1,19 @@
|
@@ -1,27 +1,23 @@
|
||||||
<!DOCTYPE html>
|
<!DOCTYPE html>
|
||||||
<html>
|
<html>
|
||||||
<head>
|
<head>
|
||||||
@ -118,8 +118,13 @@ index a120ed3d..5f9214d0 100644
|
|||||||
<p>
|
<p>
|
||||||
- WebUI is not a part of pcs repository but it has its own
|
- WebUI is not a part of pcs repository but it has its own
|
||||||
- <a href="https://github.com/ClusterLabs/pcs-web-ui">repository</a>.
|
- <a href="https://github.com/ClusterLabs/pcs-web-ui">repository</a>.
|
||||||
- </p>
|
+ Since RHEL 10, pcsd web UI is no longer available. Management of high
|
||||||
- <p>
|
+ availability clusters has been<br>moved to an add-on for the RHEL web
|
||||||
|
+ console. The HA Cluster Management add-on can be installed<br>from within
|
||||||
|
+ the RHEL web console or by installing the <code>cockpit-ha-cluster</code>
|
||||||
|
+ RPM package.
|
||||||
|
</p>
|
||||||
|
<p>
|
||||||
- You can clone <a href="https://github.com/ClusterLabs/pcs-web-ui">WebUI repository</a>
|
- You can clone <a href="https://github.com/ClusterLabs/pcs-web-ui">WebUI repository</a>
|
||||||
- and build the web application into pcs by:
|
- and build the web application into pcs by:
|
||||||
- </p>
|
- </p>
|
||||||
@ -131,16 +136,13 @@ index a120ed3d..5f9214d0 100644
|
|||||||
- <p>
|
- <p>
|
||||||
- For more details, see instructions in
|
- For more details, see instructions in
|
||||||
- <a href="https://github.com/ClusterLabs/pcs-web-ui/blob/main/README.md">README.md</a>.
|
- <a href="https://github.com/ClusterLabs/pcs-web-ui/blob/main/README.md">README.md</a>.
|
||||||
+ Since RHEL 10.0, pcsd web UI is no longer available. Management of high
|
+ To learn more, please visit:
|
||||||
+ availability clusters has been moved to an add-on for the RHEL web console.
|
+ <a href="https://access.redhat.com/solutions/7099451">
|
||||||
+ The HA Cluster Management add-on can be installed from the cockpit-ha-cluster
|
+ https://access.redhat.com/solutions/7099451
|
||||||
+ RPM package or from the RHEL web console. To learn more, please visit:
|
+ </a>
|
||||||
+ <a href="https://access.redhat.com/solutions/7099451">
|
|
||||||
+ https://access.redhat.com/solutions/7099451
|
|
||||||
+ </a>
|
|
||||||
</p>
|
</p>
|
||||||
</body>
|
</body>
|
||||||
</html>
|
</html>
|
||||||
--
|
--
|
||||||
2.47.0
|
2.47.1
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -16,6 +16,6 @@ SHA512 (puma-6.4.3.gem) = e8baf137c5164f11b8563561405fc4218210707bfb15d0f21118d4
|
|||||||
SHA512 (rack-3.1.8.gem) = 7d7b3d8d40c3afc184de90c7602385854bc890ec13c98029e31db0134dbebd7655425334249c908bdb9e5fd1f15754872064611bbf1317a46c6082fd7cdf9b9d
|
SHA512 (rack-3.1.8.gem) = 7d7b3d8d40c3afc184de90c7602385854bc890ec13c98029e31db0134dbebd7655425334249c908bdb9e5fd1f15754872064611bbf1317a46c6082fd7cdf9b9d
|
||||||
SHA512 (rackup-2.2.1.gem) = e63c4dee6f1a677d507df0ae7bcebec88673e7a0a8d6621997949045db60801907038a148a0608f6e62864cb2ac056fca382f3438dc227b0fa7a3be52d56ea66
|
SHA512 (rackup-2.2.1.gem) = e63c4dee6f1a677d507df0ae7bcebec88673e7a0a8d6621997949045db60801907038a148a0608f6e62864cb2ac056fca382f3438dc227b0fa7a3be52d56ea66
|
||||||
SHA512 (tilt-2.4.0.gem) = 8cf5036017f501da8843340a9c574ee647074782dcb27ee0aa906fb96ad1e66b90dfb80159aa4c5e7605490058c5ae478bd0fe09f17ae50a2697327d02c814cc
|
SHA512 (tilt-2.4.0.gem) = 8cf5036017f501da8843340a9c574ee647074782dcb27ee0aa906fb96ad1e66b90dfb80159aa4c5e7605490058c5ae478bd0fe09f17ae50a2697327d02c814cc
|
||||||
SHA512 (pcs-web-ui-node-modules-0.1.21.tar.xz) = fb69949224b5637cf7e825b3bd9694c98667513f54c044d06911cce7964ccdcc66530d46b9289f24995abaff9dd6ed62a805ab926773c595c150a70a80cc989b
|
SHA512 (pcs-web-ui-0.1.22.tar.gz) = cb97ffba625326ab3857b9c22b4400907177a5ea88769ae611cc9315758c1ceca7e16a1b92d43fc594911fcde6003d3beadb388c6bdd5c1bcc67d699c49c9b2c
|
||||||
SHA512 (pcs-1353dfbb3af82d77f4de17a3fa4cbde185bb2b2d.tar.gz) = 5b5faf9ddbefbbca170f0c45e00c1a1a5e719bba4d7fb97ea22be26029373b27a33ea4b7558a1f740986931bbdcf5c04fb7f76446346a78bd734cc732c0328cc
|
SHA512 (pcs-web-ui-node-modules-0.1.22.tar.xz) = b1db7d8c04e942baf8a99f115cbda31a84f562c7deeee5f1371e5ddf5fb5e73ce084ede1f0da7083b2d0114228f58006599f1b9a29dd3a5202b3119e41f74d69
|
||||||
SHA512 (pcs-web-ui-34372d1268f065ed186546f55216aaa2d7e76b54.tar.gz) = 67f388c020243764ab52e291ff6cdb8e7346f6d184e31919561ca63affc301b0baf8a968e1088161d9b7f9f2cc5c4f1a517aa3e2016b0d0930d1e2ba320c6865
|
SHA512 (pcs-0.12.0.tar.gz) = f9b93bd39ce18898aa3bab7d4da86535e7351b75f15a0bc333598e2dae03ebf0f0f0638b1b441533af7f32909902353c3cf3ed5a219d0ce3b67a3a0e2c63b194
|
||||||
|
Loading…
Reference in New Issue
Block a user