Re-synced to upstream sources
This commit is contained in:
parent
174df125c0
commit
4bfe6fb772
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@
|
||||
/pcs-0.9.41.tar.gz
|
||||
/pcs-0.9.44.tar.gz
|
||||
/pcs-0.9.48.tar.gz
|
||||
/pcs-withgems-0.9.102.tar.gz
|
||||
|
72
fedfix.patch
72
fedfix.patch
@ -1,45 +1,35 @@
|
||||
--- pcs-0.9.39/pcsd/Makefile.fedfix 2013-03-13 18:21:24.000000000 -0500
|
||||
+++ pcs-0.9.39/pcsd/Makefile 2013-04-19 17:02:21.965509809 -0500
|
||||
@@ -1,10 +1,11 @@
|
||||
-PCSD_GEMS=sinatra sinatra-contrib json highline rack rack-protection tilt eventmachine rack-test backports sinatra-sugar monkey-lib rpam-ruby19
|
||||
+PCSD_GEMS=rpam-ruby19
|
||||
|
||||
tarball:
|
||||
rm -f dist/pcsd.tar.gz
|
||||
tar -C .. -czvf dist/pcsd.tar.gz --exclude ".*" --exclude .git --exclude --exclude=gemhome/* --exclude=dist --exclude=assets --exclude=jquery-ui pcs-gui
|
||||
|
||||
--- pcs-0.9.102/pcsd/Makefile.fedfix 2013-12-13 17:59:47.983000261 -0600
|
||||
+++ pcs-0.9.102/pcsd/Makefile 2013-12-13 17:59:57.709889020 -0600
|
||||
@@ -1,5 +1,5 @@
|
||||
build_gems:
|
||||
+# echo "No gems to build"
|
||||
mkdir -p gems; cd gems; gem install --local -i ../gemhome ${PCSD_GEMS}
|
||||
- bundle install --local --deployment
|
||||
+ bundle install --local --path vendor/bundle
|
||||
|
||||
get_gems:
|
||||
--- pcs-0.9.39/pcsd/pcsd.rb.fedfix 2013-03-19 18:04:53.000000000 -0500
|
||||
+++ pcs-0.9.39/pcsd/pcsd.rb 2013-04-19 17:01:32.958053089 -0500
|
||||
@@ -1,5 +1,5 @@
|
||||
require 'sinatra'
|
||||
-require 'sinatra/reloader' if development? #require 'rack/ssl'
|
||||
+#require 'sinatra/reloader' if development? #require 'rack/ssl'
|
||||
require 'open3'
|
||||
require 'rexml/document'
|
||||
require 'resource.rb'
|
||||
@@ -18,13 +18,13 @@ require 'logger'
|
||||
use Rack::CommonLogger
|
||||
#use Rack::SSL
|
||||
|
||||
-also_reload 'resource.rb'
|
||||
-also_reload 'remote.rb'
|
||||
-also_reload 'fenceagent.rb'
|
||||
-also_reload 'cluster.rb'
|
||||
-also_reload 'config.rb'
|
||||
-also_reload 'pcs.rb'
|
||||
-also_reload 'auth.rb'
|
||||
+#also_reload 'resource.rb'
|
||||
+#also_reload 'remote.rb'
|
||||
+#also_reload 'fenceagent.rb'
|
||||
+#also_reload 'cluster.rb'
|
||||
+#also_reload 'config.rb'
|
||||
+#also_reload 'pcs.rb'
|
||||
+#also_reload 'auth.rb'
|
||||
|
||||
enable :sessions
|
||||
bundle package
|
||||
--- pcs-0.9.102/pcsd/Gemfile.fedfix 2013-12-04 17:59:26.000000000 -0600
|
||||
+++ pcs-0.9.102/pcsd/Gemfile 2013-12-13 17:58:57.063583063 -0600
|
||||
@@ -1,15 +1,15 @@
|
||||
source 'https://rubygems.org'
|
||||
|
||||
-gem 'sinatra'
|
||||
+#gem 'sinatra'
|
||||
gem 'sinatra-contrib'
|
||||
-gem 'highline'
|
||||
-gem 'rack'
|
||||
-gem 'rack-protection'
|
||||
-gem 'tilt'
|
||||
-gem 'eventmachine'
|
||||
-gem 'rack-test'
|
||||
+#gem 'highline'
|
||||
+#gem 'rack'
|
||||
+#gem 'rack-protection'
|
||||
+#gem 'tilt'
|
||||
+#gem 'eventmachine'
|
||||
+#gem 'rack-test'
|
||||
gem 'backports'
|
||||
gem 'sinatra-sugar'
|
||||
gem 'monkey-lib'
|
||||
gem 'rpam-ruby19'
|
||||
-gem 'multi_json'
|
||||
+#gem 'multi_json'
|
||||
|
35
pcs.spec
35
pcs.spec
@ -1,14 +1,18 @@
|
||||
Name: pcs
|
||||
Version: 0.9.48
|
||||
Version: 0.9.102
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
URL: http://github.com/feist/pcs
|
||||
Group: System Environment/Base
|
||||
BuildRequires: python2-devel ruby ruby-devel pam-devel rubygem-sinatra rubygem-json rubygem-rack-test
|
||||
BuildRequires: python2-devel ruby ruby-devel pam-devel
|
||||
BuildRequires: rubygem-sinatra rubygem-highline rubygem-rack rubygem-rack-protection rubygem-tilt
|
||||
BuildRequires: rubygem-eventmachine rubygem-rack-test rubygem-multi_json rubygem-json
|
||||
Summary: Pacemaker Configuration System
|
||||
Source0: http://people.redhat.com/cfeist/pcs/pcs-%{version}.tar.gz
|
||||
Source0: http://people.redhat.com/cfeist/pcs/pcs-withgems-%{version}.tar.gz
|
||||
Patch0: fedfix.patch
|
||||
Requires: pacemaker ruby rubygem-sinatra rubygem-json rubygem-rack-test
|
||||
Requires: pacemaker ruby
|
||||
Requires: rubygem-sinatra rubygem-highline rubygem-rack rubygem-rack-protection rubygem-tilt
|
||||
Requires: rubygem-eventmachine rubygem-rack-test rubygem-multi_json rubygem-json
|
||||
|
||||
%description
|
||||
pcs is a corosync and pacemaker configuration tool. It permits users to
|
||||
@ -17,6 +21,8 @@ easily view, modify and created pacemaker based clusters.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fedfix
|
||||
cd pcsd ; bundle install --local ; cd ..
|
||||
|
||||
|
||||
%build
|
||||
|
||||
@ -28,7 +34,16 @@ make install_pcsd DESTDIR=$RPM_BUILD_ROOT PYTHON_SITELIB=%{python_sitelib} hdrdi
|
||||
chmod 755 $RPM_BUILD_ROOT/%{python_sitelib}/pcs/pcs.py
|
||||
|
||||
# Temporary fix for ruby-2.0.0 and rpam
|
||||
cp $RPM_BUILD_ROOT/usr/lib/pcsd/gemhome/gems/rpam-ruby19-1.2.1/ext/Rpam/rpam_ext.so $RPM_BUILD_ROOT/usr/lib/pcsd/gemhome/gems/rpam-ruby19-1.2.1/lib
|
||||
#cp $RPM_BUILD_ROOT/usr/lib/pcsd/gemhome/gems/rpam-ruby19-1.2.1/ext/Rpam/rpam_ext.so $RPM_BUILD_ROOT/usr/lib/pcsd/gemhome/gems/rpam-ruby19-1.2.1/lib
|
||||
|
||||
%post
|
||||
%systemd_post pcsd.service
|
||||
|
||||
%preun
|
||||
%systemd_preun pcsd.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart pcsd.service
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
@ -36,13 +51,23 @@ cp $RPM_BUILD_ROOT/usr/lib/pcsd/gemhome/gems/rpam-ruby19-1.2.1/ext/Rpam/rpam_ext
|
||||
%{python_sitelib}/pcs-%{version}-py2.*.egg-info
|
||||
/usr/sbin/pcs
|
||||
/usr/lib/pcsd/*
|
||||
/usr/lib/pcsd/.bundle/config
|
||||
/usr/lib/pcsd/.gitignore
|
||||
/usr/lib/systemd/system/pcsd.service
|
||||
/var/lib/pcsd
|
||||
/etc/pam.d/pcsd
|
||||
/etc/bash_completion.d/pcs
|
||||
/etc/logrotate.d/pcsd
|
||||
%dir /var/log/pcsd
|
||||
/etc/sysconfig/pcsd
|
||||
%{_mandir}/man8/pcs.*
|
||||
|
||||
%doc COPYING README
|
||||
|
||||
%changelog
|
||||
* Fri Dec 13 2013 Chris Feist <cfeist@redhat.com> - 0.9.102-1
|
||||
- Re-synced to upstream sources
|
||||
|
||||
* Wed Jun 19 2013 Chris Feist <cfeist@redhat.com> - 0.9.48-1
|
||||
- Rebuild with upstream sources
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user