Resolves: rhbz#1817695
This commit is contained in:
parent
a85960601d
commit
48169244fa
@ -0,0 +1,27 @@
|
||||
From 94cf5891507fa284ae5c1734df96c76a5bd58618 Mon Sep 17 00:00:00 2001
|
||||
From: Ondrej Mular <omular@redhat.com>
|
||||
Date: Fri, 27 Mar 2020 13:50:54 +0100
|
||||
Subject: [PATCH] remove usage of deprecated xml.etree.cElementTree
|
||||
|
||||
module xml.etree.cElementTree was depracated in python 3.3 and will be
|
||||
removed in 3.9, see: https://bugs.python.org/issue36543
|
||||
---
|
||||
pcs_test/tier0/test_utils.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pcs_test/tier0/test_utils.py b/pcs_test/tier0/test_utils.py
|
||||
index 866f4df4..98ce7806 100644
|
||||
--- a/pcs_test/tier0/test_utils.py
|
||||
+++ b/pcs_test/tier0/test_utils.py
|
||||
@@ -4,7 +4,7 @@ import sys
|
||||
from time import sleep
|
||||
from unittest import mock, TestCase
|
||||
import xml.dom.minidom
|
||||
-import xml.etree.cElementTree as ET
|
||||
+import xml.etree.ElementTree as ET
|
||||
|
||||
from pcs_test.tools.xml import dom_get_child_elements
|
||||
from pcs_test.tools.misc import get_test_resource as rc
|
||||
--
|
||||
2.20.1
|
||||
|
10
pcs.spec
10
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.10.5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPLv2: pcs
|
||||
# ASL 2.0: tornado
|
||||
@ -60,7 +60,7 @@ Source44: https://github.com/konradhalas/dacite/archive/v%{dacite_version}/dacit
|
||||
Source100: https://github.com/idevat/pcs-web-ui/archive/%{ui_commit}/%{ui_src_name}.tar.gz
|
||||
Source101: https://github.com/idevat/pcs-web-ui/releases/download/%{ui_commit}/pcs-web-ui-node-modules-%{ui_commit}.tar.xz
|
||||
|
||||
# Patch0: bz1656953-01-drop-removed-command-pcs-resource-show-from-help.patch
|
||||
Patch0: bz1817695-remove-usage-of-deprecated-xml.etree.cElementTree.patch
|
||||
|
||||
# git for patches
|
||||
BuildRequires: git
|
||||
@ -223,7 +223,7 @@ update_times_patch(){
|
||||
update_times ${patch_file_name} `diffstat -p1 -l ${patch_file_name}`
|
||||
}
|
||||
|
||||
# update_times_patch %%{PATCH0}
|
||||
update_times_patch %%{PATCH0}
|
||||
|
||||
# prepare dirs/files necessary for building web ui
|
||||
# inside SOURCE100 is only directory %%{ui_src_name}
|
||||
@ -449,6 +449,10 @@ remove_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Fri Mar 27 2020 Ondrej Mular <omular@redhat.com> - 0.10.5-2
|
||||
- Remove usage of deprecated module xml.etree.cElementTree
|
||||
- Resolves: rhbz#1817695
|
||||
|
||||
* Wed Mar 18 2020 Miroslav Lisik <mlisik@redhat.com> - 0.10.5-1
|
||||
- Rebased to latest upstream sources (see CHANGELOG.md)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user