Rebased to latest upstream sources (see CHANGELOG.md)
- Updated pcs-web-ui - Resolves: rhbz#2068452
This commit is contained in:
parent
a6e4f795a7
commit
478964bb97
3
.gitignore
vendored
3
.gitignore
vendored
@ -97,3 +97,6 @@
|
||||
/pcs-web-ui-0.1.12.tar.gz
|
||||
/pcs-web-ui-node-modules-0.1.12.tar.xz
|
||||
/pcs-0.11.2.tar.gz
|
||||
/pcs-0.11.3.tar.gz
|
||||
/pcs-web-ui-0.1.14.tar.gz
|
||||
/pcs-web-ui-node-modules-0.1.14.tar.xz
|
||||
|
@ -1,70 +0,0 @@
|
||||
From 5666877a0fe2cb9d99b1bca82d2d531887c22e4e Mon Sep 17 00:00:00 2001
|
||||
From: Miroslav Lisik <mlisik@redhat.com>
|
||||
Date: Wed, 8 Jun 2022 16:57:29 +0200
|
||||
Subject: [PATCH] Python 3.11 related fixes
|
||||
|
||||
fix test_failed function in test tools
|
||||
fix enum value in test fixture
|
||||
fix test case mocking
|
||||
---
|
||||
pcs_test/tier0/cli/test_nvset.py | 3 ++-
|
||||
pcs_test/tier0/lib/commands/test_ticket.py | 2 +-
|
||||
pcs_test/tools/case_analysis.py | 13 ++++++-------
|
||||
3 files changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/pcs_test/tier0/cli/test_nvset.py b/pcs_test/tier0/cli/test_nvset.py
|
||||
index 93a96e7a..ad44f2a1 100644
|
||||
--- a/pcs_test/tier0/cli/test_nvset.py
|
||||
+++ b/pcs_test/tier0/cli/test_nvset.py
|
||||
@@ -149,7 +149,8 @@ class NvsetDtoListToLines(TestCase):
|
||||
|
||||
def fixture_dto_list(self):
|
||||
return [
|
||||
- self.fixture_dto(in_effect) for in_effect in CibRuleInEffectStatus
|
||||
+ self.fixture_dto(in_effect.value)
|
||||
+ for in_effect in CibRuleInEffectStatus
|
||||
]
|
||||
|
||||
def test_expired_included(self):
|
||||
diff --git a/pcs_test/tier0/lib/commands/test_ticket.py b/pcs_test/tier0/lib/commands/test_ticket.py
|
||||
index 5459582a..3e7b7310 100644
|
||||
--- a/pcs_test/tier0/lib/commands/test_ticket.py
|
||||
+++ b/pcs_test/tier0/lib/commands/test_ticket.py
|
||||
@@ -95,7 +95,7 @@ class CreateTest(TestCase):
|
||||
)
|
||||
|
||||
|
||||
-@patch_commands("get_constraints", mock.Mock)
|
||||
+@patch_commands("get_constraints", mock.Mock())
|
||||
class RemoveTest(TestCase):
|
||||
@patch_commands("ticket.remove_plain", mock.Mock(return_value=1))
|
||||
@patch_commands(
|
||||
diff --git a/pcs_test/tools/case_analysis.py b/pcs_test/tools/case_analysis.py
|
||||
index 49fd1ee8..6d311548 100644
|
||||
--- a/pcs_test/tools/case_analysis.py
|
||||
+++ b/pcs_test/tools/case_analysis.py
|
||||
@@ -10,15 +10,14 @@ def _list2reason(test, exc_list):
|
||||
def test_failed(test):
|
||||
# Borrowed from
|
||||
# https://stackoverflow.com/questions/4414234/getting-pythons-unittest-results-in-a-teardown-method/39606065#39606065
|
||||
- # for Python versions 2.7 to 3.6
|
||||
- if hasattr(test, "_outcome"): # Python 3.4+
|
||||
- # these 2 methods have no side effects
|
||||
+ # for Python versions 3.4 to 3.11
|
||||
+ if hasattr(test._outcome, "errors"):
|
||||
+ # Python 3.4 - 3.10 (These 2 methods have no side effects)
|
||||
result = test.defaultTestResult()
|
||||
test._feedErrorsToResult(result, test._outcome.errors)
|
||||
- else: # Python 3.2 - 3.3 or 3.0 - 3.1 and 2.7
|
||||
- result = getattr(
|
||||
- test, "_outcomeForDoCleanups", test._resultForDoCleanups
|
||||
- )
|
||||
+ else:
|
||||
+ # Python 3.11+
|
||||
+ result = test._outcome.result
|
||||
|
||||
return _list2reason(test, result.errors) or _list2reason(
|
||||
test, result.failures
|
||||
--
|
||||
2.35.3
|
||||
|
@ -1,23 +0,0 @@
|
||||
From fa75f40361bc39cbd645b8014713e4c0ad0cda18 Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Devat <idevat@redhat.com>
|
||||
Date: Mon, 24 Jan 2022 14:08:54 +0100
|
||||
Subject: [PATCH 2/2] fix backend parameter "all" in cluster destroy
|
||||
|
||||
---
|
||||
src/app/backend/calls/destroyCluster.ts | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/app/backend/calls/destroyCluster.ts b/src/app/backend/calls/destroyCluster.ts
|
||||
index b6e83a41..cf41ea42 100644
|
||||
--- a/src/app/backend/calls/destroyCluster.ts
|
||||
+++ b/src/app/backend/calls/destroyCluster.ts
|
||||
@@ -4,5 +4,5 @@ const { url } = endpoints.destroyCluster;
|
||||
|
||||
export const destroyCluster = (clusterName: string): CallResult =>
|
||||
http.post(url({ clusterName }), {
|
||||
- params: [["--all", "1"]],
|
||||
+ params: [["all", "1"]],
|
||||
});
|
||||
--
|
||||
2.34.1
|
||||
|
22
pcs.spec
22
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.11.2
|
||||
Release: 3%{?dist}
|
||||
Version: 0.11.3
|
||||
Release: 1%{?dist}
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPLv2: pcs
|
||||
@ -17,8 +17,8 @@ Summary: Pacemaker Configuration System
|
||||
%global pcs_source_name %{name}-%{version_or_commit}
|
||||
|
||||
# ui_commit can be determined by hash, tag or branch
|
||||
%global ui_commit 0.1.12
|
||||
%global ui_modules_version 0.1.12
|
||||
%global ui_commit 0.1.14
|
||||
%global ui_modules_version 0.1.14
|
||||
%global ui_src_name pcs-web-ui-%{ui_commit}
|
||||
|
||||
%global pcs_snmp_pkg_name pcs-snmp
|
||||
@ -49,12 +49,9 @@ Source101: https://github.com/ClusterLabs/pcs-web-ui/releases/download/%{ui_comm
|
||||
|
||||
# pcs patches: <= 200
|
||||
# Patch0: name.patch
|
||||
Patch0: bz2093935-01-Python-3.11-related-fixes.patch
|
||||
|
||||
# ui patches: >200
|
||||
# Patch201: name.patch
|
||||
Patch201: simplify-ternar-expression.patch
|
||||
Patch202: fix-backend-parameter-all-in-cluster-destroy.patch
|
||||
|
||||
# git for patches
|
||||
BuildRequires: git-core
|
||||
@ -247,13 +244,10 @@ update_times_patch(){
|
||||
%autosetup -D -T -b 100 -a 101 -S git -n %{ui_src_name} -N
|
||||
%autopatch -p1 -m 201
|
||||
# update_times_patch %%{PATCH201}
|
||||
update_times_patch %{PATCH201}
|
||||
update_times_patch %{PATCH202}
|
||||
|
||||
# patch pcs sources
|
||||
%autosetup -S git -n %{pcs_source_name} -N
|
||||
%autopatch -p1 -M 200
|
||||
update_times_patch %{PATCH0}
|
||||
|
||||
# prepare dirs/files necessary for building all bundles
|
||||
# -----------------------------------------------------
|
||||
@ -284,7 +278,8 @@ pwd
|
||||
%make_install
|
||||
|
||||
# install pcs-web-ui
|
||||
cp -r %{_builddir}/%{ui_src_name}/build ${RPM_BUILD_ROOT}%{_libdir}/%{pcsd_public_dir}/ui
|
||||
# cp -r %%{_builddir}/%%{ui_src_name}/build ${RPM_BUILD_ROOT}%%{_libdir}/%%{pcsd_public_dir}/ui
|
||||
make -C %{_builddir}/%{ui_src_name} _install PCSD_DIR=${RPM_BUILD_ROOT}%{_libdir}/pcsd
|
||||
|
||||
# symlink favicon into pcsd directories
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/%{pcsd_public_dir}/images/
|
||||
@ -426,6 +421,11 @@ run_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Tue Jun 28 2022 Miroslav Lisik <mlisik@redhat.com> - 0.11.3-1
|
||||
- Rebased to latest upstream sources (see CHANGELOG.md)
|
||||
- Updated pcs-web-ui
|
||||
- Resolves: rhbz#2068452
|
||||
|
||||
* Tue Jun 14 2022 Python Maint <python-maint@redhat.com> - 0.11.2-3
|
||||
- Rebuilt for Python 3.11
|
||||
|
||||
|
@ -1,26 +0,0 @@
|
||||
From f44cdc871a39da3960bd04565b4d1d5ffa19bd23 Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Devat <idevat@redhat.com>
|
||||
Date: Thu, 20 Jan 2022 13:32:49 +0100
|
||||
Subject: [PATCH 1/2] simplify ternar expression
|
||||
|
||||
The motivation for this is that covscan complains about it.
|
||||
---
|
||||
src/app/view/share/useUrlTabs.ts | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/app/view/share/useUrlTabs.ts b/src/app/view/share/useUrlTabs.ts
|
||||
index 7278dad8..a1136bf3 100644
|
||||
--- a/src/app/view/share/useUrlTabs.ts
|
||||
+++ b/src/app/view/share/useUrlTabs.ts
|
||||
@@ -13,7 +13,7 @@ export const useUrlTabs = <TABS extends ReadonlyArray<string>>(
|
||||
|
||||
return {
|
||||
currentTab,
|
||||
- matchedContext: tab !== null ? tab.matched : `/${defaultTab}`,
|
||||
+ matchedContext: tab?.matched ?? `/${defaultTab}`,
|
||||
tabList,
|
||||
};
|
||||
};
|
||||
--
|
||||
2.34.1
|
||||
|
6
sources
6
sources
@ -1,6 +1,6 @@
|
||||
SHA512 (pyagentx-0.4.pcs.2.tar.gz) = d4194fec9a3e5fefe3793d49b7fec1feafef294c7e613a06046c2993daeefc5cb39d7c5b2b402ff83e49b2d976953f862264288c758c0be09d997b5323cc558a
|
||||
SHA512 (dacite-1.6.0.tar.gz) = 034255f095589d309fe5805413d8b148f430cd20a0de305b7954083b530d516da1d8f3f00ebb5264a8cfb77f2b2a76f1e2d863e78bd191f1d85021c5553815da
|
||||
SHA512 (thin-1.8.1.gem) = c200ea03b7876b2a17b5875557fa967b8d01db20cc401811f314f3285f8249b8793e4709b7bc033a9c5813b9a51e3093c55f717b4a98b8fda171aa82813b7419
|
||||
SHA512 (pcs-web-ui-0.1.12.tar.gz) = 0c1e3e71ce4cf5a1a39319b379985267642ed36d54bc18c6b0c4c5c9f8cd24e59c4f6137a64ffe704fe22a056960c3a205308dba17060680f3bbd92abe9ab9f4
|
||||
SHA512 (pcs-web-ui-node-modules-0.1.12.tar.xz) = 4f72f5f239613ab93ce1f32126050fae1b1c00ec3b73799a1ace3687c1a35370168ff1b6e070c2b661ece84e3ed4463189453247a2799f20dac1028b0c9b83f6
|
||||
SHA512 (pcs-0.11.2.tar.gz) = 65ba7e1e73c1e0462b2afb1c5321a4c97916b73410ef37fb262e10779b9fd4b7906ac4567bdab632abd6d470b6fc033cca754ba72567b03c07139eb9ad811b97
|
||||
SHA512 (pcs-0.11.3.tar.gz) = 5575a825976d668029eed007b7ddf8b3ad7f3eb6a510c56f4c1779c9228660f5141df761166e3dc307de14313be2045c8dd6e637432a7cab6da51163b8e41578
|
||||
SHA512 (pcs-web-ui-0.1.14.tar.gz) = aaaef6dcdd2255a3d48b9b03984debb61a5f83761fa70e5e2ecaf5c99bc38328cb8fc4347f2115b155ebcc862823ac6f89ef573f011ffe1118cb389e3cbe5661
|
||||
SHA512 (pcs-web-ui-node-modules-0.1.14.tar.xz) = 5042023409fb49fd0fee12d86794d410e3e28608e28e5bc419aa1cf98f17dd3668081821edbf4f6d660707d40697b3dbde697702c7039459325fb6a4171d5d93
|
||||
|
Loading…
Reference in New Issue
Block a user