Rebased to latest upstream sources
This commit is contained in:
parent
704acb797e
commit
3b2f88a991
1
.gitignore
vendored
1
.gitignore
vendored
@ -68,3 +68,4 @@
|
|||||||
/pcs-web-ui-node-modules-0.1.2.tar.xz
|
/pcs-web-ui-node-modules-0.1.2.tar.xz
|
||||||
/tilt-2.0.9.gem
|
/tilt-2.0.9.gem
|
||||||
/dacite-1.1.0.tar.gz
|
/dacite-1.1.0.tar.gz
|
||||||
|
/pcs-67591ed1487cb0aefa181fdfc166c8a66b55d25a.tar.gz
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From 94cf5891507fa284ae5c1734df96c76a5bd58618 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ondrej Mular <omular@redhat.com>
|
|
||||||
Date: Fri, 27 Mar 2020 13:50:54 +0100
|
|
||||||
Subject: [PATCH] remove usage of deprecated xml.etree.cElementTree
|
|
||||||
|
|
||||||
module xml.etree.cElementTree was depracated in python 3.3 and will be
|
|
||||||
removed in 3.9, see: https://bugs.python.org/issue36543
|
|
||||||
---
|
|
||||||
pcs_test/tier0/test_utils.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/pcs_test/tier0/test_utils.py b/pcs_test/tier0/test_utils.py
|
|
||||||
index 866f4df4..98ce7806 100644
|
|
||||||
--- a/pcs_test/tier0/test_utils.py
|
|
||||||
+++ b/pcs_test/tier0/test_utils.py
|
|
||||||
@@ -4,7 +4,7 @@ import sys
|
|
||||||
from time import sleep
|
|
||||||
from unittest import mock, TestCase
|
|
||||||
import xml.dom.minidom
|
|
||||||
-import xml.etree.cElementTree as ET
|
|
||||||
+import xml.etree.ElementTree as ET
|
|
||||||
|
|
||||||
from pcs_test.tools.xml import dom_get_child_elements
|
|
||||||
from pcs_test.tools.misc import get_test_resource as rc
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
27
pcs.spec
27
pcs.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pcs
|
Name: pcs
|
||||||
Version: 0.10.5
|
Version: 0.10.5
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||||
# GPLv2: pcs
|
# GPLv2: pcs
|
||||||
# ASL 2.0: tornado
|
# ASL 2.0: tornado
|
||||||
@ -9,8 +9,8 @@ License: GPLv2 and ASL 2.0 and MIT
|
|||||||
URL: https://github.com/ClusterLabs/pcs
|
URL: https://github.com/ClusterLabs/pcs
|
||||||
Summary: Pacemaker Configuration System
|
Summary: Pacemaker Configuration System
|
||||||
|
|
||||||
%global version_or_commit %{version}
|
# %%global version_or_commit %%{version}
|
||||||
# %%global version_or_commit f556c4adb538c8a95d763472d370f3f5d27eb38a
|
%global version_or_commit 67591ed1487cb0aefa181fdfc166c8a66b55d25a
|
||||||
%global pcs_source_name %{name}-%{version_or_commit}
|
%global pcs_source_name %{name}-%{version_or_commit}
|
||||||
|
|
||||||
# ui_commit can be determined by hash, tag or branch
|
# ui_commit can be determined by hash, tag or branch
|
||||||
@ -60,7 +60,7 @@ Source44: https://github.com/konradhalas/dacite/archive/v%{dacite_version}/dacit
|
|||||||
Source100: https://github.com/idevat/pcs-web-ui/archive/%{ui_commit}/%{ui_src_name}.tar.gz
|
Source100: https://github.com/idevat/pcs-web-ui/archive/%{ui_commit}/%{ui_src_name}.tar.gz
|
||||||
Source101: https://github.com/idevat/pcs-web-ui/releases/download/%{ui_commit}/pcs-web-ui-node-modules-%{ui_commit}.tar.xz
|
Source101: https://github.com/idevat/pcs-web-ui/releases/download/%{ui_commit}/pcs-web-ui-node-modules-%{ui_commit}.tar.xz
|
||||||
|
|
||||||
Patch0: bz1817695-remove-usage-of-deprecated-xml.etree.cElementTree.patch
|
# Patch0: name.patch
|
||||||
|
|
||||||
# git for patches
|
# git for patches
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
@ -97,14 +97,6 @@ BuildRequires: systemd
|
|||||||
# for tests
|
# for tests
|
||||||
BuildRequires: python3-lxml
|
BuildRequires: python3-lxml
|
||||||
BuildRequires: python3-pyOpenSSL
|
BuildRequires: python3-pyOpenSSL
|
||||||
BuildRequires: pacemaker-cli >= 2.0.0
|
|
||||||
BuildRequires: fence-virt
|
|
||||||
BuildRequires: fence-agents-apc
|
|
||||||
BuildRequires: fence-agents-scsi
|
|
||||||
BuildRequires: fence-agents-ipmilan
|
|
||||||
# fence-agents-ilo2 issue with dependencies
|
|
||||||
# BuildRequires: fence-agents-ilo2
|
|
||||||
BuildRequires: booth-site
|
|
||||||
# pcsd fonts and font management tools for creating symlinks to fonts
|
# pcsd fonts and font management tools for creating symlinks to fonts
|
||||||
BuildRequires: fontconfig
|
BuildRequires: fontconfig
|
||||||
BuildRequires: liberation-sans-fonts
|
BuildRequires: liberation-sans-fonts
|
||||||
@ -223,7 +215,7 @@ update_times_patch(){
|
|||||||
update_times ${patch_file_name} `diffstat -p1 -l ${patch_file_name}`
|
update_times ${patch_file_name} `diffstat -p1 -l ${patch_file_name}`
|
||||||
}
|
}
|
||||||
|
|
||||||
update_times_patch %%{PATCH0}
|
# update_times_patch %%{PATCH0}
|
||||||
|
|
||||||
# prepare dirs/files necessary for building web ui
|
# prepare dirs/files necessary for building web ui
|
||||||
# inside SOURCE100 is only directory %%{ui_src_name}
|
# inside SOURCE100 is only directory %%{ui_src_name}
|
||||||
@ -327,10 +319,7 @@ run_all_tests(){
|
|||||||
# disabled tests:
|
# disabled tests:
|
||||||
#
|
#
|
||||||
BUNDLED_LIB_LOCATION=$RPM_BUILD_ROOT%{pcs_libdir}/pcs/bundled/packages \
|
BUNDLED_LIB_LOCATION=$RPM_BUILD_ROOT%{pcs_libdir}/pcs/bundled/packages \
|
||||||
%{__python3} pcs_test/suite.py -v --vanilla \
|
%{__python3} pcs_test/suite.py --tier0 -v --vanilla
|
||||||
--all-but \
|
|
||||||
pcs_test.tier0.daemon.app.test_app_remote.SyncConfigMutualExclusive.test_get_not_locked \
|
|
||||||
pcs_test.tier0.daemon.app.test_app_remote.SyncConfigMutualExclusive.test_post_not_locked \
|
|
||||||
|
|
||||||
test_result_python=$?
|
test_result_python=$?
|
||||||
|
|
||||||
@ -449,6 +438,10 @@ remove_all_tests
|
|||||||
%license pyagentx_LICENSE.txt
|
%license pyagentx_LICENSE.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 07 2020 Ondrej Mular <omular@redhat.com> - 0.10.5-4
|
||||||
|
- Rebased to latest upstream sources (see CHANGELOG.md)
|
||||||
|
- Run only tier0 tests in check section
|
||||||
|
|
||||||
* Fri Apr 03 2020 Ondrej Mular <omular@redhat.com> - 0.10.5-3
|
* Fri Apr 03 2020 Ondrej Mular <omular@redhat.com> - 0.10.5-3
|
||||||
- Enable gating
|
- Enable gating
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,8 +1,8 @@
|
|||||||
SHA512 (pcsd-bundle-config-1) = f2a2df2dab39c2012cc6a91517716dde8f5a48788d1069c4addf619bc4dc45a98fd48f0f7964b5400e43e84fe96f942a550d2762553fea97e63dc7ad9b8be823
|
SHA512 (pcsd-bundle-config-1) = f2a2df2dab39c2012cc6a91517716dde8f5a48788d1069c4addf619bc4dc45a98fd48f0f7964b5400e43e84fe96f942a550d2762553fea97e63dc7ad9b8be823
|
||||||
SHA512 (pyagentx-0.4.pcs.2.tar.gz) = d4194fec9a3e5fefe3793d49b7fec1feafef294c7e613a06046c2993daeefc5cb39d7c5b2b402ff83e49b2d976953f862264288c758c0be09d997b5323cc558a
|
SHA512 (pyagentx-0.4.pcs.2.tar.gz) = d4194fec9a3e5fefe3793d49b7fec1feafef294c7e613a06046c2993daeefc5cb39d7c5b2b402ff83e49b2d976953f862264288c758c0be09d997b5323cc558a
|
||||||
SHA512 (tornado-6.0.3.tar.gz) = 8caaa64d14edcb3993dffea3175685d82afb0068a8e8834cbb6eb9e15883fe113bb57cd98d99c25362bef0a6ee2762f2baf24effd645ecd77f035583cc4de756
|
SHA512 (tornado-6.0.3.tar.gz) = 8caaa64d14edcb3993dffea3175685d82afb0068a8e8834cbb6eb9e15883fe113bb57cd98d99c25362bef0a6ee2762f2baf24effd645ecd77f035583cc4de756
|
||||||
SHA512 (pcs-0.10.5.tar.gz) = 38393f4ffec7c3062819cac099c9946eafec27326ac770af987f000f6617a417e04cf1ea209c3e6e1ca28b283822b448394325864d403af2fea140370f974e0e
|
|
||||||
SHA512 (pcs-web-ui-0.1.2.tar.gz) = 2fcb1c600cc644234036b47d7d277bb083945f3827c3f561d4301d901f2df579bf3f15da9f185ed3067951b76d17d102088d64aa921be2caa29d393d8342fb2a
|
SHA512 (pcs-web-ui-0.1.2.tar.gz) = 2fcb1c600cc644234036b47d7d277bb083945f3827c3f561d4301d901f2df579bf3f15da9f185ed3067951b76d17d102088d64aa921be2caa29d393d8342fb2a
|
||||||
SHA512 (pcs-web-ui-node-modules-0.1.2.tar.xz) = 48bc9e60170e8aedf744c57d78813b5a2e241a104c9a309f551aeaaa808f1a2bd77c6bae46a5833e1502a0bf222774b2604dfd4f75b4ddc461e50f49bf73f468
|
SHA512 (pcs-web-ui-node-modules-0.1.2.tar.xz) = 48bc9e60170e8aedf744c57d78813b5a2e241a104c9a309f551aeaaa808f1a2bd77c6bae46a5833e1502a0bf222774b2604dfd4f75b4ddc461e50f49bf73f468
|
||||||
SHA512 (tilt-2.0.9.gem) = 522b2b40ca1eefc7df66cb421c66734699a2ffb1e7d1797181c2718f7ca018d3376c1a2b3617b5d3549115af69108db4c3c4632e2682329d5baf24bfdae92b42
|
SHA512 (tilt-2.0.9.gem) = 522b2b40ca1eefc7df66cb421c66734699a2ffb1e7d1797181c2718f7ca018d3376c1a2b3617b5d3549115af69108db4c3c4632e2682329d5baf24bfdae92b42
|
||||||
SHA512 (dacite-1.1.0.tar.gz) = d7b1ce482584de3f4bc5c381cac054a7a7fd844e497b15e862f23b89b145d244bcf91eddb5a214e257822d362df19159ae379d71b1a7ff969790652905f7531f
|
SHA512 (dacite-1.1.0.tar.gz) = d7b1ce482584de3f4bc5c381cac054a7a7fd844e497b15e862f23b89b145d244bcf91eddb5a214e257822d362df19159ae379d71b1a7ff969790652905f7531f
|
||||||
|
SHA512 (pcs-67591ed1487cb0aefa181fdfc166c8a66b55d25a.tar.gz) = ee2f38b3c13c338ad9b36e26f21d704ac278ed9efa466a4030279afadcbb7c755ae444d8967911ad24c99c1114bfe1d8538f9b74114850be63e20b20fa71195c
|
||||||
|
Loading…
Reference in New Issue
Block a user