Resolves: rhbz#2048640
- Fixed snmp client - Fixed translating resource roles in colocation constraint
This commit is contained in:
parent
e9f7ea4da1
commit
2a4b9888d0
25
bz20486401-01-Fix-snmp-client.patch
Normal file
25
bz20486401-01-Fix-snmp-client.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 7902bb8fe7f97fbbc93e7001a6c4e8a445dcb44e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Valentin=20Vidi=C4=87?= <vvidic@valentin-vidic.from.hr>
|
||||
Date: Wed, 15 Dec 2021 20:32:26 +0100
|
||||
Subject: [PATCH 1/2] Fix snmp client
|
||||
|
||||
Required constant is missing causing the command to fail on startup and breaking the pcs_snmp_agent service.
|
||||
---
|
||||
pcsd/pcsd-cli-main.rb | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/pcsd/pcsd-cli-main.rb b/pcsd/pcsd-cli-main.rb
|
||||
index 29b9006d..be72d543 100644
|
||||
--- a/pcsd/pcsd-cli-main.rb
|
||||
+++ b/pcsd/pcsd-cli-main.rb
|
||||
@@ -10,6 +10,7 @@ require 'remote.rb'
|
||||
|
||||
|
||||
PCS = get_pcs_path()
|
||||
+PCS_INTERNAL = get_pcs_internal_path()
|
||||
$logger_device = StringIO.new
|
||||
$logger = Logger.new($logger_device)
|
||||
early_log($logger)
|
||||
--
|
||||
2.34.1
|
||||
|
25
fix-translating-resource-roles-in-colocation-constra.patch
Normal file
25
fix-translating-resource-roles-in-colocation-constra.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From f759872276ed8ff04bbf05010c18bbe4d1abdb11 Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Jelinek <tojeline@redhat.com>
|
||||
Date: Tue, 1 Feb 2022 16:10:35 +0100
|
||||
Subject: [PATCH 2/2] fix translating resource roles in colocation constraints
|
||||
|
||||
---
|
||||
pcs/lib/xml_tools.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pcs/lib/xml_tools.py b/pcs/lib/xml_tools.py
|
||||
index 07752f92..6a652fd1 100644
|
||||
--- a/pcs/lib/xml_tools.py
|
||||
+++ b/pcs/lib/xml_tools.py
|
||||
@@ -66,7 +66,7 @@ def export_attributes(
|
||||
result = {str(key): str(value) for key, value in element.attrib.items()}
|
||||
if not with_id:
|
||||
result.pop("id", None)
|
||||
- for role_name in ("role", "rsc-role"):
|
||||
+ for role_name in ("role", "rsc-role", "with-rsc-role"):
|
||||
if role_name in result:
|
||||
result[role_name] = pacemaker.role.get_value_primary(
|
||||
const.PcmkRoleType(result[role_name].capitalize())
|
||||
--
|
||||
2.34.1
|
||||
|
11
pcs.spec
11
pcs.spec
@ -1,6 +1,6 @@
|
||||
Name: pcs
|
||||
Version: 0.11.1
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
|
||||
# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
|
||||
# GPLv2: pcs
|
||||
@ -113,6 +113,8 @@ Patch5: bz2033248-01-skip-checking-of-scsi-devices-to-be-removed.patch
|
||||
Patch6: Make-ocf-linbit-drbd-agent-pass-OCF-validation.patch
|
||||
Patch7: bz1990787-01-Multiple-fixes-in-pcs-resource-move-command.patch
|
||||
Patch8: bz2040420-01-fix-creating-empty-cib.patch
|
||||
Patch9: bz20486401-01-Fix-snmp-client.patch
|
||||
Patch10: fix-translating-resource-roles-in-colocation-constra.patch
|
||||
|
||||
# Downstream patches do not come from upstream. They adapt pcs for specific
|
||||
# RHEL needs.
|
||||
@ -313,6 +315,8 @@ update_times_patch %{PATCH5}
|
||||
update_times_patch %{PATCH6}
|
||||
update_times_patch %{PATCH7}
|
||||
update_times_patch %{PATCH8}
|
||||
update_times_patch %{PATCH9}
|
||||
update_times_patch %{PATCH10}
|
||||
|
||||
# prepare dirs/files necessary for building all bundles
|
||||
# -----------------------------------------------------
|
||||
@ -553,6 +557,11 @@ run_all_tests
|
||||
%license pyagentx_LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Tue Feb 01 2022 Miroslav Lisik <mlisik@redhat.com> - 0.11.1-10
|
||||
- Fixed snmp client
|
||||
- Fixed translating resource roles in colocation constraint
|
||||
- Resolves: rhbz#2048640
|
||||
|
||||
* Tue Jan 25 2022 Miroslav Lisik <mlisik@redhat.com> - 0.11.1-9
|
||||
- Fixed cluster destroy in web ui
|
||||
- Fixed covscan issue in web ui
|
||||
|
Loading…
Reference in New Issue
Block a user