Don't try and build gems at all
This commit is contained in:
parent
cb9739cdfe
commit
274eea6d37
11
fedfix.patch
11
fedfix.patch
@ -2,12 +2,21 @@ Index: pcs/pcs-0.9.36/pcsd/Makefile
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- pcs.orig/pcs-0.9.36/pcsd/Makefile
|
--- pcs.orig/pcs-0.9.36/pcsd/Makefile
|
||||||
+++ pcs/pcs-0.9.36/pcsd/Makefile
|
+++ pcs/pcs-0.9.36/pcsd/Makefile
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,11 +1,12 @@
|
||||||
-PCSD_GEMS=sinatra sinatra-contrib json highline rack rack-protection tilt eventmachine rack-test backports sinatra-sugar monkey-lib rpam-ruby19
|
-PCSD_GEMS=sinatra sinatra-contrib json highline rack rack-protection tilt eventmachine rack-test backports sinatra-sugar monkey-lib rpam-ruby19
|
||||||
+PCSD_GEMS=
|
+PCSD_GEMS=
|
||||||
|
|
||||||
tarball:
|
tarball:
|
||||||
rm -f dist/pcsd.tar.gz
|
rm -f dist/pcsd.tar.gz
|
||||||
|
tar -C .. -czvf dist/pcsd.tar.gz --exclude ".*" --exclude .git --exclude --exclude=gemhome/* --exclude=dist --exclude=assets --exclude=jquery-ui pcs-gui
|
||||||
|
|
||||||
|
build_gems:
|
||||||
|
- mkdir -p gems; cd gems; gem install --local -i ../gemhome ${PCSD_GEMS}
|
||||||
|
+ echo "No gems to build"
|
||||||
|
+# mkdir -p gems; cd gems; gem install --local -i ../gemhome ${PCSD_GEMS}
|
||||||
|
|
||||||
|
get_gems:
|
||||||
|
mkdir -p gems; cd gems; gem fetch ${PCSD_GEMS}
|
||||||
Index: pcs/pcs-0.9.36/pcsd/pcsd.rb
|
Index: pcs/pcs-0.9.36/pcsd/pcsd.rb
|
||||||
===================================================================
|
===================================================================
|
||||||
--- pcs.orig/pcs-0.9.36/pcsd/pcsd.rb
|
--- pcs.orig/pcs-0.9.36/pcsd/pcsd.rb
|
||||||
|
5
pcs.spec
5
pcs.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pcs
|
Name: pcs
|
||||||
Version: 0.9.36
|
Version: 0.9.36
|
||||||
Release: 2%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://github.com/feist/pcs
|
URL: http://github.com/feist/pcs
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -40,6 +40,9 @@ chmod 755 $RPM_BUILD_ROOT/%{python_sitelib}/pcs/pcs.py
|
|||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 25 2013 Chris Feist <cfeist@rehdat.com> - 0.9.36-4
|
||||||
|
- Don't try to build gems at all
|
||||||
|
|
||||||
* Mon Mar 25 2013 Chris Feist <cfeist@rehdat.com> - 0.9.36-3
|
* Mon Mar 25 2013 Chris Feist <cfeist@rehdat.com> - 0.9.36-3
|
||||||
- Removed all gems from build, will need to find pam package in the future
|
- Removed all gems from build, will need to find pam package in the future
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user