10.23 bump
This commit is contained in:
parent
22bc41c3c3
commit
d53482340e
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/pcre2-10.22-RC1.tar.bz2
|
||||
/pcre2-10.22.tar.bz2
|
||||
/pcre2-10.23-RC1.tar.bz2
|
||||
/pcre2-10.23.tar.bz2
|
||||
|
@ -1,47 +0,0 @@
|
||||
From 415b992217a1e393fac5f4a6893013135510cda0 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Tue, 17 Jan 2017 13:48:37 +0100
|
||||
Subject: [PATCH] Fix warning on printing pointer difference
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
src/pcre2test.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/pcre2test.c b/src/pcre2test.c
|
||||
index 5ea245d..e1c8d25 100644
|
||||
--- a/src/pcre2test.c
|
||||
+++ b/src/pcre2test.c
|
||||
@@ -4663,7 +4663,7 @@ if ((pat_patctl.control & CTL_HEXPAT) != 0)
|
||||
if (d == 0)
|
||||
{
|
||||
fprintf(outfile, "** Missing closing quote in hex pattern: "
|
||||
- "opening quote is at offset %lu.\n", pq - buffer - 2);
|
||||
+ "opening quote is at offset %td.\n", pq - buffer - 2);
|
||||
return PR_SKIP;
|
||||
}
|
||||
if (d == c) break;
|
||||
@@ -4677,7 +4677,7 @@ if ((pat_patctl.control & CTL_HEXPAT) != 0)
|
||||
{
|
||||
if (!isxdigit(c))
|
||||
{
|
||||
- fprintf(outfile, "** Unexpected non-hex-digit '%c' at offset %lu "
|
||||
+ fprintf(outfile, "** Unexpected non-hex-digit '%c' at offset %td "
|
||||
"in hex pattern: quote missing?\n", c, pp - buffer - 2);
|
||||
return PR_SKIP;
|
||||
}
|
||||
@@ -4689,7 +4689,7 @@ if ((pat_patctl.control & CTL_HEXPAT) != 0)
|
||||
d = *pp;
|
||||
if (!isxdigit(d))
|
||||
{
|
||||
- fprintf(outfile, "** Unexpected non-hex-digit '%c' at offset %lu "
|
||||
+ fprintf(outfile, "** Unexpected non-hex-digit '%c' at offset %td "
|
||||
"in hex pattern: quote missing?\n", d, pp - buffer - 1);
|
||||
return PR_SKIP;
|
||||
}
|
||||
--
|
||||
2.7.4
|
||||
|
10
pcre2.spec
10
pcre2.spec
@ -1,8 +1,8 @@
|
||||
# This is stable release:
|
||||
%global rcversion RC1
|
||||
#%%global rcversion RC1
|
||||
Name: pcre2
|
||||
Version: 10.23
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}.1
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
|
||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||
Summary: Perl-compatible regular expression library
|
||||
Group: System Environment/Libraries
|
||||
@ -37,8 +37,6 @@ Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{?rcversion:T
|
||||
# Do no set RPATH if libdir is not /usr/lib
|
||||
Patch0: pcre2-10.10-Fix-multilib.patch
|
||||
# Fix a compiler warning, proposed to upstream but not portable before ISO C99
|
||||
Patch1: pcre2-10.23-RC1-Fix-warning-on-printing-pointer-difference.patch
|
||||
# New libtool to get rid of RPATH and to use distribution autotools
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: coreutils
|
||||
@ -115,7 +113,6 @@ Utilities demonstrating PCRE2 capabilities like pcre2grep or pcre2test.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{myversion}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
# Because of multilib patch
|
||||
libtoolize --copy --force
|
||||
autoreconf -vif
|
||||
@ -214,6 +211,9 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcre2test.*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 14 2017 Petr Pisar <ppisar@redhat.com> - 10.23-1
|
||||
- 10.23 bump
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 10.23-0.1.RC1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pcre2-10.23-RC1.tar.bz2) = e7ab5f34bcd0b94018c4330292756d465677af69408dbfc28d8e229b638ead33edd232f7289f57a2a07138f83362e277b80b1a7703d5568700ffaa1727badcf7
|
||||
SHA512 (pcre2-10.23.tar.bz2) = 3e5910bd2405cc35934d91e4be760abe4f2e900202a20b6ba74adb7a3acb2b74b3bf9b0e97e8de10f8e8534133e0722e0bf0f5fb40d6c2c4520d1ed61749d456
|
||||
|
Loading…
Reference in New Issue
Block a user