Fix an issue with restoring originally unset entries in recursion
Upstream commits:794245ecc2
457c0e69a8
Resolves: BZ#2248133
This commit is contained in:
parent
697a0c375e
commit
a5b9257eb7
65
pcre2-10.42-Add-more-examples-fixed-by-300.patch
Normal file
65
pcre2-10.42-Add-more-examples-fixed-by-300.patch
Normal file
@ -0,0 +1,65 @@
|
||||
From 457c0e69a8f78d32bc7d4b6422cd01e396a4cf5d Mon Sep 17 00:00:00 2001
|
||||
From: Philip Hazel <Philip.Hazel@gmail.com>
|
||||
Date: Tue, 3 Oct 2023 16:52:56 +0100
|
||||
Subject: [PATCH] Add more examples fixed by #300; update ChangeLog
|
||||
|
||||
---
|
||||
testdata/testinput1 | 8 ++++++++
|
||||
testdata/testoutput1 | 22 ++++++++++++++++++++++
|
||||
3 files changed, 34 insertions(+)
|
||||
|
||||
diff --git a/testdata/testinput1 b/testdata/testinput1
|
||||
index 3d75a35..533389d 100644
|
||||
--- a/testdata/testinput1
|
||||
+++ b/testdata/testinput1
|
||||
@@ -4374,6 +4374,14 @@
|
||||
|
||||
/(?<all>(?:(?:a(?&all))|(b))(c?))/
|
||||
aabc
|
||||
+
|
||||
+/(a(b)|(c))(?1)/
|
||||
+ abc
|
||||
+ cab
|
||||
+
|
||||
+/(?1)(a(b)|(c))/
|
||||
+ abc
|
||||
+ cab
|
||||
|
||||
/(?<NAME>(?&NAME_PAT))\s+(?<ADDR>(?&ADDRESS_PAT))
|
||||
(?(DEFINE)
|
||||
diff --git a/testdata/testoutput1 b/testdata/testoutput1
|
||||
index 26d3c83..bedd924 100644
|
||||
--- a/testdata/testoutput1
|
||||
+++ b/testdata/testoutput1
|
||||
@@ -6954,6 +6954,28 @@ No match
|
||||
1: aabc
|
||||
2: <unset>
|
||||
3:
|
||||
+
|
||||
+/(a(b)|(c))(?1)/
|
||||
+ abc
|
||||
+ 0: abc
|
||||
+ 1: ab
|
||||
+ 2: b
|
||||
+ cab
|
||||
+ 0: cab
|
||||
+ 1: c
|
||||
+ 2: <unset>
|
||||
+ 3: c
|
||||
+
|
||||
+/(?1)(a(b)|(c))/
|
||||
+ abc
|
||||
+ 0: abc
|
||||
+ 1: c
|
||||
+ 2: <unset>
|
||||
+ 3: c
|
||||
+ cab
|
||||
+ 0: cab
|
||||
+ 1: ab
|
||||
+ 2: b
|
||||
|
||||
/(?<NAME>(?&NAME_PAT))\s+(?<ADDR>(?&ADDRESS_PAT))
|
||||
(?(DEFINE)
|
||||
--
|
||||
2.41.0
|
||||
|
@ -0,0 +1,61 @@
|
||||
From 794245ecc296724b52f5030831e58bedbffa2452 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Carlo=20Marcelo=20Arenas=20Bel=C3=B3n?= <carenas@gmail.com>
|
||||
Date: Tue, 3 Oct 2023 08:14:23 -0700
|
||||
Subject: [PATCH] match: also restore originally unset entries in recursion
|
||||
(#300)
|
||||
|
||||
A regresion from ~10.30 not affecting JIT
|
||||
---
|
||||
src/pcre2_match.c | 2 +-
|
||||
testdata/testinput1 | 3 +++
|
||||
testdata/testoutput1 | 7 +++++++
|
||||
3 files changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/pcre2_match.c b/src/pcre2_match.c
|
||||
index 5ce1792..8b57c75 100644
|
||||
--- a/src/pcre2_match.c
|
||||
+++ b/src/pcre2_match.c
|
||||
@@ -5953,7 +5953,7 @@ fprintf(stderr, "++ op=%d\n", *Fecode);
|
||||
{
|
||||
P = (heapframe *)((char *)N - frame_size);
|
||||
memcpy((char *)F + offsetof(heapframe, ovector), P->ovector,
|
||||
- P->offset_top * sizeof(PCRE2_SIZE));
|
||||
+ Foffset_top * sizeof(PCRE2_SIZE));
|
||||
Foffset_top = P->offset_top;
|
||||
Fcapture_last = P->capture_last;
|
||||
Fcurrent_recurse = P->current_recurse;
|
||||
diff --git a/testdata/testinput1 b/testdata/testinput1
|
||||
index 062dfe0..3d75a35 100644
|
||||
--- a/testdata/testinput1
|
||||
+++ b/testdata/testinput1
|
||||
@@ -4372,6 +4372,9 @@
|
||||
/^(?(DEFINE) (?<A> a) (?<B> b) ) (?&A) (?&B) /x
|
||||
abcd
|
||||
|
||||
+/(?<all>(?:(?:a(?&all))|(b))(c?))/
|
||||
+ aabc
|
||||
+
|
||||
/(?<NAME>(?&NAME_PAT))\s+(?<ADDR>(?&ADDRESS_PAT))
|
||||
(?(DEFINE)
|
||||
(?<NAME_PAT>[a-z]+)
|
||||
diff --git a/testdata/testoutput1 b/testdata/testoutput1
|
||||
index 1dc3b2f..26d3c83 100644
|
||||
--- a/testdata/testoutput1
|
||||
+++ b/testdata/testoutput1
|
||||
@@ -6948,6 +6948,13 @@ No match
|
||||
abcd
|
||||
0: ab
|
||||
|
||||
+/(?<all>(?:(?:a(?&all))|(b))(c?))/
|
||||
+ aabc
|
||||
+ 0: aabc
|
||||
+ 1: aabc
|
||||
+ 2: <unset>
|
||||
+ 3:
|
||||
+
|
||||
/(?<NAME>(?&NAME_PAT))\s+(?<ADDR>(?&ADDRESS_PAT))
|
||||
(?(DEFINE)
|
||||
(?<NAME_PAT>[a-z]+)
|
||||
--
|
||||
2.41.0
|
||||
|
11
pcre2.spec
11
pcre2.spec
@ -9,7 +9,7 @@
|
||||
#%%global rcversion RC1
|
||||
Name: pcre2
|
||||
Version: 10.42
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}.2
|
||||
Release: %{?rcversion:0.}2%{?rcversion:.%rcversion}%{?dist}
|
||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||
Summary: Perl-compatible regular expression library
|
||||
# the library: BSD with exceptions
|
||||
@ -51,6 +51,11 @@ Source1: https://github.com/PCRE2Project/pcre2/releases/download/pcre2-%{vers
|
||||
Source2: https://ftp.pcre.org/pub/pcre/Public-Key
|
||||
# Do no set RPATH if libdir is not /usr/lib
|
||||
Patch0: pcre2-10.10-Fix-multilib.patch
|
||||
# Upstream commits:
|
||||
# https://github.com/PCRE2Project/pcre2/commit/794245ecc296724b52f5030831e58bedbffa2452
|
||||
# https://github.com/PCRE2Project/pcre2/commit/457c0e69a8f78d32bc7d4b6422cd01e396a4cf5d
|
||||
Patch1: pcre2-10.42-Match-also-restore-originally-unset-entries-in-recur.patch
|
||||
Patch2: pcre2-10.42-Add-more-examples-fixed-by-300.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -255,6 +260,10 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcre2test.*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 10.42-2
|
||||
- Fix an issue with restoring originally unset entries in recursion
|
||||
- Resolves: BZ#2248133
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 10.42-1.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user