Fix pcre2-config --libs-posix output
This commit is contained in:
parent
d3d89abedd
commit
6a1b5a7a57
@ -0,0 +1,122 @@
|
||||
From 2ea592a6f17c9e94810181aa9e41401956fedf87 Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Tue, 22 Nov 2016 10:18:08 +0000
|
||||
Subject: [PATCH] Correct libpcre2posix typos (should be libpcre2-posix).
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Petr Pisar: Ported to 10.22:
|
||||
|
||||
commit c7235e18071f76478fc33d9b78ea97525da48e59
|
||||
Author: ph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Tue Nov 22 10:18:08 2016 +0000
|
||||
|
||||
Correct libpcre2posix typos (should be libpcre2-posix).
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@602 6239d852-aaf2-0410-a92c-
|
||||
79f79f948069
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
CMakeLists.txt | 16 ++++++++--------
|
||||
README | 8 ++++----
|
||||
pcre2-config.in | 2 +-
|
||||
3 files changed, 13 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index ced3df2..af6e107 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -505,18 +505,18 @@ ADD_LIBRARY(pcre2-8 ${PCRE2_HEADERS} ${PCRE2_SOURCES} ${PROJECT_BINARY_DIR}/conf
|
||||
SET_PROPERTY(TARGET pcre2-8
|
||||
PROPERTY COMPILE_DEFINITIONS PCRE2_CODE_UNIT_WIDTH=8)
|
||||
SET(targets ${targets} pcre2-8)
|
||||
-ADD_LIBRARY(pcre2posix ${PCRE2POSIX_HEADERS} ${PCRE2POSIX_SOURCES})
|
||||
-SET_PROPERTY(TARGET pcre2posix
|
||||
+ADD_LIBRARY(pcre2-posix ${PCRE2POSIX_HEADERS} ${PCRE2POSIX_SOURCES})
|
||||
+SET_PROPERTY(TARGET pcre2-posix
|
||||
PROPERTY COMPILE_DEFINITIONS PCRE2_CODE_UNIT_WIDTH=8)
|
||||
-SET(targets ${targets} pcre2posix)
|
||||
-TARGET_LINK_LIBRARIES(pcre2posix pcre2-8)
|
||||
+SET(targets ${targets} pcre2-posix)
|
||||
+TARGET_LINK_LIBRARIES(pcre2-posix pcre2-8)
|
||||
|
||||
IF(MINGW AND NOT PCRE2_STATIC)
|
||||
IF(NON_STANDARD_LIB_PREFIX)
|
||||
- SET_TARGET_PROPERTIES(pcre2-8 pcre2posix PROPERTIES PREFIX "")
|
||||
+ SET_TARGET_PROPERTIES(pcre2-8 pcre2-posix PROPERTIES PREFIX "")
|
||||
ENDIF(NON_STANDARD_LIB_PREFIX)
|
||||
IF(NON_STANDARD_LIB_SUFFIX)
|
||||
- SET_TARGET_PROPERTIES(pcre2-8 pcre2posix PROPERTIES SUFFIX "-0.dll")
|
||||
+ SET_TARGET_PROPERTIES(pcre2-8 pcre2-posix PROPERTIES SUFFIX "-0.dll")
|
||||
ENDIF(NON_STANDARD_LIB_SUFFIX)
|
||||
ENDIF(MINGW AND NOT PCRE2_STATIC)
|
||||
ENDIF(PCRE2_BUILD_PCRE2_8)
|
||||
@@ -564,7 +564,7 @@ IF(PCRE2_BUILD_PCRE2GREP)
|
||||
SET_PROPERTY(TARGET pcre2grep
|
||||
PROPERTY COMPILE_DEFINITIONS PCRE2_CODE_UNIT_WIDTH=8)
|
||||
SET(targets ${targets} pcre2grep)
|
||||
- TARGET_LINK_LIBRARIES(pcre2grep pcre2posix ${PCRE2GREP_LIBS})
|
||||
+ TARGET_LINK_LIBRARIES(pcre2grep pcre2-posix ${PCRE2GREP_LIBS})
|
||||
ENDIF(PCRE2_BUILD_PCRE2GREP)
|
||||
|
||||
# Testing
|
||||
@@ -577,7 +577,7 @@ IF(PCRE2_BUILD_TESTS)
|
||||
ADD_EXECUTABLE(pcre2test ${PCRE2TEST_SOURCES})
|
||||
SET(targets ${targets} pcre2test)
|
||||
IF(PCRE2_BUILD_PCRE2_8)
|
||||
- LIST(APPEND PCRE2TEST_LIBS pcre2posix pcre2-8)
|
||||
+ LIST(APPEND PCRE2TEST_LIBS pcre2-posix pcre2-8)
|
||||
ENDIF(PCRE2_BUILD_PCRE2_8)
|
||||
IF(PCRE2_BUILD_PCRE2_16)
|
||||
LIST(APPEND PCRE2TEST_LIBS pcre2-16)
|
||||
diff --git a/README b/README
|
||||
index 03d67f6..1dd6a24 100644
|
||||
--- a/README
|
||||
+++ b/README
|
||||
@@ -44,7 +44,7 @@ wrappers.
|
||||
|
||||
The distribution does contain a set of C wrapper functions for the 8-bit
|
||||
library that are based on the POSIX regular expression API (see the pcre2posix
|
||||
-man page). These can be found in a library called libpcre2posix. Note that this
|
||||
+man page). These can be found in a library called libpcre2-posix. Note that this
|
||||
just provides a POSIX calling interface to PCRE2; the regular expressions
|
||||
themselves still follow Perl syntax and semantics. The POSIX API is restricted,
|
||||
and does not give full access to all of PCRE2's facilities.
|
||||
@@ -58,8 +58,8 @@ renamed or pointed at by a link.
|
||||
If you are using the POSIX interface to PCRE2 and there is already a POSIX
|
||||
regex library installed on your system, as well as worrying about the regex.h
|
||||
header file (as mentioned above), you must also take care when linking programs
|
||||
-to ensure that they link with PCRE2's libpcre2posix library. Otherwise they may
|
||||
-pick up the POSIX functions of the same name from the other library.
|
||||
+to ensure that they link with PCRE2's libpcre2-posix library. Otherwise they
|
||||
+may pick up the POSIX functions of the same name from the other library.
|
||||
|
||||
One way of avoiding this confusion is to compile PCRE2 with the addition of
|
||||
-Dregcomp=PCRE2regcomp (and similarly for the other POSIX functions) to the
|
||||
@@ -814,7 +814,7 @@ The distribution should contain the files listed below.
|
||||
libpcre2-8.pc.in template for libpcre2-8.pc for pkg-config
|
||||
libpcre2-16.pc.in template for libpcre2-16.pc for pkg-config
|
||||
libpcre2-32.pc.in template for libpcre2-32.pc for pkg-config
|
||||
- libpcre2posix.pc.in template for libpcre2posix.pc for pkg-config
|
||||
+ libpcre2-posix.pc.in template for libpcre2-posix.pc for pkg-config
|
||||
ltmain.sh file used to build a libtool script
|
||||
missing ) common stub for a few missing GNU programs while
|
||||
) installing, generated by automake
|
||||
diff --git a/pcre2-config.in b/pcre2-config.in
|
||||
index dbef5e5..dcc1095 100644
|
||||
--- a/pcre2-config.in
|
||||
+++ b/pcre2-config.in
|
||||
@@ -74,7 +74,7 @@ while test $# -gt 0; do
|
||||
;;
|
||||
--libs-posix)
|
||||
if test @enable_pcre2_8@ = yes ; then
|
||||
- echo $libS$libR -lpcre2posix -lpcre2-8
|
||||
+ echo $libS$libR -lpcre2-posix -lpcre2-8
|
||||
else
|
||||
echo "${usage}" 1>&2
|
||||
fi
|
||||
--
|
||||
2.7.4
|
||||
|
@ -2,7 +2,7 @@
|
||||
#%%global rcversion RC1
|
||||
Name: pcre2
|
||||
Version: 10.22
|
||||
Release: %{?rcversion:0.}6%{?rcversion:.%rcversion}%{?dist}
|
||||
Release: %{?rcversion:0.}7%{?rcversion:.%rcversion}%{?dist}
|
||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||
Summary: Perl-compatible regular expression library
|
||||
Group: System Environment/Libraries
|
||||
@ -55,6 +55,9 @@ Patch10: pcre2-10.22-The-offset-modifier-in-pcre2test-was-not-being-ignor.pat
|
||||
# Fix faulty auto-anchoring patterns when .* is inside an assertion,
|
||||
# in upstream after 10.22
|
||||
Patch11: pcre2-10.22-Fix-auto-anchor-bug-when-.-is-inside-an-assertion.patch
|
||||
# Fix pcre2-config --libs-posix output, in upstream after 10.22,
|
||||
# upstream bug #1924
|
||||
Patch12: pcre2-10.22-Correct-libpcre2posix-typos-should-be-libpcre2-posix.patch
|
||||
# New libtool to get rid of RPATH and to use distribution autotools
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -143,6 +146,7 @@ Utilities demonstrating PCRE2 capabilities like pcre2grep or pcre2test.
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
# Because of multilib patch
|
||||
libtoolize --copy --force
|
||||
autoreconf -vif
|
||||
@ -239,6 +243,9 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcre2test.*
|
||||
|
||||
%changelog
|
||||
* Fri Dec 09 2016 Petr Pisar <ppisar@redhat.com> - 10.22-7
|
||||
- Fix pcre2-config --libs-posix output (upstream bug #1924)
|
||||
|
||||
* Tue Nov 08 2016 Petr Pisar <ppisar@redhat.com> - 10.22-6
|
||||
- Fix faulty auto-anchoring patterns when .* is inside an assertion
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user