10.22 bump
This commit is contained in:
parent
0f1e744ae8
commit
57e14270c0
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/pcre2-10.21-RC1.tar.bz2
|
||||
/pcre2-10.21.tar.bz2
|
||||
/pcre2-10.22-RC1.tar.bz2
|
||||
/pcre2-10.22.tar.bz2
|
||||
|
@ -1,56 +0,0 @@
|
||||
From 7490ab47a6b597a4724b961a1987300809d0bef1 Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Sat, 2 Jul 2016 15:52:30 +0000
|
||||
Subject: [PATCH] Additional test for recent JIT bugfix.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@540 6239d852-aaf2-0410-a92c-79f79f948069
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
testdata/testinput17 | 8 ++++++++
|
||||
testdata/testoutput17 | 10 ++++++++++
|
||||
2 files changed, 18 insertions(+)
|
||||
|
||||
diff --git a/testdata/testinput17 b/testdata/testinput17
|
||||
index f1bf25f..90c0a09 100644
|
||||
--- a/testdata/testinput17
|
||||
+++ b/testdata/testinput17
|
||||
@@ -288,5 +288,13 @@
|
||||
/abc/jitfast
|
||||
abc
|
||||
abc\=no_jit
|
||||
+
|
||||
+# ----
|
||||
+
|
||||
+/[aC]/mg,firstline
|
||||
+match\nmatch
|
||||
+
|
||||
+/[aCz]/mg,firstline
|
||||
+match\nmatch
|
||||
|
||||
# End of testinput17
|
||||
diff --git a/testdata/testoutput17 b/testdata/testoutput17
|
||||
index 36509c8..60fe20b 100644
|
||||
--- a/testdata/testoutput17
|
||||
+++ b/testdata/testoutput17
|
||||
@@ -530,5 +530,15 @@ Failed: error -47: match limit exceeded
|
||||
0: abc (JIT)
|
||||
abc\=no_jit
|
||||
0: abc (JIT)
|
||||
+
|
||||
+# ----
|
||||
+
|
||||
+/[aC]/mg,firstline
|
||||
+match\nmatch
|
||||
+ 0: a (JIT)
|
||||
+
|
||||
+/[aCz]/mg,firstline
|
||||
+match\nmatch
|
||||
+ 0: a (JIT)
|
||||
|
||||
# End of testinput17
|
||||
--
|
||||
2.5.5
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 96715b703ae66d10c312c1ef9e3d297b17a7145e Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Sat, 2 Jul 2016 16:03:06 +0000
|
||||
Subject: [PATCH] Fix incorrect SONAME for pcre2posix wrapper library.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@541 6239d852-aaf2-0410-a92c-79f79f948069
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7230ebb..d119f82 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -20,7 +20,7 @@ m4_define(pcre2_date, [2016-06-29])
|
||||
m4_define(libpcre2_8_version, [4:0:4])
|
||||
m4_define(libpcre2_16_version, [4:0:4])
|
||||
m4_define(libpcre2_32_version, [4:0:4])
|
||||
-m4_define(libpcre2_posix_version, [0:2:0])
|
||||
+m4_define(libpcre2_posix_version, [1:0:0])
|
||||
|
||||
AC_PREREQ(2.57)
|
||||
AC_INIT(PCRE2, pcre2_major.pcre2_minor[]pcre2_prerelease, , pcre2)
|
||||
--
|
||||
2.5.5
|
||||
|
@ -1,64 +0,0 @@
|
||||
From 987102fcb0b726a1f29c9ed3e52c3839ebe372cd Mon Sep 17 00:00:00 2001
|
||||
From: zherczeg <zherczeg@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Fri, 1 Jul 2016 08:56:59 +0000
|
||||
Subject: [PATCH] Fix register overwite in JIT when SSE2 acceleration is
|
||||
enabled.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@539 6239d852-aaf2-0410-a92c-79f79f948069
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
ChangeLog | 2 ++
|
||||
src/pcre2_jit_compile.c | 4 ++--
|
||||
src/pcre2_jit_test.c | 1 +
|
||||
3 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 6b8b9a4..47f5835 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -166,6 +166,8 @@ it fails when running the interpreter with a 16M stack (and if changing the
|
||||
stack size via pcre2test is possible). This avoids having to manually set a
|
||||
large stack size when testing with clang.
|
||||
|
||||
+42. Fix register overwite in JIT when SSE2 acceleration is enabled.
|
||||
+
|
||||
|
||||
Version 10.21 12-January-2016
|
||||
-----------------------------
|
||||
diff --git a/src/pcre2_jit_compile.c b/src/pcre2_jit_compile.c
|
||||
index c98f977..8dea90a 100644
|
||||
--- a/src/pcre2_jit_compile.c
|
||||
+++ b/src/pcre2_jit_compile.c
|
||||
@@ -4027,12 +4027,12 @@ sljit_emit_op_custom(compiler, instruction, 4);
|
||||
|
||||
if (load_twice)
|
||||
{
|
||||
- OP1(SLJIT_MOV, TMP3, 0, TMP2, 0);
|
||||
+ OP1(SLJIT_MOV, RETURN_ADDR, 0, TMP2, 0);
|
||||
instruction[3] = 0xc0 | (tmp2_ind << 3) | 1;
|
||||
sljit_emit_op_custom(compiler, instruction, 4);
|
||||
|
||||
OP2(SLJIT_OR, TMP1, 0, TMP1, 0, TMP2, 0);
|
||||
- OP1(SLJIT_MOV, TMP2, 0, TMP3, 0);
|
||||
+ OP1(SLJIT_MOV, TMP2, 0, RETURN_ADDR, 0);
|
||||
}
|
||||
|
||||
OP2(SLJIT_ASHR, TMP1, 0, TMP1, 0, TMP2, 0);
|
||||
diff --git a/src/pcre2_jit_test.c b/src/pcre2_jit_test.c
|
||||
index dfe0032..705ba18 100644
|
||||
--- a/src/pcre2_jit_test.c
|
||||
+++ b/src/pcre2_jit_test.c
|
||||
@@ -692,6 +692,7 @@ static struct regression_test_case regression_test_cases[] = {
|
||||
{ PCRE2_FIRSTLINE | PCRE2_DOTALL, PCRE2_NEWLINE_LF, 0, 0 | F_NOMATCH, "ab.", "ab" },
|
||||
{ MU | PCRE2_FIRSTLINE, A, 0, 1 | F_NOMATCH, "^[a-d0-9]", "\nxx\nd" },
|
||||
{ PCRE2_FIRSTLINE | PCRE2_DOTALL, PCRE2_NEWLINE_ANY, 0, 0, "....a", "012\n0a" },
|
||||
+ { MU | PCRE2_FIRSTLINE, A, 0, 0, "[aC]", "a" },
|
||||
|
||||
/* Recurse. */
|
||||
{ MU, A, 0, 0, "(a)(?1)", "aa" },
|
||||
--
|
||||
2.5.5
|
||||
|
@ -1,68 +0,0 @@
|
||||
From c9290e0e852d5af7a209d154c32135286da2d4c4 Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Sun, 3 Jul 2016 15:21:01 +0000
|
||||
Subject: [PATCH] Fix typo again - hopefully correctly this time.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@543 6239d852-aaf2-0410-a92c-79f79f948069
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
doc/pcre2unicode.3 | 16 ++++++++--------
|
||||
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/doc/pcre2unicode.3 b/doc/pcre2unicode.3
|
||||
index 607d40e..253d4b6 100644
|
||||
--- a/doc/pcre2unicode.3
|
||||
+++ b/doc/pcre2unicode.3
|
||||
@@ -1,4 +1,4 @@
|
||||
-.TH PCRE2UNICODE 3 "02 July 2016" "PCRE2 10.22"
|
||||
+.TH PCRE2UNICODE 3 "03 July 2016" "PCRE2 10.22"
|
||||
.SH NAME
|
||||
PCRE - Perl-compatible regular expressions (revised API)
|
||||
.SH "UNICODE AND UTF SUPPORT"
|
||||
@@ -63,7 +63,7 @@ characters (see the description of \eC in the
|
||||
.\" HREF
|
||||
\fBpcre2pattern\fP
|
||||
.\"
|
||||
-documentation).
|
||||
+documentation).
|
||||
.P
|
||||
The use of \eC is not supported by the alternative matching function
|
||||
\fBpcre2_dfa_match()\fP when in UTF-8 or UTF-16 mode, that is, when a character
|
||||
@@ -235,9 +235,9 @@ never occur in a valid UTF-8 string.
|
||||
.sp
|
||||
The following negative error codes are given for invalid UTF-16 strings:
|
||||
.sp
|
||||
- PCRE2_UTF16_ERR1 Missing low surrogate at end of string
|
||||
- PCRE2_UTF16_ERR2 Invalid low surrogate follows high surrogate
|
||||
- PCRE2_UTF16_ERR3 Isolated low surrogate
|
||||
+ PCRE2_ERROR_UTF16_ERR1 Missing low surrogate at end of string
|
||||
+ PCRE2_ERROR_UTF16_ERR2 Invalid low surrogate follows high surrogate
|
||||
+ PCRE2_ERROR_UTF16_ERR3 Isolated low surrogate
|
||||
.sp
|
||||
.
|
||||
.
|
||||
@@ -247,8 +247,8 @@ The following negative error codes are given for invalid UTF-16 strings:
|
||||
.sp
|
||||
The following negative error codes are given for invalid UTF-32 strings:
|
||||
.sp
|
||||
- PCRE2_UTF32_ERR1 Surrogate character (range from 0xd800 to 0xdfff)
|
||||
- PCRE2_UTF32_ERR2 Code point is greater than 0x10ffff
|
||||
+ PCRE2_ERROR_UTF32_ERR1 Surrogate character (0xd800 to 0xdfff)
|
||||
+ PCRE2_ERROR_UTF32_ERR2 Code point is greater than 0x10ffff
|
||||
.sp
|
||||
.
|
||||
.
|
||||
@@ -266,6 +266,6 @@ Cambridge, England.
|
||||
.rs
|
||||
.sp
|
||||
.nf
|
||||
-Last updated: 02 July 2016
|
||||
+Last updated: 03 July 2016
|
||||
Copyright (c) 1997-2016 University of Cambridge.
|
||||
.fi
|
||||
--
|
||||
2.5.5
|
||||
|
@ -1,89 +0,0 @@
|
||||
From 4acd03a5ae1acb5361233d469b19e7e954805a2a Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>
|
||||
Date: Sat, 2 Jul 2016 16:34:01 +0000
|
||||
Subject: [PATCH] Fix typos and add clarification to documentation.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@542 6239d852-aaf2-0410-a92c-79f79f948069
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
doc/pcre2unicode.3 | 33 ++++++++++++++++++---------------
|
||||
1 file changed, 18 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/doc/pcre2unicode.3 b/doc/pcre2unicode.3
|
||||
index 59e226e..607d40e 100644
|
||||
--- a/doc/pcre2unicode.3
|
||||
+++ b/doc/pcre2unicode.3
|
||||
@@ -1,4 +1,4 @@
|
||||
-.TH PCRE2UNICODE 3 "16 October 2015" "PCRE2 10.21"
|
||||
+.TH PCRE2UNICODE 3 "02 July 2016" "PCRE2 10.22"
|
||||
.SH NAME
|
||||
PCRE - Perl-compatible regular expressions (revised API)
|
||||
.SH "UNICODE AND UTF SUPPORT"
|
||||
@@ -57,18 +57,21 @@ individual code units.
|
||||
In UTF modes, the dot metacharacter matches one UTF character instead of a
|
||||
single code unit.
|
||||
.P
|
||||
-The escape sequence \eC can be used to match a single code unit, in a UTF mode,
|
||||
+The escape sequence \eC can be used to match a single code unit in a UTF mode,
|
||||
but its use can lead to some strange effects because it breaks up multi-unit
|
||||
characters (see the description of \eC in the
|
||||
.\" HREF
|
||||
\fBpcre2pattern\fP
|
||||
.\"
|
||||
-documentation). The use of \eC is not supported by the alternative matching
|
||||
-function \fBpcre2_dfa_match()\fP when in UTF mode. Its use provokes a
|
||||
-match-time error. The JIT optimization also does not support \eC in UTF mode.
|
||||
-If JIT optimization is requested for a UTF pattern that contains \eC, it will
|
||||
-not succeed, and so the matching will be carried out by the normal interpretive
|
||||
-function.
|
||||
+documentation).
|
||||
+.P
|
||||
+The use of \eC is not supported by the alternative matching function
|
||||
+\fBpcre2_dfa_match()\fP when in UTF-8 or UTF-16 mode, that is, when a character
|
||||
+may consist of more than one code unit. The use of \eC in these modes provokes
|
||||
+a match-time error. Also, the JIT optimization does not support \eC in these
|
||||
+modes. If JIT optimization is requested for a UTF-8 or UTF-16 pattern that
|
||||
+contains \eC, it will not succeed, and so when \fBpcre2_match()\fP is called,
|
||||
+the matching will be carried out by the normal interpretive function.
|
||||
.P
|
||||
The character escapes \eb, \eB, \ed, \eD, \es, \eS, \ew, and \eW correctly test
|
||||
characters of any code value, but, by default, the characters that PCRE2
|
||||
@@ -232,9 +235,9 @@ never occur in a valid UTF-8 string.
|
||||
.sp
|
||||
The following negative error codes are given for invalid UTF-16 strings:
|
||||
.sp
|
||||
- PCRE_UTF16_ERR1 Missing low surrogate at end of string
|
||||
- PCRE_UTF16_ERR2 Invalid low surrogate follows high surrogate
|
||||
- PCRE_UTF16_ERR3 Isolated low surrogate
|
||||
+ PCRE2_UTF16_ERR1 Missing low surrogate at end of string
|
||||
+ PCRE2_UTF16_ERR2 Invalid low surrogate follows high surrogate
|
||||
+ PCRE2_UTF16_ERR3 Isolated low surrogate
|
||||
.sp
|
||||
.
|
||||
.
|
||||
@@ -244,8 +247,8 @@ The following negative error codes are given for invalid UTF-16 strings:
|
||||
.sp
|
||||
The following negative error codes are given for invalid UTF-32 strings:
|
||||
.sp
|
||||
- PCRE_UTF32_ERR1 Surrogate character (range from 0xd800 to 0xdfff)
|
||||
- PCRE_UTF32_ERR2 Code point is greater than 0x10ffff
|
||||
+ PCRE2_UTF32_ERR1 Surrogate character (range from 0xd800 to 0xdfff)
|
||||
+ PCRE2_UTF32_ERR2 Code point is greater than 0x10ffff
|
||||
.sp
|
||||
.
|
||||
.
|
||||
@@ -263,6 +266,6 @@ Cambridge, England.
|
||||
.rs
|
||||
.sp
|
||||
.nf
|
||||
-Last updated: 16 October 2015
|
||||
-Copyright (c) 1997-2015 University of Cambridge.
|
||||
+Last updated: 02 July 2016
|
||||
+Copyright (c) 1997-2016 University of Cambridge.
|
||||
.fi
|
||||
--
|
||||
2.5.5
|
||||
|
25
pcre2.spec
25
pcre2.spec
@ -1,5 +1,5 @@
|
||||
# This is stable release:
|
||||
%global rcversion RC1
|
||||
#%%global rcversion RC1
|
||||
Name: pcre2
|
||||
Version: 10.22
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
|
||||
@ -15,25 +15,14 @@ Group: System Environment/Libraries
|
||||
# ar-lib: GPLv2+ with exception
|
||||
# autotools: GPLv3+ with exception
|
||||
# install-sh: MIT
|
||||
# ltmain.sh: GPLv2+ with exception and GPLv3+ with
|
||||
# exception and GPLv3+
|
||||
# testdata: Public Domain
|
||||
License: BSD
|
||||
URL: http://www.pcre.org/
|
||||
Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{?rcversion:Testing/}%{name}-%{myversion}.tar.bz2
|
||||
# Do no set RPATH if libdir is not /usr/lib
|
||||
Patch0: pcre2-10.10-Fix-multilib.patch
|
||||
# Fix register overwite in JIT when SSE2 acceleration is enabled, in upstream
|
||||
# after 10.22-RC1
|
||||
Patch1: pcre2-10.22-RC1-Fix-register-overwite-in-JIT-when-SSE2-acceleration-.patch
|
||||
# Test for Fix-register-overwite-in-JIT-when-SSE2-acceleration-.patch, in
|
||||
# upstream after 10.22-RC1
|
||||
Patch2: pcre2-10.22-RC1-Additional-test-for-recent-JIT-bugfix.patch
|
||||
# Bump pcre2posix SONAME because of ABI change in 10.22-RC1, in upstream after
|
||||
# 10.22-RC1
|
||||
Patch3: pcre2-10.22-RC1-Fix-incorrect-SONAME-for-pcre2posix-wrapper-library.patch
|
||||
# Correct pcre2unicode(3) documentation, in upstream after 10.22-RC1
|
||||
Patch4: pcre2-10.22-RC1-Fix-typos-and-add-clarification-to-documentation.patch
|
||||
# Correct pcre2unicode(3) documentation, in upstream after 10.22-RC1
|
||||
Patch5: pcre2-10.22-RC1-Fix-typo-again-hopefully-correctly-this-time.patch
|
||||
|
||||
# New libtool to get rid of RPATH and to use distribution autotools
|
||||
BuildRequires: autoconf
|
||||
@ -112,11 +101,6 @@ Utilities demonstrating PCRE2 capabilities like pcre2grep or pcre2test.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{myversion}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
# Because of multilib patch
|
||||
libtoolize --copy --force
|
||||
autoreconf -vif
|
||||
@ -213,6 +197,9 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcre2test.*
|
||||
|
||||
%changelog
|
||||
* Fri Jul 29 2016 Petr Pisar <ppisar@redhat.com> - 10.22-1
|
||||
- 10.22 bump
|
||||
|
||||
* Thu Jun 30 2016 Petr Pisar <ppisar@redhat.com> - 10.22-0.1.RC1
|
||||
- 10.22-RC1 bump
|
||||
- libpcre2-posix library changed ABI
|
||||
|
Loading…
Reference in New Issue
Block a user