8.32-RC2 bump
This commit is contained in:
parent
ae4fe51404
commit
f7643576d2
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ pcre-8.10.tar.bz2
|
|||||||
/pcre-8.30.tar.bz2
|
/pcre-8.30.tar.bz2
|
||||||
/pcre-8.31-RC1.tar.bz2
|
/pcre-8.31-RC1.tar.bz2
|
||||||
/pcre-8.31.tar.bz2
|
/pcre-8.31.tar.bz2
|
||||||
|
/pcre-8.32-RC1.tar.bz2
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
Set re_nsub in regcomp() properly
|
|
||||||
|
|
||||||
Port from upstream commit:
|
|
||||||
|
|
||||||
r1024 | ph10 | 2012-08-29 13:08:24 +0200 (St, 29 srp 2012) | 2 lines
|
|
||||||
Fix re_nsub bug in the POSIX wrapper.
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=853990
|
|
||||||
http://bugs.exim.org/show_bug.cgi?id=1287
|
|
||||||
|
|
||||||
Index: pcreposix.c
|
|
||||||
===================================================================
|
|
||||||
--- pcreposix.c (revision 1023)
|
|
||||||
+++ pcreposix.c (revision 1024)
|
|
||||||
@@ -259,6 +259,7 @@
|
|
||||||
int erroffset;
|
|
||||||
int errorcode;
|
|
||||||
int options = 0;
|
|
||||||
+int re_nsub = 0;
|
|
||||||
|
|
||||||
if ((cflags & REG_ICASE) != 0) options |= PCRE_CASELESS;
|
|
||||||
if ((cflags & REG_NEWLINE) != 0) options |= PCRE_MULTILINE;
|
|
||||||
@@ -282,7 +283,8 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
(void)pcre_fullinfo((const pcre *)preg->re_pcre, NULL, PCRE_INFO_CAPTURECOUNT,
|
|
||||||
- &(preg->re_nsub));
|
|
||||||
+ &re_nsub);
|
|
||||||
+preg->re_nsub = (size_t)re_nsub;
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
@ -1,4 +1,4 @@
|
|||||||
From 32caa8eafa03dac3252fca05f6b39cc55f9e85a7 Mon Sep 17 00:00:00 2001
|
From 6f8b68f2740f3100154342338ed3d26e676dae69 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||||
Date: Mon, 7 Feb 2011 11:37:09 +0100
|
Date: Mon, 7 Feb 2011 11:37:09 +0100
|
||||||
Subject: [PATCH] Fix spelling in pcretest(1) manual
|
Subject: [PATCH] Fix spelling in pcretest(1) manual
|
||||||
@ -14,28 +14,28 @@ Collins dictionary of spelling and word division shows "termin-ate" and
|
|||||||
British and American hyphenation conventions; I try to follow the
|
British and American hyphenation conventions; I try to follow the
|
||||||
British ones, as exemplified in the Collins.
|
British ones, as exemplified in the Collins.
|
||||||
---
|
---
|
||||||
doc/pcretest.1 | 8 ++++----
|
doc/pcretest.1 | 8 ++++----
|
||||||
1 files changed, 4 insertions(+), 4 deletions(-)
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/doc/pcretest.1 b/doc/pcretest.1
|
diff --git a/doc/pcretest.1 b/doc/pcretest.1
|
||||||
index beb9d17..8f0552a 100644
|
index 41ef6ac..258a62f 100644
|
||||||
--- a/doc/pcretest.1
|
--- a/doc/pcretest.1
|
||||||
+++ b/doc/pcretest.1
|
+++ b/doc/pcretest.1
|
||||||
@@ -467,8 +467,8 @@ recognized:
|
@@ -601,8 +601,8 @@ recognized:
|
||||||
after a successful match (number less than 32)
|
after a successful match (number less than 32)
|
||||||
.\" JOIN
|
.\" JOIN
|
||||||
\eCname call pcre[16]_copy_named_substring() for substring
|
\eCname call pcre[16|32]_copy_named_substring() for substring
|
||||||
- "name" after a successful match (name termin-
|
- "name" after a successful match (name termin-
|
||||||
- ated by next non alphanumeric character)
|
- ated by next non alphanumeric character)
|
||||||
+ "name" after a successful match (name terminated
|
+ "name" after a successful match (name terminated
|
||||||
+ by next non-alphanumeric character)
|
+ by next non alphanumeric character)
|
||||||
.\" JOIN
|
.\" JOIN
|
||||||
\eC+ show the current captured substrings at callout
|
\eC+ show the current captured substrings at callout
|
||||||
time
|
time
|
||||||
@@ -489,8 +489,8 @@ recognized:
|
@@ -623,8 +623,8 @@ recognized:
|
||||||
after a successful match (number less than 32)
|
after a successful match (number less than 32)
|
||||||
.\" JOIN
|
.\" JOIN
|
||||||
\eGname call pcre[16]_get_named_substring() for substring
|
\eGname call pcre[16|32]_get_named_substring() for substring
|
||||||
- "name" after a successful match (name termin-
|
- "name" after a successful match (name termin-
|
||||||
- ated by next non-alphanumeric character)
|
- ated by next non-alphanumeric character)
|
||||||
+ "name" after a successful match (name terminated
|
+ "name" after a successful match (name terminated
|
||||||
@ -44,5 +44,5 @@ index beb9d17..8f0552a 100644
|
|||||||
\eJdd set up a JIT stack of dd kilobytes maximum (any
|
\eJdd set up a JIT stack of dd kilobytes maximum (any
|
||||||
number of digits)
|
number of digits)
|
||||||
--
|
--
|
||||||
1.7.7.6
|
1.7.11.7
|
||||||
|
|
14
pcre.spec
14
pcre.spec
@ -1,8 +1,8 @@
|
|||||||
# This is stable release:
|
# This is stable release:
|
||||||
#%%global rcversion RC1
|
%global rcversion RC1
|
||||||
Name: pcre
|
Name: pcre
|
||||||
Version: 8.31
|
Version: 8.32
|
||||||
Release: %{?rcversion:0.}2%{?rcversion:.%rcversion}%{?dist}
|
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
|
||||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||||
Summary: Perl-compatible regular expression library
|
Summary: Perl-compatible regular expression library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -12,9 +12,7 @@ Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/%{name}/%{?rcversion:Te
|
|||||||
# Upstream thinks RPATH is good idea.
|
# Upstream thinks RPATH is good idea.
|
||||||
Patch0: pcre-8.21-multilib.patch
|
Patch0: pcre-8.21-multilib.patch
|
||||||
# Refused by upstream, bug #675477
|
# Refused by upstream, bug #675477
|
||||||
Patch1: pcre-8.30-refused_spelling_terminated.patch
|
Patch1: pcre-8.32-refused_spelling_terminated.patch
|
||||||
# Set re_nsub in regcomp() properly, bug #853990
|
|
||||||
Patch2: pcre-8.31-re_nsub.patch
|
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
# New libtool to get rid of rpath
|
# New libtool to get rid of rpath
|
||||||
BuildRequires: autoconf, automake, libtool
|
BuildRequires: autoconf, automake, libtool
|
||||||
@ -54,7 +52,6 @@ Utilities demonstrating PCRE capabilities like pcregrep or pcretest.
|
|||||||
# Get rid of rpath
|
# Get rid of rpath
|
||||||
%patch0 -p1 -b .multilib
|
%patch0 -p1 -b .multilib
|
||||||
%patch1 -p1 -b .terminated_typos
|
%patch1 -p1 -b .terminated_typos
|
||||||
%patch2 -p0 -b .re_nsub
|
|
||||||
# Because of rpath patch
|
# Because of rpath patch
|
||||||
libtoolize --copy --force && autoreconf
|
libtoolize --copy --force && autoreconf
|
||||||
# One contributor's name is non-UTF-8
|
# One contributor's name is non-UTF-8
|
||||||
@ -118,6 +115,9 @@ make check
|
|||||||
%{_mandir}/man1/pcretest.*
|
%{_mandir}/man1/pcretest.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 13 2012 Petr Pisar <ppisar@redhat.com> - 8.32-0.1.RC1
|
||||||
|
- 8.32-RC1 bump
|
||||||
|
|
||||||
* Mon Sep 03 2012 Petr Pisar <ppisar@redhat.com> - 8.31-2
|
* Mon Sep 03 2012 Petr Pisar <ppisar@redhat.com> - 8.31-2
|
||||||
- Set re_nsub in regcomp() properly (bug #853990)
|
- Set re_nsub in regcomp() properly (bug #853990)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user