- update to 6.6
- fix multilib problem
This commit is contained in:
parent
cae5019b08
commit
dba96c6cb9
@ -1,3 +1,4 @@
|
||||
pcre-4.5.tar.bz2
|
||||
pcre-5.0.tar.bz2
|
||||
pcre-6.3.tar.bz2
|
||||
pcre-6.6.tar.bz2
|
||||
|
29
pcre-6.6-multilib.patch
Normal file
29
pcre-6.6-multilib.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- pcre-6.6/pcre-config.in.orig 2006-05-09 11:34:37.000000000 +0200
|
||||
+++ pcre-6.6/pcre-config.in 2006-05-09 11:36:09.000000000 +0200
|
||||
@@ -12,13 +12,6 @@
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-libR=
|
||||
-case `uname -s` in
|
||||
- *SunOS*)
|
||||
- libR=" -R@libdir@"
|
||||
- ;;
|
||||
-esac
|
||||
-
|
||||
while test $# -gt 0; do
|
||||
case "$1" in
|
||||
-*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
|
||||
@@ -52,10 +45,10 @@
|
||||
echo $includes
|
||||
;;
|
||||
--libs-posix)
|
||||
- echo -L@libdir@$libR -lpcreposix -lpcre
|
||||
+ echo -lpcreposix -lpcre
|
||||
;;
|
||||
--libs)
|
||||
- echo -L@libdir@$libR -lpcre
|
||||
+ echo -lpcre
|
||||
;;
|
||||
*)
|
||||
echo "${usage}" 1>&2
|
29
pcre.spec
29
pcre.spec
@ -1,10 +1,10 @@
|
||||
Name: pcre
|
||||
Version: 6.3
|
||||
Release: 1.2.1
|
||||
Version: 6.6
|
||||
Release: 1
|
||||
Summary: Perl-compatible regular expression library
|
||||
URL: http://www.pcre.org/
|
||||
Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
|
||||
Patch1: pcre-5.0-libdir.patch
|
||||
Patch1: pcre-6.6-multilib.patch
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
Prefix: %{_prefix}
|
||||
@ -30,23 +30,26 @@ Development files (Headers, libraries for static linking, etc) for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .libdir
|
||||
%patch1 -p1 -b .multilib
|
||||
|
||||
%build
|
||||
%configure --enable-utf8
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
rm -rf %{buildroot}
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_lib}
|
||||
mv $RPM_BUILD_ROOT%{_libdir}/libpcre.so.* $RPM_BUILD_ROOT/%{_lib}/
|
||||
pushd $RPM_BUILD_ROOT%{_libdir}
|
||||
mkdir -p %{buildroot}/%{_lib}
|
||||
mv %{buildroot}%{_libdir}/libpcre.so.* %{buildroot}/%{_lib}/
|
||||
pushd %{buildroot}%{_libdir}
|
||||
ln -fs ../../%{_lib}/libpcre.so.0 libpcre.so
|
||||
popd
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
# get rid of unneeded *.la files
|
||||
rm -f %{buildroot}%{_libdir}/*.la
|
||||
|
||||
%check
|
||||
make check
|
||||
@ -56,7 +59,7 @@ make check
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -77,6 +80,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_bindir}/pcre-config
|
||||
|
||||
%changelog
|
||||
* Tue May 09 2006 Than Ngo <than@redhat.com> 6.6-1
|
||||
- update to 6.6
|
||||
- fix multilib problem
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 6.3-1.2.1
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user