Fix a crash when finding a Unicode property for a character with a code point greater than 0x10ffff
This commit is contained in:
parent
ec2d617244
commit
c36d2c5e3d
@ -0,0 +1,72 @@
|
||||
From 8037f71d03b3cd8919248f38448a0a2d3715c18c Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>
|
||||
Date: Fri, 24 Feb 2017 17:30:30 +0000
|
||||
Subject: [PATCH] Fix Unicode property crash for 32-bit characters greater than
|
||||
0x10ffff.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1688 2f5784b3-3f2a-0410-8824-cb99058d5e15
|
||||
|
||||
Petr Písař: Ported to 8.40.
|
||||
|
||||
diff --git a/pcre_internal.h b/pcre_internal.h
|
||||
index 2923b29..154d3f6 100644
|
||||
--- a/pcre_internal.h
|
||||
+++ b/pcre_internal.h
|
||||
@@ -2772,6 +2772,9 @@ extern const pcre_uint8 PRIV(ucd_stage1)[];
|
||||
extern const pcre_uint16 PRIV(ucd_stage2)[];
|
||||
extern const pcre_uint32 PRIV(ucp_gentype)[];
|
||||
extern const pcre_uint32 PRIV(ucp_gbtable)[];
|
||||
+#ifdef COMPILE_PCRE32
|
||||
+extern const ucd_record PRIV(dummy_ucd_record)[];
|
||||
+#endif
|
||||
#ifdef SUPPORT_JIT
|
||||
extern const int PRIV(ucp_typerange)[];
|
||||
#endif
|
||||
@@ -2780,9 +2783,15 @@ extern const int PRIV(ucp_typerange)[];
|
||||
/* UCD access macros */
|
||||
|
||||
#define UCD_BLOCK_SIZE 128
|
||||
-#define GET_UCD(ch) (PRIV(ucd_records) + \
|
||||
+#define REAL_GET_UCD(ch) (PRIV(ucd_records) + \
|
||||
PRIV(ucd_stage2)[PRIV(ucd_stage1)[(int)(ch) / UCD_BLOCK_SIZE] * \
|
||||
UCD_BLOCK_SIZE + (int)(ch) % UCD_BLOCK_SIZE])
|
||||
+
|
||||
+#ifdef COMPILE_PCRE32
|
||||
+#define GET_UCD(ch) ((ch > 0x10ffff)? PRIV(dummy_ucd_record) : REAL_GET_UCD(ch))
|
||||
+#else
|
||||
+#define GET_UCD(ch) REAL_GET_UCD(ch)
|
||||
+#endif
|
||||
|
||||
#define UCD_CHARTYPE(ch) GET_UCD(ch)->chartype
|
||||
#define UCD_SCRIPT(ch) GET_UCD(ch)->script
|
||||
diff --git a/pcre_ucd.c b/pcre_ucd.c
|
||||
index 69c4fd4..f22f826 100644
|
||||
--- a/pcre_ucd.c
|
||||
+++ b/pcre_ucd.c
|
||||
@@ -38,6 +38,20 @@ const pcre_uint16 PRIV(ucd_stage2)[] = {0};
|
||||
const pcre_uint32 PRIV(ucd_caseless_sets)[] = {0};
|
||||
#else
|
||||
|
||||
+/* If the 32-bit library is run in non-32-bit mode, character values
|
||||
+greater than 0x10ffff may be encountered. For these we set up a
|
||||
+special record. */
|
||||
+
|
||||
+#ifdef COMPILE_PCRE32
|
||||
+const ucd_record PRIV(dummy_ucd_record)[] = {{
|
||||
+ ucp_Common, /* script */
|
||||
+ ucp_Cn, /* type unassigned */
|
||||
+ ucp_gbOther, /* grapheme break property */
|
||||
+ 0, /* case set */
|
||||
+ 0, /* other case */
|
||||
+ }};
|
||||
+#endif
|
||||
+
|
||||
/* When recompiling tables with a new Unicode version, please check the
|
||||
types in this structure definition from pcre_internal.h (the actual
|
||||
field names will be different):
|
||||
--
|
||||
2.7.4
|
||||
|
10
pcre.spec
10
pcre.spec
@ -55,6 +55,10 @@ Patch7: pcre-8.40-Make-pcretest-check-size-of-O-argument.patch
|
||||
# Document pcretest input cannot contain binary zeroes, upstream bug #2045,
|
||||
# in upstream after 8.40
|
||||
Patch8: pcre-8.40-Minor-doc-update.patch
|
||||
# Fix a crash when finding a Unicode property for a character with a code
|
||||
# point greater than 0x10ffff in UTF-32 library while UTF mode is disabled,
|
||||
# upstream bug #2052, in upstream after 8.40
|
||||
Patch9: pcre-8.40-Fix-Unicode-property-crash-for-32-bit-characters-gre.patch
|
||||
BuildRequires: readline-devel
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -151,6 +155,7 @@ Utilities demonstrating PCRE capabilities like pcregrep or pcretest.
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
# Because of rpath patch
|
||||
libtoolize --copy --force
|
||||
autoreconf -vif
|
||||
@ -247,10 +252,13 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcretest.*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 24 2017 Petr Pisar <ppisar@redhat.com> - 8.40-5
|
||||
* Mon Feb 27 2017 Petr Pisar <ppisar@redhat.com> - 8.40-5
|
||||
- Fix a crash in pcretest when \O directive was supplied with too big number
|
||||
(upstream bug #2044)
|
||||
- Document pcretest input cannot contain binary zeroes (upstream bug #2045)
|
||||
- Fix a crash when finding a Unicode property for a character with a code
|
||||
point greater than 0x10ffff in UTF-32 library while UTF mode is disabled
|
||||
(upstream bug #2052)
|
||||
|
||||
* Thu Feb 23 2017 Petr Pisar <ppisar@redhat.com> - 8.40-4
|
||||
- Fix a crash in pcretest when printing non-ASCII characters
|
||||
|
Loading…
Reference in New Issue
Block a user