8.37 bump
This commit is contained in:
parent
1f75ea5a21
commit
7c4af13676
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@ pcre-8.10.tar.bz2
|
||||
/pcre-8.36-RC1.tar.bz2
|
||||
/pcre-8.36.tar.bz2
|
||||
/pcre-8.37-RC1.tar.bz2
|
||||
/pcre-8.37.tar.bz2
|
||||
|
@ -1,96 +0,0 @@
|
||||
From 4ef0a06d7be50e00918c63c90ad934ba29970c42 Mon Sep 17 00:00:00 2001
|
||||
From: zherczeg <zherczeg@2f5784b3-3f2a-0410-8824-cb99058d5e15>
|
||||
Date: Thu, 23 Apr 2015 13:51:51 +0000
|
||||
Subject: [PATCH] Fix ARM64 SP alignment issue in JIT.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1551 2f5784b3-3f2a-0410-8824-cb99058d5e15
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
|
||||
diff --git a/sljit/sljitNativeARM_64.c b/sljit/sljitNativeARM_64.c
|
||||
index c5251be..b66455f 100644
|
||||
--- a/sljit/sljitNativeARM_64.c
|
||||
+++ b/sljit/sljitNativeARM_64.c
|
||||
@@ -1081,12 +1081,13 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_si sljit_emit_enter(struct sljit_compiler *compil
|
||||
FAIL_IF(push_inst(compiler, ADDI | RD(SLJIT_SP) | RN(TMP_SP) | (0 << 10)));
|
||||
offs = (local_size - saved_regs_size) << (15 - 3);
|
||||
} else {
|
||||
- compiler->local_size += 2 * sizeof(sljit_sw);
|
||||
- local_size -= saved_regs_size;
|
||||
- saved_regs_size += 2 * sizeof(sljit_sw);
|
||||
- FAIL_IF(push_inst(compiler, STP_PRE | 29 | RT2(TMP_LR)
|
||||
- | RN(TMP_SP) | ((-(saved_regs_size >> 3) & 0x7f) << 15)));
|
||||
- offs = 2 << 15;
|
||||
+ offs = 0 << 15;
|
||||
+ if (saved_regs_size & 0x8) {
|
||||
+ offs = 1 << 15;
|
||||
+ saved_regs_size += sizeof(sljit_sw);
|
||||
+ }
|
||||
+ local_size -= saved_regs_size + SLJIT_LOCALS_OFFSET;
|
||||
+ FAIL_IF(push_inst(compiler, SUBI | RD(TMP_SP) | RN(TMP_SP) | (saved_regs_size << 10)));
|
||||
}
|
||||
|
||||
tmp = saveds < SLJIT_NUMBER_OF_SAVED_REGISTERS ? (SLJIT_S0 + 1 - saveds) : SLJIT_FIRST_SAVED_REG;
|
||||
@@ -1122,6 +1123,8 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_si sljit_emit_enter(struct sljit_compiler *compil
|
||||
}
|
||||
if (local_size)
|
||||
FAIL_IF(push_inst(compiler, SUBI | RD(TMP_SP) | RN(TMP_SP) | (local_size << 10)));
|
||||
+ FAIL_IF(push_inst(compiler, STP_PRE | 29 | RT2(TMP_LR)
|
||||
+ | RN(TMP_SP) | ((-(16 >> 3) & 0x7f) << 15)));
|
||||
FAIL_IF(push_inst(compiler, ADDI | RD(SLJIT_SP) | RN(TMP_SP) | (0 << 10)));
|
||||
}
|
||||
|
||||
@@ -1145,8 +1148,6 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_si sljit_set_context(struct sljit_compiler *compi
|
||||
|
||||
local_size += GET_SAVED_REGISTERS_SIZE(scratches, saveds, 0) + SLJIT_LOCALS_OFFSET;
|
||||
local_size = (local_size + 15) & ~0xf;
|
||||
- if (local_size > (63 * sizeof(sljit_sw)))
|
||||
- local_size += 2 * sizeof(sljit_sw);
|
||||
compiler->local_size = local_size;
|
||||
return SLJIT_SUCCESS;
|
||||
}
|
||||
@@ -1167,16 +1168,20 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_si sljit_emit_return(struct sljit_compiler *compi
|
||||
if (local_size <= (63 * sizeof(sljit_sw)))
|
||||
offs = (local_size - saved_regs_size) << (15 - 3);
|
||||
else {
|
||||
- saved_regs_size += 2 * sizeof(sljit_sw);
|
||||
- local_size -= saved_regs_size;
|
||||
+ FAIL_IF(push_inst(compiler, LDP_PST | 29 | RT2(TMP_LR)
|
||||
+ | RN(TMP_SP) | (((16 >> 3) & 0x7f) << 15)));
|
||||
+ offs = 0 << 15;
|
||||
+ if (saved_regs_size & 0x8) {
|
||||
+ offs = 1 << 15;
|
||||
+ saved_regs_size += sizeof(sljit_sw);
|
||||
+ }
|
||||
+ local_size -= saved_regs_size + SLJIT_LOCALS_OFFSET;
|
||||
if (local_size > 0xfff) {
|
||||
FAIL_IF(push_inst(compiler, ADDI | RD(TMP_SP) | RN(TMP_SP) | ((local_size >> 12) << 10) | (1 << 22)));
|
||||
local_size &= 0xfff;
|
||||
}
|
||||
if (local_size)
|
||||
FAIL_IF(push_inst(compiler, ADDI | RD(TMP_SP) | RN(TMP_SP) | (local_size << 10)));
|
||||
- local_size = saved_regs_size;
|
||||
- offs = 2 << 15;
|
||||
}
|
||||
|
||||
tmp = compiler->saveds < SLJIT_NUMBER_OF_SAVED_REGISTERS ? (SLJIT_S0 + 1 - compiler->saveds) : SLJIT_FIRST_SAVED_REG;
|
||||
@@ -1204,8 +1209,12 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_si sljit_emit_return(struct sljit_compiler *compi
|
||||
if (prev != -1)
|
||||
FAIL_IF(push_inst(compiler, LDRI | RT(prev) | RN(TMP_SP) | (offs >> 5)));
|
||||
|
||||
- FAIL_IF(push_inst(compiler, LDP_PST | 29 | RT2(TMP_LR)
|
||||
- | RN(TMP_SP) | (((local_size >> 3) & 0x7f) << 15)));
|
||||
+ if (compiler->local_size <= (63 * sizeof(sljit_sw))) {
|
||||
+ FAIL_IF(push_inst(compiler, LDP_PST | 29 | RT2(TMP_LR)
|
||||
+ | RN(TMP_SP) | (((local_size >> 3) & 0x7f) << 15)));
|
||||
+ } else {
|
||||
+ FAIL_IF(push_inst(compiler, ADDI | RD(TMP_SP) | RN(TMP_SP) | (saved_regs_size << 10)));
|
||||
+ }
|
||||
|
||||
FAIL_IF(push_inst(compiler, RET | RN(TMP_LR)));
|
||||
return SLJIT_SUCCESS;
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,44 +0,0 @@
|
||||
From 2765d0933715e6b2c78a4e74fa8d5cad27273f29 Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>
|
||||
Date: Thu, 23 Apr 2015 17:34:33 +0000
|
||||
Subject: [PATCH] Fix static linking issue with pkg-config.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1552 2f5784b3-3f2a-0410-8824-cb99058d5e15
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
|
||||
diff --git a/libpcre.pc.in b/libpcre.pc.in
|
||||
index 1f26b32..0a35da8 100644
|
||||
--- a/libpcre.pc.in
|
||||
+++ b/libpcre.pc.in
|
||||
@@ -9,4 +9,5 @@ Name: libpcre
|
||||
Description: PCRE - Perl compatible regular expressions C library with 8 bit character support
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lpcre
|
||||
+Libs.private: @PTHREAD_CFLAGS@ @PTHREAD_LIBS@
|
||||
Cflags: -I${includedir} @PCRE_STATIC_CFLAG@
|
||||
diff --git a/libpcre16.pc.in b/libpcre16.pc.in
|
||||
index f589b75..080c9dc 100644
|
||||
--- a/libpcre16.pc.in
|
||||
+++ b/libpcre16.pc.in
|
||||
@@ -9,4 +9,5 @@ Name: libpcre16
|
||||
Description: PCRE - Perl compatible regular expressions C library with 16 bit character support
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lpcre16
|
||||
+Libs.private: @PTHREAD_CFLAGS@ @PTHREAD_LIBS@
|
||||
Cflags: -I${includedir} @PCRE_STATIC_CFLAG@
|
||||
diff --git a/libpcre32.pc.in b/libpcre32.pc.in
|
||||
index 6582105..a3ae0e1 100644
|
||||
--- a/libpcre32.pc.in
|
||||
+++ b/libpcre32.pc.in
|
||||
@@ -9,4 +9,5 @@ Name: libpcre32
|
||||
Description: PCRE - Perl compatible regular expressions C library with 32 bit character support
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lpcre32
|
||||
+Libs.private: @PTHREAD_CFLAGS@ @PTHREAD_LIBS@
|
||||
Cflags: -I${includedir} @PCRE_STATIC_CFLAG@
|
||||
--
|
||||
2.1.0
|
||||
|
14
pcre.spec
14
pcre.spec
@ -1,8 +1,8 @@
|
||||
# Is this a stable/testing release:
|
||||
%global rcversion RC1
|
||||
#%%global rcversion RC1
|
||||
Name: pcre
|
||||
Version: 8.37
|
||||
Release: %{?rcversion:0.}2%{?rcversion:.%rcversion}%{?dist}
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
|
||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||
Summary: Perl-compatible regular expression library
|
||||
Group: System Environment/Libraries
|
||||
@ -21,6 +21,7 @@ Group: System Environment/Libraries
|
||||
# aclocal.m4: (GPLv2+ or BSD) and FSFULLR
|
||||
# Makefile.in: FSFULLR
|
||||
# configure: FSFUL
|
||||
# testdata: Public Domain (see LICENSE file)
|
||||
## Binary packages:
|
||||
# other files: BSD
|
||||
License: BSD
|
||||
@ -30,10 +31,6 @@ Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/%{name}/%{?rcversion:Te
|
||||
Patch0: pcre-8.21-multilib.patch
|
||||
# Refused by upstream, bug #675477
|
||||
Patch1: pcre-8.32-refused_spelling_terminated.patch
|
||||
# Fix static linking, bug #1214494, in upstream after 8.37-RC1
|
||||
Patch2: pcre-8.37-RC1-Fix-static-linking-issue-with-pkg-config.patch
|
||||
# Fix JIT on AArch64, in upstream after 8.37-RC1
|
||||
Patch3: pcre-8.37-RC1-Fix-ARM64-SP-alignment-issue-in-JIT.patch
|
||||
BuildRequires: readline-devel
|
||||
# New libtool to get rid of rpath
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
@ -75,8 +72,6 @@ Utilities demonstrating PCRE capabilities like pcregrep or pcretest.
|
||||
# Get rid of rpath
|
||||
%patch0 -p1 -b .multilib
|
||||
%patch1 -p1 -b .terminated_typos
|
||||
%patch2 -p1 -b .static_linking
|
||||
%patch3 -p1 -b .aarch64_jit
|
||||
# Because of rpath patch
|
||||
libtoolize --copy --force && autoreconf -vif
|
||||
# One contributor's name is non-UTF-8
|
||||
@ -147,6 +142,9 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcretest.*
|
||||
|
||||
%changelog
|
||||
* Tue Apr 28 2015 Petr Pisar <ppisar@redhat.com> - 8.37-1
|
||||
- 8.37 bump
|
||||
|
||||
* Thu Apr 23 2015 Petr Pisar <ppisar@redhat.com> - 8.37-0.2.RC1
|
||||
- Fix static linking (bug #1214494)
|
||||
- Package pcredemo.c as a documentation for pcre-devel
|
||||
|
Loading…
Reference in New Issue
Block a user