Add (*LF) to a list of start-of-pattern options in the C++ wrapper
This commit is contained in:
parent
fd0c45c6e6
commit
46bf871629
@ -0,0 +1,28 @@
|
||||
From f74e04f2d8755fdd5cf5e387735593354972ad23 Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>
|
||||
Date: Thu, 23 May 2019 16:27:33 +0000
|
||||
Subject: [PATCH] Fix omission of (*LF) from list in the C++ wrapper.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1753 2f5784b3-3f2a-0410-8824-cb99058d5e15
|
||||
Petr Písař: Ported to 8.43.
|
||||
---
|
||||
pcrecpp.cc | 1 +
|
||||
|
||||
diff --git a/pcrecpp.cc b/pcrecpp.cc
|
||||
index 6a3eff8..0d6b140 100644
|
||||
--- a/pcrecpp.cc
|
||||
+++ b/pcrecpp.cc
|
||||
@@ -92,6 +92,7 @@ static const char *start_options[] = {
|
||||
"(*LIMIT_RECURSION=",
|
||||
"(*LIMIT_MATCH=",
|
||||
"(*CRLF)",
|
||||
+ "(*LF)",
|
||||
"(*CR)",
|
||||
"(*BSR_UNICODE)",
|
||||
"(*BSR_ANYCRLF)",
|
||||
--
|
||||
2.20.1
|
||||
|
10
pcre.spec
10
pcre.spec
@ -2,7 +2,7 @@
|
||||
#%%global rcversion RC1
|
||||
Name: pcre
|
||||
Version: 8.43
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
|
||||
Release: %{?rcversion:0.}2%{?rcversion:.%rcversion}%{?dist}
|
||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||
Summary: Perl-compatible regular expression library
|
||||
## Source package only:
|
||||
@ -40,6 +40,9 @@ Patch2: pcre-8.41-fix_stack_estimator.patch
|
||||
# This amends ABI, application built with this patch cannot run with
|
||||
# previous libpcreposix builds.
|
||||
Patch3: pcre-8.42-Declare-POSIX-regex-function-names-as-macros-to-PCRE.patch
|
||||
# Add (*LF) to a list of start-of-pattern options in the C++ wrapper,
|
||||
# upstream bug #2400, in upstream after 8.43
|
||||
Patch4: pcre-8.43-Fix-omission-of-LF-from-list-in-the-C-wrapper.patch
|
||||
BuildRequires: readline-devel
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -125,6 +128,7 @@ Utilities demonstrating PCRE capabilities like pcregrep or pcretest.
|
||||
%patch1 -p1
|
||||
%patch2 -p2
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
# Because of rpath patch
|
||||
libtoolize --copy --force
|
||||
autoreconf -vif
|
||||
@ -224,6 +228,10 @@ make %{?_smp_mflags} check VERBOSE=yes
|
||||
%{_mandir}/man1/pcretest.*
|
||||
|
||||
%changelog
|
||||
* Fri May 24 2019 Petr Pisar <ppisar@redhat.com> - 8.43-2
|
||||
- Add (*LF) to a list of start-of-pattern options in the C++ wrapper
|
||||
(upstream bug #2400)
|
||||
|
||||
* Mon Feb 25 2019 Petr Pisar <ppisar@redhat.com> - 8.43-1
|
||||
- 8.43 bump
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user