8.35-RC1 bump
Preliminary JIT support for aarch64 still fails the tests.
This commit is contained in:
parent
e4dd0bc521
commit
4096da0a47
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@ pcre-8.10.tar.bz2
|
||||
/pcre-8.33-RC1.tar.bz2
|
||||
/pcre-8.33.tar.bz2
|
||||
/pcre-8.34.tar.bz2
|
||||
/pcre-8.35-RC1.tar.bz2
|
||||
|
@ -1,55 +0,0 @@
|
||||
From c061f6a865a473cf93aae1e6a0ccd2325509a6b2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Thu, 9 Jan 2014 13:39:28 +0100
|
||||
Subject: [PATCH] Fix range check in JIT path
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Jitted range check was wrong:
|
||||
|
||||
re> /[efij]/S+
|
||||
data> e
|
||||
No match
|
||||
|
||||
while interpretted path is correct:
|
||||
|
||||
re> /[efij]/
|
||||
data> e
|
||||
0: e
|
||||
|
||||
This fix is part of:
|
||||
|
||||
commit c07887b22a83fba842e88889c9e57a622b9ee439
|
||||
Author: zherczeg <zherczeg@2f5784b3-3f2a-0410-8824-cb99058d5e15>
|
||||
Date: Sun Dec 22 20:47:08 2013 +0000
|
||||
|
||||
The auto-possessification of character sets were improved. The JIT compiler also optimizes more character set checks.
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1415 2f5784b3-3f2a-0410-8824-cb99058d5e15
|
||||
|
||||
<http://bugs.exim.org/show_bug.cgi?id=1423>
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
pcre_jit_compile.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pcre_jit_compile.c b/pcre_jit_compile.c
|
||||
index d070263..47447da 100644
|
||||
--- a/pcre_jit_compile.c
|
||||
+++ b/pcre_jit_compile.c
|
||||
@@ -3573,7 +3573,9 @@ switch(ranges[0])
|
||||
}
|
||||
return TRUE;
|
||||
}
|
||||
- if ((ranges[3] - ranges[2]) == (ranges[5] - ranges[4]) && is_powerof2(ranges[4] - ranges[2]))
|
||||
+ if ((ranges[3] - ranges[2]) == (ranges[5] - ranges[4])
|
||||
+ && (ranges[2] | (ranges[4] - ranges[2])) == ranges[4]
|
||||
+ && is_powerof2(ranges[4] - ranges[2]))
|
||||
{
|
||||
if (readch)
|
||||
read_char(common);
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,59 +0,0 @@
|
||||
From 2c970c22d75c6b2fda321a918b607766a0c2d4f3 Mon Sep 17 00:00:00 2001
|
||||
From: ph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>
|
||||
Date: Mon, 10 Mar 2014 16:28:54 +0000
|
||||
Subject: [PATCH] Fix typo that caused max/min quantifiers in ungreedy mode not
|
||||
to work.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1462 2f5784b3-3f2a-0410-8824-cb99058d5e15
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
|
||||
Petr Pisar: Ported to 8.34.
|
||||
|
||||
diff --git a/pcre_compile.c b/pcre_compile.c
|
||||
index 180a46c..8a5b723 100644
|
||||
--- a/pcre_compile.c
|
||||
+++ b/pcre_compile.c
|
||||
@@ -3642,7 +3642,7 @@ for (;;)
|
||||
break;
|
||||
|
||||
case OP_MINUPTO:
|
||||
- *code += OP_MINUPTO - OP_UPTO;
|
||||
+ *code += OP_POSUPTO - OP_MINUPTO;
|
||||
break;
|
||||
}
|
||||
}
|
||||
diff --git a/testdata/testinput2 b/testdata/testinput2
|
||||
index 71df1a8..da6e614 100644
|
||||
--- a/testdata/testinput2
|
||||
+++ b/testdata/testinput2
|
||||
@@ -907,6 +907,9 @@
|
||||
|
||||
/\U/I
|
||||
|
||||
+/a{1,3}b/U
|
||||
+ ab
|
||||
+
|
||||
/[/I
|
||||
|
||||
/[a-/I
|
||||
diff --git a/testdata/testoutput2 b/testdata/testoutput2
|
||||
index e9d3265..b6da7df 100644
|
||||
--- a/testdata/testoutput2
|
||||
+++ b/testdata/testoutput2
|
||||
@@ -3178,6 +3178,10 @@ Failed: PCRE does not support \L, \l, \N{name}, \U, or \u at offset 1
|
||||
/\U/I
|
||||
Failed: PCRE does not support \L, \l, \N{name}, \U, or \u at offset 1
|
||||
|
||||
+/a{1,3}b/U
|
||||
+ ab
|
||||
+ 0: ab
|
||||
+
|
||||
/[/I
|
||||
Failed: missing terminating ] for character class at offset 1
|
||||
|
||||
--
|
||||
1.8.5.3
|
||||
|
15
pcre.spec
15
pcre.spec
@ -1,8 +1,8 @@
|
||||
# This is stable release:
|
||||
#%%global rcversion RC1
|
||||
%global rcversion RC1
|
||||
Name: pcre
|
||||
Version: 8.34
|
||||
Release: %{?rcversion:0.}4%{?rcversion:.%rcversion}%{?dist}
|
||||
Version: 8.35
|
||||
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
|
||||
%global myversion %{version}%{?rcversion:-%rcversion}
|
||||
Summary: Perl-compatible regular expression library
|
||||
Group: System Environment/Libraries
|
||||
@ -13,10 +13,6 @@ Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/%{name}/%{?rcversion:Te
|
||||
Patch0: pcre-8.21-multilib.patch
|
||||
# Refused by upstream, bug #675477
|
||||
Patch1: pcre-8.32-refused_spelling_terminated.patch
|
||||
# Fix jitted range check, in upstream after 8.34, bug #1048097
|
||||
Patch2: pcre-8.34-Fix-range-check-in-JIT-path.patch
|
||||
# Fix max/min quantifiers in ungreedy mode, in upstream after 8.34, bug #1074500
|
||||
Patch3: pcre-8.34-Fix-typo-that-caused-max-min-quantifiers-in-ungreedy.patch
|
||||
BuildRequires: readline-devel
|
||||
# New libtool to get rid of rpath
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
@ -58,8 +54,6 @@ Utilities demonstrating PCRE capabilities like pcregrep or pcretest.
|
||||
# Get rid of rpath
|
||||
%patch0 -p1 -b .multilib
|
||||
%patch1 -p1 -b .terminated_typos
|
||||
%patch2 -p1 -b .jitted_range_check
|
||||
%patch3 -p1 -b .minmax_quantifier
|
||||
# Because of rpath patch
|
||||
libtoolize --copy --force && autoreconf -vif
|
||||
# One contributor's name is non-UTF-8
|
||||
@ -127,6 +121,9 @@ make check
|
||||
%{_mandir}/man1/pcretest.*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 14 2014 Petr Pisar <ppisar@redhat.com> - 8.35-0.1.RC1
|
||||
- 8.35-RC1 bump
|
||||
|
||||
* Tue Mar 11 2014 Petr Pisar <ppisar@redhat.com> - 8.34-4
|
||||
- Fix max/min quantifiers in ungreedy mode (bug #1074500)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user