8.30 RC1 bump

UTF-16 enabled too.
This commit is contained in:
Petr Písař 2012-01-04 16:15:27 +01:00
parent fbd137e285
commit 2bd0b1ba06
5 changed files with 82 additions and 122 deletions

View File

@ -1,30 +0,0 @@
From 7ff6515c706e881fe1388576e79d52243e290958 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 2 Jan 2012 12:27:29 +0100
Subject: [PATCH] Do not dereference NULL argument of pcre_free_study()
Back-ported from:
r836 | ph10 | 2011-12-28 18:16:11 +0100 (St, 28 pro 2011) | 2 lines
Merging all the changes from the pcre16 branch into the trunk.
Upstream bug #1186.
---
pcre_study.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/pcre_study.c b/pcre_study.c
index cb2f23e..0a3ecbc 100644
--- a/pcre_study.c
+++ b/pcre_study.c
@@ -1377,6 +1377,8 @@ Returns: nothing
PCRE_EXP_DEFN void
pcre_free_study(pcre_extra *extra)
{
+if (extra == NULL)
+ return;
#ifdef SUPPORT_JIT
if ((extra->flags & PCRE_EXTRA_EXECUTABLE_JIT) != 0 &&
extra->executable_jit != NULL)
--
1.7.7.5

View File

@ -1,73 +0,0 @@
From 1daa2332fb112a2868957e0ed42242e6115d0d72 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 2 Jan 2012 10:56:09 +0100
Subject: [PATCH] Do not make unmatched subpattern wildcard
Back-ported from:
r836 | ph10 | 2011-12-28 18:16:11 +0100 (St, 28 pro 2011) | 2 lines
Merging all the changes from the pcre16 branch into the trunk.
See <https://bugzilla.redhat.com/show_bug.cgi?id=769597> for more
details.
---
pcre_exec.c | 6 +++++-
testdata/testinput1 | 6 ++++++
testdata/testoutput1 | 10 ++++++++++
3 files changed, 21 insertions(+), 1 deletions(-)
diff --git a/pcre_exec.c b/pcre_exec.c
index 46498d5..a7cec30 100644
--- a/pcre_exec.c
+++ b/pcre_exec.c
@@ -2620,9 +2620,13 @@ for (;;)
}
/* Handle repeated back references. If the length of the reference is
- zero, just continue with the main loop. */
+ zero, just continue with the main loop. If the length is negative, it
+ means the reference is unset in non-Java-compatible mode. If the minimum is
+ zero, we can continue at the same level without recursion. For any other
+ minimum, carrying on will result in NOMATCH. */
if (length == 0) continue;
+ if (length < 0 && min == 0) continue;
/* First, ensure the minimum number of matches are present. We get back
the length of the reference string explicitly rather than passing the
diff --git a/testdata/testinput1 b/testdata/testinput1
index 36d7028..b41de5a 100644
--- a/testdata/testinput1
+++ b/testdata/testinput1
@@ -4318,4 +4318,10 @@
/a[\C-X]b/
aJb
+/(another)?(\1?)test/
+ hello world test
+
+/(another)?(\1+)test/
+ hello world test
+
/-- End of testinput1 --/
diff --git a/testdata/testoutput1 b/testdata/testoutput1
index bc237ab..2357ddb 100644
--- a/testdata/testoutput1
+++ b/testdata/testoutput1
@@ -7053,4 +7053,14 @@ No match
aJb
0: aJb
+/(another)?(\1?)test/
+ hello world test
+ 0: test
+ 1: <unset>
+ 2:
+
+/(another)?(\1+)test/
+ hello world test
+No match
+
/-- End of testinput1 --/
--
1.7.7.5

View File

@ -1,4 +1,4 @@
From a0530232f6ba0499bd14390fc54244fadd82b5d7 Mon Sep 17 00:00:00 2001
From 32caa8eafa03dac3252fca05f6b39cc55f9e85a7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 7 Feb 2011 11:37:09 +0100
Subject: [PATCH] Fix spelling in pcretest(1) manual
@ -18,13 +18,13 @@ British ones, as exemplified in the Collins.
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/doc/pcretest.1 b/doc/pcretest.1
index 2689bfa..cef1727 100644
index beb9d17..8f0552a 100644
--- a/doc/pcretest.1
+++ b/doc/pcretest.1
@@ -413,8 +413,8 @@ recognized:
@@ -467,8 +467,8 @@ recognized:
after a successful match (number less than 32)
.\" JOIN
\eCname call pcre_copy_named_substring() for substring
\eCname call pcre[16]_copy_named_substring() for substring
- "name" after a successful match (name termin-
- ated by next non alphanumeric character)
+ "name" after a successful match (name terminated
@ -32,10 +32,10 @@ index 2689bfa..cef1727 100644
.\" JOIN
\eC+ show the current captured substrings at callout
time
@@ -435,8 +435,8 @@ recognized:
@@ -489,8 +489,8 @@ recognized:
after a successful match (number less than 32)
.\" JOIN
\eGname call pcre_get_named_substring() for substring
\eGname call pcre[16]_get_named_substring() for substring
- "name" after a successful match (name termin-
- ated by next non-alphanumeric character)
+ "name" after a successful match (name terminated
@ -44,5 +44,5 @@ index 2689bfa..cef1727 100644
\eJdd set up a JIT stack of dd kilobytes maximum (any
number of digits)
--
1.7.6.1
1.7.7.6

View File

@ -0,0 +1,61 @@
Index: Makefile.am
===================================================================
--- Makefile.am (revision 906)
+++ Makefile.am (working copy)
@@ -521,31 +521,31 @@
# Arrange for the per-function man pages to have 16-bit names as well.
install-data-hook:
- ln -s $(DESTDIR)$(man3dir)/pcre_assign_jit_stack.3 $(DESTDIR)$(man3dir)/pcre16_assign_jit_stack.3
- ln -s $(DESTDIR)$(man3dir)/pcre_compile.3 $(DESTDIR)$(man3dir)/pcre16_compile.3
- ln -s $(DESTDIR)$(man3dir)/pcre_compile2.3 $(DESTDIR)$(man3dir)/pcre16_compile2.3
- ln -s $(DESTDIR)$(man3dir)/pcre_config.3 $(DESTDIR)$(man3dir)/pcre16_config.3
- ln -s $(DESTDIR)$(man3dir)/pcre_copy_named_substring.3 $(DESTDIR)$(man3dir)/pcre16_copy_named_substring.3
- ln -s $(DESTDIR)$(man3dir)/pcre_copy_substring.3 $(DESTDIR)$(man3dir)/pcre16_copy_substring.3
- ln -s $(DESTDIR)$(man3dir)/pcre_dfa_exec.3 $(DESTDIR)$(man3dir)/pcre16_dfa_exec.3
- ln -s $(DESTDIR)$(man3dir)/pcre_exec.3 $(DESTDIR)$(man3dir)/pcre16_exec.3
- ln -s $(DESTDIR)$(man3dir)/pcre_free_study.3 $(DESTDIR)$(man3dir)/pcre16_free_study.3
- ln -s $(DESTDIR)$(man3dir)/pcre_free_substring.3 $(DESTDIR)$(man3dir)/pcre16_free_substring.3
- ln -s $(DESTDIR)$(man3dir)/pcre_free_substring_list.3 $(DESTDIR)$(man3dir)/pcre16_free_substring_list.3
- ln -s $(DESTDIR)$(man3dir)/pcre_fullinfo.3 $(DESTDIR)$(man3dir)/pcre16_fullinfo.3
- ln -s $(DESTDIR)$(man3dir)/pcre_get_named_substring.3 $(DESTDIR)$(man3dir)/pcre16_get_named_substring.3
- ln -s $(DESTDIR)$(man3dir)/pcre_get_stringnumber.3 $(DESTDIR)$(man3dir)/pcre16_get_stringnumber.3
- ln -s $(DESTDIR)$(man3dir)/pcre_get_stringtable_entries.3 $(DESTDIR)$(man3dir)/pcre16_get_stringtable_entries.3
- ln -s $(DESTDIR)$(man3dir)/pcre_get_substring.3 $(DESTDIR)$(man3dir)/pcre16_get_substring.3
- ln -s $(DESTDIR)$(man3dir)/pcre_get_substring_list.3 $(DESTDIR)$(man3dir)/pcre16_get_substring_list.3
- ln -s $(DESTDIR)$(man3dir)/pcre_jit_stack_alloc.3 $(DESTDIR)$(man3dir)/pcre16_jit_stack_alloc.3
- ln -s $(DESTDIR)$(man3dir)/pcre_jit_stack_free.3 $(DESTDIR)$(man3dir)/pcre16_jit_stack_free.3
- ln -s $(DESTDIR)$(man3dir)/pcre_maketables.3 $(DESTDIR)$(man3dir)/pcre16_maketables.3
- ln -s $(DESTDIR)$(man3dir)/pcre_pattern_to_host_byte_order.3 $(DESTDIR)$(man3dir)/pcre16_pattern_to_host_byte_order.3
- ln -s $(DESTDIR)$(man3dir)/pcre_refcount.3 $(DESTDIR)$(man3dir)/pcre16_refcount.3
- ln -s $(DESTDIR)$(man3dir)/pcre_study.3 $(DESTDIR)$(man3dir)/pcre16_study.3
- ln -s $(DESTDIR)$(man3dir)/pcre_utf16_to_host_byte_order.3 $(DESTDIR)$(man3dir)/pcre16_utf16_to_host_byte_order.3
- ln -s $(DESTDIR)$(man3dir)/pcre_version.3 $(DESTDIR)$(man3dir)/pcre16_version.3
+ ln -s pcre_assign_jit_stack.3 $(DESTDIR)$(man3dir)/pcre16_assign_jit_stack.3
+ ln -s pcre_compile.3 $(DESTDIR)$(man3dir)/pcre16_compile.3
+ ln -s pcre_compile2.3 $(DESTDIR)$(man3dir)/pcre16_compile2.3
+ ln -s pcre_config.3 $(DESTDIR)$(man3dir)/pcre16_config.3
+ ln -s pcre_copy_named_substring.3 $(DESTDIR)$(man3dir)/pcre16_copy_named_substring.3
+ ln -s pcre_copy_substring.3 $(DESTDIR)$(man3dir)/pcre16_copy_substring.3
+ ln -s pcre_dfa_exec.3 $(DESTDIR)$(man3dir)/pcre16_dfa_exec.3
+ ln -s pcre_exec.3 $(DESTDIR)$(man3dir)/pcre16_exec.3
+ ln -s pcre_free_study.3 $(DESTDIR)$(man3dir)/pcre16_free_study.3
+ ln -s pcre_free_substring.3 $(DESTDIR)$(man3dir)/pcre16_free_substring.3
+ ln -s pcre_free_substring_list.3 $(DESTDIR)$(man3dir)/pcre16_free_substring_list.3
+ ln -s pcre_fullinfo.3 $(DESTDIR)$(man3dir)/pcre16_fullinfo.3
+ ln -s pcre_get_named_substring.3 $(DESTDIR)$(man3dir)/pcre16_get_named_substring.3
+ ln -s pcre_get_stringnumber.3 $(DESTDIR)$(man3dir)/pcre16_get_stringnumber.3
+ ln -s pcre_get_stringtable_entries.3 $(DESTDIR)$(man3dir)/pcre16_get_stringtable_entries.3
+ ln -s pcre_get_substring.3 $(DESTDIR)$(man3dir)/pcre16_get_substring.3
+ ln -s pcre_get_substring_list.3 $(DESTDIR)$(man3dir)/pcre16_get_substring_list.3
+ ln -s pcre_jit_stack_alloc.3 $(DESTDIR)$(man3dir)/pcre16_jit_stack_alloc.3
+ ln -s pcre_jit_stack_free.3 $(DESTDIR)$(man3dir)/pcre16_jit_stack_free.3
+ ln -s pcre_maketables.3 $(DESTDIR)$(man3dir)/pcre16_maketables.3
+ ln -s pcre_pattern_to_host_byte_order.3 $(DESTDIR)$(man3dir)/pcre16_pattern_to_host_byte_order.3
+ ln -s pcre_refcount.3 $(DESTDIR)$(man3dir)/pcre16_refcount.3
+ ln -s pcre_study.3 $(DESTDIR)$(man3dir)/pcre16_study.3
+ ln -s pcre_utf16_to_host_byte_order.3 $(DESTDIR)$(man3dir)/pcre16_utf16_to_host_byte_order.3
+ ln -s pcre_version.3 $(DESTDIR)$(man3dir)/pcre16_version.3
pcrecpp_man = doc/pcrecpp.3
EXTRA_DIST += $(pcrecpp_man)

View File

@ -1,8 +1,8 @@
# This is stable release:
#%%global rcversion RC1
%global rcversion RC1
Name: pcre
Version: 8.21
Release: %{?rcversion:0.}2%{?rcversion:.%rcversion}%{?dist}.1
Version: 8.30
Release: %{?rcversion:0.}1%{?rcversion:.%rcversion}%{?dist}
%global myversion %{version}%{?rcversion:-%rcversion}
Summary: Perl-compatible regular expression library
Group: System Environment/Libraries
@ -11,12 +11,10 @@ URL: http://www.pcre.org/
Source: ftp://ftp.csx.cam.ac.uk/pub/software/programming/%{name}/%{?rcversion:Testing/}%{name}-%{myversion}.tar.bz2
# Upstream thinks RPATH is good idea.
Patch0: pcre-8.21-multilib.patch
# Use relative symlinks in for manual pages, submitted to upstream
Patch1: pcre-8.30-relative_symlinks.patch
# Refused by upstream, bug #675477
Patch1: pcre-8.20-refused_spelling_terminated.patch
# Bug #769597, fixed by upstream after 8.21.
Patch2: pcre-8.21-Do-not-make-unmatched-subpattern-wildcard.patch
# Upstream bug #1186, fixed by upstream after 8.21.
Patch3: pcre-8.21-Do-not-dereference-NULL-argument-of-pcre_free_study.patch
Patch2: pcre-8.30-refused_spelling_terminated.patch
BuildRequires: readline-devel
# New libtool to get rid of rpath
BuildRequires: autoconf, automake, libtool
@ -55,10 +53,9 @@ Utilities demonstrating PCRE capabilities like pcregrep or pcretest.
%setup -q -n %{name}-%{myversion}
# Get rid of rpath
%patch0 -p1 -b .multilib
%patch1 -p0 -b .relative_symlinks
libtoolize --copy --force && autoreconf
%patch1 -p1 -b .terminated_typos
%patch2 -p1 -b .unmatched_subpattern
%patch3 -p1 -b .null_pcre_free_study
%patch2 -p1 -b .terminated_typos
# One contributor's name is non-UTF-8
for F in ChangeLog; do
iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
@ -73,7 +70,8 @@ done
%else
--enable-jit \
%endif
--enable-pcretest-libreadline --enable-utf8 --enable-unicode-properties
--enable-pcretest-libreadline --enable-utf --enable-unicode-properties \
--enable-pcre8 --enable-pcre16
make %{?_smp_mflags}
%install
@ -129,6 +127,10 @@ make check
%{_mandir}/man1/pcretest.*
%changelog
* Fri Jan 27 2012 Petr Pisar <ppisar@redhat.com> - 8.30-0.1.RC1
- 8.30 Relase candidate 1 with UTF-16 bump
- Enable UTF-16 variant of PCRE library
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.21-2.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild