Merge commits from 8.6 into 9.0.0 branch.
Related: rhbz#1991764
This commit is contained in:
parent
bf5a61994e
commit
faadd7c7e2
8
pcp.spec
8
pcp.spec
@ -1,6 +1,6 @@
|
||||
Name: pcp
|
||||
Version: 5.3.5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: System-level performance monitoring and performance management
|
||||
License: GPLv2+ and LGPLv2+ and CC-BY
|
||||
URL: https://pcp.io
|
||||
@ -8,6 +8,8 @@ URL: https://pcp.io
|
||||
%global artifactory https://performancecopilot.jfrog.io/artifactory
|
||||
Source0: %{artifactory}/pcp-source-release/pcp-%{version}.src.tar.gz
|
||||
|
||||
Patch0: redhat-bugzilla-2017632.patch
|
||||
|
||||
%if 0%{?fedora} >= 26 || 0%{?rhel} > 7
|
||||
%global __python2 python2
|
||||
%else
|
||||
@ -2275,6 +2277,7 @@ updated policy package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# the buildsubdir macro gets defined in %setup and is apparently only available in the next step (i.e. the %build step)
|
||||
@ -3385,6 +3388,9 @@ PCP_LOG_DIR=%{_logsdir}
|
||||
%files zeroconf -f pcp-zeroconf-files.rpm
|
||||
|
||||
%changelog
|
||||
* Fri Nov 26 2021 Nathan Scott <nathans@redhat.com> - 5.3.5-2
|
||||
- Updates to pmlogconf persistance changes (BZ 2017632)
|
||||
|
||||
* Wed Nov 10 2021 Nathan Scott <nathans@redhat.com> - 5.3.5-1
|
||||
- Update to latest PCP sources (BZ 1991764)
|
||||
|
||||
|
126
redhat-bugzilla-2017632.patch
Normal file
126
redhat-bugzilla-2017632.patch
Normal file
@ -0,0 +1,126 @@
|
||||
commit 343aef25472baa74c3a4669cf86b670d93d41dcb
|
||||
Author: Nathan Scott <nathans@redhat.com>
|
||||
Date: Tue Nov 23 16:11:24 2021 +1100
|
||||
|
||||
pmlogconf: fix reprobing with interactive changes
|
||||
|
||||
In testing an earlier persistance fix it was discovered
|
||||
that reprobe was inadvertently overwriting user requests
|
||||
for changes interactively.
|
||||
|
||||
Related to Red Hat BZ #2017632
|
||||
|
||||
diff --git a/qa/368.out b/qa/368.out
|
||||
index 829162f859..179a1142cf 100644
|
||||
--- a/qa/368.out
|
||||
+++ b/qa/368.out
|
||||
@@ -80,44 +80,10 @@ Differences ...
|
||||
Keep changes? [y]
|
||||
Group: qa group one
|
||||
Log this group? [y] ...
|
||||
-Differences ...
|
||||
-*** TMP.orig ...
|
||||
---- TMP.conf.new ...
|
||||
-***************
|
||||
-*** 22,35 ****
|
||||
- sample.long.million
|
||||
- }
|
||||
- #----
|
||||
-! #+ 02:x::
|
||||
-! #----
|
||||
-! #+ 03:y:default:
|
||||
-! ## qa group three
|
||||
- log advisory on default {
|
||||
-! sample.longlong.ten
|
||||
- }
|
||||
- #----
|
||||
- #+ 04:n:default:
|
||||
- ## qa group four
|
||||
- #----
|
||||
---- 22,36 ----
|
||||
- sample.long.million
|
||||
- }
|
||||
- #----
|
||||
-! #+ 02:y:default:
|
||||
-! ## qa group two
|
||||
- log advisory on default {
|
||||
-! sample.ulong.ten
|
||||
- }
|
||||
- #----
|
||||
-+ #+ 03:n:default:
|
||||
-+ ## qa group three
|
||||
-+ #----
|
||||
- #+ 04:n:default:
|
||||
- ## qa group four
|
||||
- #----
|
||||
-Keep changes? [y]
|
||||
+No changes
|
||||
+
|
||||
Group: qa group one
|
||||
-Log this group? [y] ......
|
||||
+Log this group? [y] .....
|
||||
Differences ...
|
||||
*** TMP.orig ...
|
||||
--- TMP.conf.new ...
|
||||
@@ -132,18 +98,8 @@ Differences ...
|
||||
#----
|
||||
--- 18,23 ----
|
||||
***************
|
||||
-*** 26,31 ****
|
||||
---- 25,31 ----
|
||||
- ## qa group two
|
||||
- log advisory on default {
|
||||
- sample.ulong.ten
|
||||
-+ sample.ulong.million
|
||||
- }
|
||||
- #----
|
||||
- #+ 03:n:default:
|
||||
-***************
|
||||
-*** 37,42 ****
|
||||
---- 37,53 ----
|
||||
+*** 36,41 ****
|
||||
+--- 35,51 ----
|
||||
#+ 05:n:default:
|
||||
## qa group five
|
||||
#----
|
||||
@@ -185,15 +141,13 @@ log advisory on default {
|
||||
sample.long.million
|
||||
}
|
||||
#----
|
||||
-#+ 02:y:default:
|
||||
-## qa group two
|
||||
-log advisory on default {
|
||||
- sample.ulong.ten
|
||||
- sample.ulong.million
|
||||
-}
|
||||
+#+ 02:x::
|
||||
#----
|
||||
-#+ 03:n:default:
|
||||
+#+ 03:y:default:
|
||||
## qa group three
|
||||
+log advisory on default {
|
||||
+ sample.longlong.ten
|
||||
+}
|
||||
#----
|
||||
#+ 04:n:default:
|
||||
## qa group four
|
||||
diff --git a/src/pmlogconf/pmlogconf.c b/src/pmlogconf/pmlogconf.c
|
||||
index c03c61e797..fa1156859d 100644
|
||||
--- a/src/pmlogconf/pmlogconf.c
|
||||
+++ b/src/pmlogconf/pmlogconf.c
|
||||
@@ -913,13 +913,13 @@ evaluate_state(group_t *group)
|
||||
if ((group->pmlogger || group->pmrep) && !group->pmlogconf) {
|
||||
state = group->saved_state;
|
||||
} else if (evaluate_group(group)) { /* probe */
|
||||
- if (reprobe == 0 && group->saved_state != 0)
|
||||
+ if (group->saved_state != 0)
|
||||
state = group->saved_state;
|
||||
else
|
||||
state = group->true_state;
|
||||
group->success = 1;
|
||||
} else {
|
||||
- if (reprobe == 0 && group->saved_state != 0)
|
||||
+ if (group->saved_state != 0)
|
||||
state = group->saved_state;
|
||||
else
|
||||
state = group->false_state;
|
Loading…
Reference in New Issue
Block a user