diff --git a/pcp.spec b/pcp.spec
index 352b9c8..8a4fad2 100644
--- a/pcp.spec
+++ b/pcp.spec
@@ -1,16 +1,11 @@
 Name:    pcp
-Version: 6.3.2
-Release: 5%{?dist}
+Version: 6.3.4
+Release: 1%{?dist}
 Summary: System-level performance monitoring and performance management
 License: GPL-2.0-or-later AND LGPL-2.1-or-later AND CC-BY-3.0
 URL:     https://pcp.io
 
 Source0: https://github.com/performancecopilot/pcp/releases/pcp-%{version}.src.tar.gz
-
-Patch0: pcp-xsos-fixes.patch
-Patch1: selinux-pmie-and-pmlogger.patch
-Patch2: big-endian-timestamps.patch
-
 %if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
 ExcludeArch: %{ix86}
 %endif
@@ -106,7 +101,7 @@ ExcludeArch: %{ix86}
 
 # support for pmdabcc, check bcc.spec for supported architectures of bcc
 %if 0%{?fedora} >= 25 || 0%{?rhel} > 6
-%ifarch x86_64 %{power64} aarch64 s390x
+%ifarch x86_64 %{power64} aarch64 s390x riscv64
 %global disable_bcc 0
 %else
 %global disable_bcc 1
@@ -117,7 +112,7 @@ ExcludeArch: %{ix86}
 
 # support for pmdabpf, check bcc.spec for supported architectures of libbpf-tools
 %if 0%{?fedora} >= 37 || 0%{?rhel} > 8
-%ifarch x86_64 %{power64} aarch64 s390x
+%ifarch x86_64 %{power64} aarch64 s390x riscv64
 %global disable_bpf 0
 %else
 %global disable_bpf 1
@@ -128,7 +123,7 @@ ExcludeArch: %{ix86}
 
 # support for pmdabpftrace, check bpftrace.spec for supported architectures of bpftrace
 %if 0%{?fedora} >= 30 || 0%{?rhel} > 7
-%ifarch x86_64 %{power64} aarch64 s390x
+%ifarch x86_64 %{power64} aarch64 s390x riscv64
 %global disable_bpftrace 0
 %else
 %global disable_bpftrace 1
@@ -351,7 +346,6 @@ Requires: pcp-selinux = %{version}-%{release}
 %global _pmdasdir       %{_localstatedir}/lib/pcp/pmdas
 %global _pmdasexecdir   %{_libexecdir}/pcp/pmdas
 %global _testsdir       %{_localstatedir}/lib/pcp/testsuite
-%global _ieconfigdir    %{_localstatedir}/lib/pcp/config/pmie
 %global _ieconfdir      %{_localstatedir}/lib/pcp/config/pmieconf
 %global _selinuxdir     %{_datadir}/selinux/packages/targeted
 
@@ -480,16 +474,6 @@ else
 fi
 }
 
-%global run_pmieconf() %{expand:
-if [ -d "%1" -a -w "%1" -a -w "%1/%2" ]
-then
-    pmieconf -f "%1/%2" -c enable "%3"
-    chown pcp:pcp "%1/%2" 2>/dev/null
-else
-    echo "WARNING: Cannot write to %1/%2, skipping pmieconf enable of %3." >&2
-fi
-}
-
 %description
 Performance Co-Pilot (PCP) provides a framework and services to support
 system-level performance monitoring and performance management.
@@ -2878,7 +2862,8 @@ done
 %if !%{disable_selinux}
 %selinux_relabel_pre -s targeted
 %endif
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%if 0%{?fedora} >= 42
+%elif 0%{?fedora} >= 32 || 0%{?rhel} >= 9
 echo u pcpqa - \"PCP Quality Assurance\" %{_testsdir} /bin/bash | \
   systemd-sysusers --replace=/usr/lib/sysusers.d/pcp-testsuite.conf -
 %else
@@ -2920,7 +2905,8 @@ fi
 %endif
 
 %pre
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%if 0%{?fedora} >= 42
+%elif 0%{?fedora} >= 32 || 0%{?rhel} >= 9
 echo u pcp - \"Performance Co-Pilot\" %{_localstatedir}/lib/pcp | \
   systemd-sysusers --replace=/usr/lib/sysusers.d/pcp.conf -
 %else
@@ -3220,7 +3206,6 @@ fi
 PCP_PMDAS_DIR=%{_pmdasdir}
 PCP_SYSCONFIG_DIR=%{_sysconfdir}/sysconfig
 PCP_PMCDCONF_PATH=%{_confdir}/pmcd/pmcd.conf
-PCP_PMIECONFIG_DIR=%{_ieconfigdir}
 # auto-install important PMDAs for RH Support (if not present already)
 for PMDA in dm nfsclient openmetrics ; do
     if ! grep -q "$PMDA/pmda$PMDA" "$PCP_PMCDCONF_PATH"
@@ -3228,8 +3213,6 @@ for PMDA in dm nfsclient openmetrics ; do
         %{install_file "$PCP_PMDAS_DIR/$PMDA" .NeedInstall}
     fi
 done
-# auto-enable these usually optional pmie rules
-%{run_pmieconf "$PCP_PMIECONFIG_DIR" config.default dmthin}
 # managed via /usr/lib/systemd/system-preset/90-default.preset nowadays:
 %if 0%{?rhel} > 0 && 0%{?rhel} < 10
 %if !%{disable_systemd}
@@ -3602,6 +3585,9 @@ fi
 %files zeroconf -f pcp-zeroconf-files.rpm
 
 %changelog
+* Fri Mar 14 2025 Nathan Scott <nathans@redhat.com> - 6.3.4-1
+- Update to latest stable version of PCP (RHEL-83468)
+
 * Fri Jan 31 2025 Nathan Scott <nathans@redhat.com> - 6.3.2-5
 - Fix writing of v3 archive timestamps on s390x (RHEL-69722)
 
diff --git a/sources b/sources
index 522878f..7096c44 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (pcp-6.3.2.src.tar.gz) = 812ed40b848675092ad27fed7265b5a09f3d4dc054748481d5c0bb4f534ab2caa5e4807b320f2969d8a779d0bbbe705866fec654b14d225bbedd721c91c3e257
+SHA512 (pcp-6.3.4.src.tar.gz) = 1c7ca82c1b2707aab1c505a87df7d4a3407a8a974e6209d2602b93e58bf50a84a08d3ecdbaf05ff8b97d7ca0007ee19a63aaee9299e9f874caefd6de5ba56120