import CS pcp-6.2.0-2.el9_4
This commit is contained in:
parent
bbcb0b03f8
commit
3240804836
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/pcp-6.0.1.src.tar.gz
|
||||
SOURCES/pcp-6.2.0.src.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
4f405e26a6c651b2f094134e0648cd5fd201d310 SOURCES/pcp-6.0.1.src.tar.gz
|
||||
617d0e505af5f253080effb6701e089fc02e7379 SOURCES/pcp-6.2.0.src.tar.gz
|
||||
|
@ -1,88 +0,0 @@
|
||||
diff --git a/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h b/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
index f84b1347bf..3c032f5230 100644
|
||||
--- a/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
+++ b/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
@@ -1678,6 +1678,7 @@ struct perf_event {
|
||||
int pending_wakeup;
|
||||
int pending_kill;
|
||||
int pending_disable;
|
||||
+ long unsigned int pending_addr;
|
||||
struct irq_work pending;
|
||||
atomic_t event_limit;
|
||||
struct perf_addr_filters_head addr_filters;
|
||||
@@ -1693,6 +1694,7 @@ struct perf_event {
|
||||
void *overflow_handler_context;
|
||||
perf_overflow_handler_t orig_overflow_handler;
|
||||
struct bpf_prog *prog;
|
||||
+ u64 bpf_cookie;
|
||||
struct trace_event_call *tp_event;
|
||||
struct event_filter *filter;
|
||||
struct ftrace_ops ftrace_ops;
|
||||
@@ -26070,7 +26072,10 @@ enum bpf_link_type {
|
||||
BPF_LINK_TYPE_ITER = 4,
|
||||
BPF_LINK_TYPE_NETNS = 5,
|
||||
BPF_LINK_TYPE_XDP = 6,
|
||||
- MAX_BPF_LINK_TYPE = 7,
|
||||
+ BPF_LINK_TYPE_PERF_EVENT = 7,
|
||||
+ BPF_LINK_TYPE_KPROBE_MULTI = 8,
|
||||
+ BPF_LINK_TYPE_STRUCT_OPS = 9,
|
||||
+ MAX_BPF_LINK_TYPE = 10,
|
||||
};
|
||||
|
||||
struct bpf_link_info {
|
||||
@@ -30363,6 +30368,11 @@ struct bpf_raw_tp_link {
|
||||
struct bpf_raw_event_map *btp;
|
||||
};
|
||||
|
||||
+struct bpf_perf_link {
|
||||
+ struct bpf_link link;
|
||||
+ struct file *perf_file;
|
||||
+};
|
||||
+
|
||||
struct btf_member {
|
||||
__u32 name_off;
|
||||
__u32 type;
|
||||
diff --git a/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h b/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
index 3b1b0127d1..052db391d4 100644
|
||||
--- a/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
+++ b/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
@@ -4345,6 +4345,7 @@ struct perf_event {
|
||||
int pending_wakeup;
|
||||
int pending_kill;
|
||||
int pending_disable;
|
||||
+ long unsigned int pending_addr;
|
||||
struct irq_work pending;
|
||||
atomic_t event_limit;
|
||||
struct perf_addr_filters_head addr_filters;
|
||||
@@ -4360,6 +4361,7 @@ struct perf_event {
|
||||
void *overflow_handler_context;
|
||||
perf_overflow_handler_t orig_overflow_handler;
|
||||
struct bpf_prog *prog;
|
||||
+ u64 bpf_cookie;
|
||||
struct trace_event_call *tp_event;
|
||||
struct event_filter *filter;
|
||||
struct ftrace_ops ftrace_ops;
|
||||
@@ -36449,7 +36451,10 @@ enum bpf_link_type {
|
||||
BPF_LINK_TYPE_ITER = 4,
|
||||
BPF_LINK_TYPE_NETNS = 5,
|
||||
BPF_LINK_TYPE_XDP = 6,
|
||||
- MAX_BPF_LINK_TYPE = 7,
|
||||
+ BPF_LINK_TYPE_PERF_EVENT = 7,
|
||||
+ BPF_LINK_TYPE_KPROBE_MULTI = 8,
|
||||
+ BPF_LINK_TYPE_STRUCT_OPS = 9,
|
||||
+ MAX_BPF_LINK_TYPE = 10,
|
||||
};
|
||||
|
||||
struct bpf_link_info {
|
||||
@@ -40756,6 +40761,11 @@ struct bpf_raw_tp_link {
|
||||
struct bpf_raw_event_map *btp;
|
||||
};
|
||||
|
||||
+struct bpf_perf_link {
|
||||
+ struct bpf_link link;
|
||||
+ struct file *perf_file;
|
||||
+};
|
||||
+
|
||||
struct btf_member {
|
||||
__u32 name_off;
|
||||
__u32 type;
|
@ -1,19 +0,0 @@
|
||||
commit 23bfdcbac0b0fb7bd33f092c6f2ad56889480335
|
||||
Author: Andreas Gerstmayr <agerstmayr@redhat.com>
|
||||
Date: Thu Oct 27 14:22:37 2022 +0200
|
||||
|
||||
build: use vendored vmlinux.h when compiling bpftool
|
||||
|
||||
diff --git a/vendor/GNUmakefile b/vendor/GNUmakefile
|
||||
index a0c29d4b45..57151e4671 100644
|
||||
--- a/vendor/GNUmakefile
|
||||
+++ b/vendor/GNUmakefile
|
||||
@@ -3,7 +3,7 @@ include $(TOPDIR)/src/include/builddefs
|
||||
|
||||
default_pcp default:
|
||||
ifeq "$(PMDA_BPF)" "true"
|
||||
- $(MAKE) -C github.com/libbpf/bpftool/src
|
||||
+ $(MAKE) -C github.com/libbpf/bpftool/src VMLINUX_H=$(PMDABPF_VMLINUXH)
|
||||
endif
|
||||
|
||||
install_pcp install:
|
@ -0,0 +1,12 @@
|
||||
diff -Naurp pcp-6.2.0.orig/src/include/pcp.conf.in pcp-6.2.0/src/include/pcp.conf.in
|
||||
--- pcp-6.2.0.orig/src/include/pcp.conf.in 2023-12-08 10:24:17.000000000 +1100
|
||||
+++ pcp-6.2.0/src/include/pcp.conf.in 2024-02-12 04:10:10.649953498 +1100
|
||||
@@ -140,7 +140,7 @@ PCP_ARCHIVE_DIR=@pcp_archive_dir@
|
||||
|
||||
# default version for generating PCP archives
|
||||
# Possible versions: 2, 3 (3 requires PCP 6+)
|
||||
-PCP_ARCHIVE_VERSION=3
|
||||
+PCP_ARCHIVE_VERSION=2
|
||||
|
||||
# directory for daily PCP activity reports
|
||||
# Standard path: /var/log/pcp/sa
|
35
SOURCES/redhat-issues-RHEL-25543-python-year-day-range.patch
Normal file
35
SOURCES/redhat-issues-RHEL-25543-python-year-day-range.patch
Normal file
@ -0,0 +1,35 @@
|
||||
commit ce6112399ebf0ff39069a34bc9286242c875555e
|
||||
Author: adam kaminski <adam@adamkaminski.com>
|
||||
Date: Fri Feb 9 12:49:34 2024 -0500
|
||||
|
||||
pmapi.py : fix for struct_time() and day of year out of range on yyyy-01-01
|
||||
|
||||
Fix for `day of year out of range` on 2024-01-01, due to self.tm_yday - 1, which returns `[2024, 1, 1, 2, 3, 0, 0, -1, 0]`. The range for tm_yday should be [1, 366].
|
||||
|
||||
# timedatectl set-ntp false
|
||||
# timedatectl set-time "2024-01-01 00:00:00"
|
||||
# /usr/libexec/pcp/bin/pcp-mpstat -P ALL -t 1 -s 2
|
||||
Traceback (most recent call last):
|
||||
File "/usr/libexec/pcp/bin/pcp-mpstat", line 653, in <module>
|
||||
sts = manager.run()
|
||||
File "/usr/lib64/python3.6/site-packages/pcp/pmcc.py", line 687, in run
|
||||
self._printer.report(self)
|
||||
File "/usr/libexec/pcp/bin/pcp-mpstat", line 606, in report
|
||||
self.print_machine_info(group, manager)
|
||||
File "/usr/libexec/pcp/bin/pcp-mpstat", line 585, in print_machine_info
|
||||
time_string = time.strftime("%x", timestamp.struct_time())
|
||||
ValueError: day of year out of range
|
||||
|
||||
diff --git a/src/python/pcp/pmapi.py b/src/python/pcp/pmapi.py
|
||||
index fd8d40e32c..05c8afb079 100644
|
||||
--- a/src/python/pcp/pmapi.py
|
||||
+++ b/src/python/pcp/pmapi.py
|
||||
@@ -330,7 +330,7 @@ class tm(Structure):
|
||||
pywday = 6
|
||||
stlist = [self.tm_year + 1900, self.tm_mon + 1, self.tm_mday,
|
||||
self.tm_hour, self.tm_min, self.tm_sec,
|
||||
- pywday, self.tm_yday - 1, self.tm_isdst]
|
||||
+ pywday, self.tm_yday + 1, self.tm_isdst]
|
||||
return time.struct_time(stlist)
|
||||
|
||||
def __str__(self):
|
491
SPECS/pcp.spec
491
SPECS/pcp.spec
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user