Rebase to pcp-6.0.4-1 and dropped earlier patches (upstreamed)
Resolves: rhbz#2175602 Resolves: rhbz#2166819 Resolves: rhbz#2185803
This commit is contained in:
parent
29a32a9c45
commit
3189c84fd5
22
pcp.spec
22
pcp.spec
@ -1,6 +1,6 @@
|
||||
Name: pcp
|
||||
Version: 6.0.1
|
||||
Release: 4%{?dist}
|
||||
Version: 6.0.4
|
||||
Release: 1%{?dist}
|
||||
Summary: System-level performance monitoring and performance management
|
||||
License: GPLv2+ and LGPLv2+ and CC-BY
|
||||
URL: https://pcp.io
|
||||
@ -8,9 +8,6 @@ URL: https://pcp.io
|
||||
%global artifactory https://performancecopilot.jfrog.io/artifactory
|
||||
Source0: %{artifactory}/pcp-source-release/pcp-%{version}.src.tar.gz
|
||||
|
||||
Patch0: redhat-bugzilla-2117074-vendored_vmlinux.h.patch
|
||||
Patch1: redhat-bugzilla-2117074-ppc_arm_vmlinux.h.patch
|
||||
|
||||
# The additional linker flags break out-of-tree PMDAs.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2043092
|
||||
%undefine _package_note_flags
|
||||
@ -96,8 +93,8 @@ Patch1: redhat-bugzilla-2117074-ppc_arm_vmlinux.h.patch
|
||||
%endif
|
||||
|
||||
# support for pmdabpf, check bcc.spec for supported architectures of libbpf-tools
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} > 8
|
||||
%ifarch x86_64 ppc64 ppc64le aarch64
|
||||
%if 0%{?fedora} >= 37 || 0%{?rhel} > 8
|
||||
%ifarch x86_64 %{power64} aarch64
|
||||
%global disable_bpf 0
|
||||
%else
|
||||
%global disable_bpf 1
|
||||
@ -280,7 +277,7 @@ BuildRequires: perl-devel perl(strict)
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) perl(LWP::UserAgent) perl(JSON)
|
||||
BuildRequires: perl(Time::HiRes) perl(Digest::MD5)
|
||||
BuildRequires: perl(XML::LibXML) perl(File::Slurp)
|
||||
BuildRequires: man %{_hostname_executable}
|
||||
BuildRequires: %{_hostname_executable}
|
||||
%if !%{disable_systemd}
|
||||
BuildRequires: systemd-devel
|
||||
%endif
|
||||
@ -2289,9 +2286,7 @@ updated policy package.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
# the buildsubdir macro gets defined in %%setup and is apparently only available in the next step (i.e. the %%build step)
|
||||
@ -3367,6 +3362,11 @@ fi
|
||||
%files zeroconf -f pcp-zeroconf-files.rpm
|
||||
|
||||
%changelog
|
||||
* Mon May 15 2023 Nathan Scott <nathans@redhat.com> - 6.0.4-1
|
||||
- Ensure pmcd.conf not rewritten needlessly (BZ 2166819)
|
||||
- Add support for pmieconf webhook action (BZ 2185803)
|
||||
- Rebase to latest stable version of PCP (BZ 2175602)
|
||||
|
||||
* Tue Jan 17 2023 Nathan Scott <nathans@redhat.com> - 6.0.1-4
|
||||
- Rebuild for dependency on new version of libbpf (BZ 2159276)
|
||||
|
||||
|
@ -1,88 +0,0 @@
|
||||
diff --git a/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h b/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
index f84b1347bf..3c032f5230 100644
|
||||
--- a/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
+++ b/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
@@ -1678,6 +1678,7 @@ struct perf_event {
|
||||
int pending_wakeup;
|
||||
int pending_kill;
|
||||
int pending_disable;
|
||||
+ long unsigned int pending_addr;
|
||||
struct irq_work pending;
|
||||
atomic_t event_limit;
|
||||
struct perf_addr_filters_head addr_filters;
|
||||
@@ -1693,6 +1694,7 @@ struct perf_event {
|
||||
void *overflow_handler_context;
|
||||
perf_overflow_handler_t orig_overflow_handler;
|
||||
struct bpf_prog *prog;
|
||||
+ u64 bpf_cookie;
|
||||
struct trace_event_call *tp_event;
|
||||
struct event_filter *filter;
|
||||
struct ftrace_ops ftrace_ops;
|
||||
@@ -26070,7 +26072,10 @@ enum bpf_link_type {
|
||||
BPF_LINK_TYPE_ITER = 4,
|
||||
BPF_LINK_TYPE_NETNS = 5,
|
||||
BPF_LINK_TYPE_XDP = 6,
|
||||
- MAX_BPF_LINK_TYPE = 7,
|
||||
+ BPF_LINK_TYPE_PERF_EVENT = 7,
|
||||
+ BPF_LINK_TYPE_KPROBE_MULTI = 8,
|
||||
+ BPF_LINK_TYPE_STRUCT_OPS = 9,
|
||||
+ MAX_BPF_LINK_TYPE = 10,
|
||||
};
|
||||
|
||||
struct bpf_link_info {
|
||||
@@ -30363,6 +30368,11 @@ struct bpf_raw_tp_link {
|
||||
struct bpf_raw_event_map *btp;
|
||||
};
|
||||
|
||||
+struct bpf_perf_link {
|
||||
+ struct bpf_link link;
|
||||
+ struct file *perf_file;
|
||||
+};
|
||||
+
|
||||
struct btf_member {
|
||||
__u32 name_off;
|
||||
__u32 type;
|
||||
diff --git a/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h b/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
index 3b1b0127d1..052db391d4 100644
|
||||
--- a/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
+++ b/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
@@ -4345,6 +4345,7 @@ struct perf_event {
|
||||
int pending_wakeup;
|
||||
int pending_kill;
|
||||
int pending_disable;
|
||||
+ long unsigned int pending_addr;
|
||||
struct irq_work pending;
|
||||
atomic_t event_limit;
|
||||
struct perf_addr_filters_head addr_filters;
|
||||
@@ -4360,6 +4361,7 @@ struct perf_event {
|
||||
void *overflow_handler_context;
|
||||
perf_overflow_handler_t orig_overflow_handler;
|
||||
struct bpf_prog *prog;
|
||||
+ u64 bpf_cookie;
|
||||
struct trace_event_call *tp_event;
|
||||
struct event_filter *filter;
|
||||
struct ftrace_ops ftrace_ops;
|
||||
@@ -36449,7 +36451,10 @@ enum bpf_link_type {
|
||||
BPF_LINK_TYPE_ITER = 4,
|
||||
BPF_LINK_TYPE_NETNS = 5,
|
||||
BPF_LINK_TYPE_XDP = 6,
|
||||
- MAX_BPF_LINK_TYPE = 7,
|
||||
+ BPF_LINK_TYPE_PERF_EVENT = 7,
|
||||
+ BPF_LINK_TYPE_KPROBE_MULTI = 8,
|
||||
+ BPF_LINK_TYPE_STRUCT_OPS = 9,
|
||||
+ MAX_BPF_LINK_TYPE = 10,
|
||||
};
|
||||
|
||||
struct bpf_link_info {
|
||||
@@ -40756,6 +40761,11 @@ struct bpf_raw_tp_link {
|
||||
struct bpf_raw_event_map *btp;
|
||||
};
|
||||
|
||||
+struct bpf_perf_link {
|
||||
+ struct bpf_link link;
|
||||
+ struct file *perf_file;
|
||||
+};
|
||||
+
|
||||
struct btf_member {
|
||||
__u32 name_off;
|
||||
__u32 type;
|
@ -1,19 +0,0 @@
|
||||
commit 23bfdcbac0b0fb7bd33f092c6f2ad56889480335
|
||||
Author: Andreas Gerstmayr <agerstmayr@redhat.com>
|
||||
Date: Thu Oct 27 14:22:37 2022 +0200
|
||||
|
||||
build: use vendored vmlinux.h when compiling bpftool
|
||||
|
||||
diff --git a/vendor/GNUmakefile b/vendor/GNUmakefile
|
||||
index a0c29d4b45..57151e4671 100644
|
||||
--- a/vendor/GNUmakefile
|
||||
+++ b/vendor/GNUmakefile
|
||||
@@ -3,7 +3,7 @@ include $(TOPDIR)/src/include/builddefs
|
||||
|
||||
default_pcp default:
|
||||
ifeq "$(PMDA_BPF)" "true"
|
||||
- $(MAKE) -C github.com/libbpf/bpftool/src
|
||||
+ $(MAKE) -C github.com/libbpf/bpftool/src VMLINUX_H=$(PMDABPF_VMLINUXH)
|
||||
endif
|
||||
|
||||
install_pcp install:
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pcp-6.0.1.src.tar.gz) = 922b787a2f28aab6355cb701500890ae83ee93b55047b65f142f9767619b2fbf91abe555106f9aa3f52f851fdb0413a92582dcf8f4dbb49894c2a557e80da5fd
|
||||
SHA512 (pcp-6.0.4.src.tar.gz) = 36d0743d680830b1bfaaef7bedb63e95a1a015e1d27643c27119d31b760ba90c9160c8197e36f2f62061d7c34e12ef7267251a5d8e6304ea7a9a4f6daf1165b1
|
||||
|
Loading…
Reference in New Issue
Block a user