Update to latest community sources
This commit is contained in:
parent
34b119e820
commit
2f7f8fc93f
@ -1,68 +0,0 @@
|
||||
Avoid calling the undeclared exit function. Include <string.h> for
|
||||
strcmp. Improves compatibility with future compilers which are likely
|
||||
to reject implicit function declarations by default.
|
||||
|
||||
Submitted upstream:
|
||||
|
||||
<https://github.com/performancecopilot/pcp/pull/1727>
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index d8726f045b264191..f285191756825493 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -14409,7 +14409,7 @@ main ()
|
||||
{
|
||||
|
||||
double x = 123.456;
|
||||
- if (fpclassify(x) == FP_NAN) exit(1);
|
||||
+ if (fpclassify(x) == FP_NAN) return 1;
|
||||
|
||||
;
|
||||
return 0;
|
||||
@@ -14438,7 +14438,7 @@ main ()
|
||||
{
|
||||
|
||||
double x = 123.456;
|
||||
- if (fpclassify(x) == FP_NAN) exit(1);
|
||||
+ if (fpclassify(x) == FP_NAN) return 1;
|
||||
|
||||
;
|
||||
return 0;
|
||||
@@ -16433,6 +16433,7 @@ else
|
||||
/* end confdefs.h. */
|
||||
|
||||
#include <time.h>
|
||||
+#include <string.h>
|
||||
int main () {
|
||||
char b[32]="";
|
||||
time_t t = time(NULL);
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f12e652dd5e6f20e..4f737c78ff63e670 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3097,7 +3097,7 @@ AC_TRY_LINK(
|
||||
],
|
||||
[
|
||||
double x = 123.456;
|
||||
- if (fpclassify(x) == FP_NAN) exit(1);
|
||||
+ if (fpclassify(x) == FP_NAN) return 1;
|
||||
], ac_cv_func_fpclassify=yes)
|
||||
AC_MSG_RESULT($ac_cv_func_fpclassify)
|
||||
if test $ac_cv_func_fpclassify = no
|
||||
@@ -3112,7 +3112,7 @@ then
|
||||
],
|
||||
[
|
||||
double x = 123.456;
|
||||
- if (fpclassify(x) == FP_NAN) exit(1);
|
||||
+ if (fpclassify(x) == FP_NAN) return 1;
|
||||
], ac_cv_func_fpclassify=yes)
|
||||
AC_MSG_RESULT($ac_cv_func_fpclassify)
|
||||
if test $ac_cv_func_fpclassify = yes
|
||||
@@ -3737,6 +3737,7 @@ AC_MSG_CHECKING([if strftime knows about %z])
|
||||
AC_TRY_RUN(
|
||||
[
|
||||
#include <time.h>
|
||||
+#include <string.h>
|
||||
int main () {
|
||||
char b[32]="";
|
||||
time_t t = time(NULL);
|
13
pcp.spec
13
pcp.spec
@ -1,13 +1,12 @@
|
||||
Name: pcp
|
||||
Version: 6.0.1
|
||||
Release: 5%{?dist}
|
||||
Version: 6.0.2
|
||||
Release: 1%{?dist}
|
||||
Summary: System-level performance monitoring and performance management
|
||||
License: GPLv2+ and LGPLv2+ and CC-BY
|
||||
URL: https://pcp.io
|
||||
|
||||
%global artifactory https://performancecopilot.jfrog.io/artifactory
|
||||
Source0: %{artifactory}/pcp-source-release/pcp-%{version}.src.tar.gz
|
||||
Patch0: pcp-configure-c99.patch
|
||||
|
||||
# The additional linker flags break out-of-tree PMDAs.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2043092
|
||||
@ -3372,6 +3371,10 @@ fi
|
||||
%files zeroconf -f pcp-zeroconf-files.rpm
|
||||
|
||||
%changelog
|
||||
* Mon Feb 13 2023 Nathan Scott <nathans@redhat.com> - 6.0.2-1
|
||||
- Resolve a dstat swap plugin related failure (BZ 2168774)
|
||||
- Update to latest PCP sources.
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
@ -3381,10 +3384,6 @@ fi
|
||||
* Thu Nov 03 2022 Jiri Olsa <jolsa@kernel.org> - 6.0.1-3
|
||||
- rebuilt for libbpf 1.0
|
||||
|
||||
* Fri Nov 11 2022 Nathan Scott <nathans@redhat.com> - 6.0.1-2
|
||||
- Resolve an issue with installing sysusers entries
|
||||
- Fix RPM spec file scriptlet relating to pmieconf (BZ 2139720)
|
||||
|
||||
* Thu Oct 27 2022 Nathan Scott <nathans@redhat.com> - 6.0.1-1
|
||||
- Resolve a BPF module related build failure (BZ 2132998)
|
||||
- Update to latest PCP sources.
|
||||
|
@ -1,20 +0,0 @@
|
||||
commit d2dff63a0f4d4eacafa16c561b4b9e32c59f248c
|
||||
Author: Nathan Scott <nathans@redhat.com>
|
||||
Date: Fri Apr 8 08:19:32 2022 +1000
|
||||
|
||||
build: fix translation of PCP_SYSCONFIG_DIR in pmie unit file
|
||||
|
||||
Resolves Red Hat BZ #2072971
|
||||
|
||||
diff --git a/src/pmie/GNUmakefile b/src/pmie/GNUmakefile
|
||||
index e0525d49e8..dc182e444a 100644
|
||||
--- a/src/pmie/GNUmakefile
|
||||
+++ b/src/pmie/GNUmakefile
|
||||
@@ -80,6 +80,7 @@ pmie.service : pmie.service.in
|
||||
$(SED) <$< >$@ \
|
||||
-e 's;@PCP_RC_DIR@;'$(PCP_RC_DIR)';' \
|
||||
-e 's;@PCP_RUN_DIR@;'$(PCP_RUN_DIR)';' \
|
||||
+ -e 's;@PCP_SYSCONFIG_DIR@;'$(PCP_SYSCONFIG_DIR)';' \
|
||||
# END
|
||||
|
||||
pmie_farm.service : pmie_farm.service.in
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pcp-6.0.1.src.tar.gz) = 922b787a2f28aab6355cb701500890ae83ee93b55047b65f142f9767619b2fbf91abe555106f9aa3f52f851fdb0413a92582dcf8f4dbb49894c2a557e80da5fd
|
||||
SHA512 (pcp-6.0.2.src.tar.gz) = 537dc44a3951c9aad1b31d283bfb36708e0480d2ac9ba469e7ed11ad00f90dd666999ec7e250e811a3bf66565f4f3aac31cf11b8efccadd02b4f19cfcc50d7d1
|
||||
|
Loading…
Reference in New Issue
Block a user