Back-port fix from upstream PCP for pcp-ss option mishandling
Resolves: RHEL-17649
This commit is contained in:
parent
4df5da50db
commit
1e8da71c53
4
pcp.spec
4
pcp.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pcp
|
Name: pcp
|
||||||
Version: 6.1.1
|
Version: 6.1.1
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: System-level performance monitoring and performance management
|
Summary: System-level performance monitoring and performance management
|
||||||
License: GPL-2.0-or-later AND LGPL-2.1-or-later AND CC-BY-3.0
|
License: GPL-2.0-or-later AND LGPL-2.1-or-later AND CC-BY-3.0
|
||||||
URL: https://pcp.io
|
URL: https://pcp.io
|
||||||
@ -3452,7 +3452,7 @@ fi
|
|||||||
%files zeroconf -f pcp-zeroconf-files.rpm
|
%files zeroconf -f pcp-zeroconf-files.rpm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Dec 13 2023 Nathan Scott <nathans@redhat.com> - 6.1.1-3
|
* Thu Dec 14 2023 Nathan Scott <nathans@redhat.com> - 6.1.1-4
|
||||||
- Fix pcp-ss(1) handling of UDP packet states (RHEL-17649)
|
- Fix pcp-ss(1) handling of UDP packet states (RHEL-17649)
|
||||||
|
|
||||||
* Wed Nov 29 2023 Nathan Scott <nathans@redhat.com> - 6.1.1-2
|
* Wed Nov 29 2023 Nathan Scott <nathans@redhat.com> - 6.1.1-2
|
||||||
|
@ -265,3 +265,31 @@ index 72e0607c1..74952911a 100755
|
|||||||
return args
|
return args
|
||||||
|
|
||||||
def connect(self):
|
def connect(self):
|
||||||
|
commit 79fdfd6d01f3e1d2d8449af3a7d9e56f9bfc65b2
|
||||||
|
Author: Jan Kurik <jkurik@redhat.com>
|
||||||
|
Date: Wed Dec 13 18:03:08 2023 +0100
|
||||||
|
|
||||||
|
Fixed crash of interpreter when using -t/-u option
|
||||||
|
|
||||||
|
Cleanup of remained code for unix and raw sockets causing python
|
||||||
|
interpreter to crash, generating a traceback.
|
||||||
|
|
||||||
|
diff --git a/src/pcp/ss/pcp-ss.py b/src/pcp/ss/pcp-ss.py
|
||||||
|
index 74952911a..5cf8ef939 100755
|
||||||
|
--- a/src/pcp/ss/pcp-ss.py
|
||||||
|
+++ b/src/pcp/ss/pcp-ss.py
|
||||||
|
@@ -253,10 +253,10 @@ class SS(object):
|
||||||
|
elif self.args.udp and netid == "udp":
|
||||||
|
state = self.valuesD["state"][inst]
|
||||||
|
ret = bool(state != "UNCONN" or self.args.listening)
|
||||||
|
- elif self.args.unix and netid == "unix":
|
||||||
|
- ret = True
|
||||||
|
- elif self.args.raw and netid == "raw":
|
||||||
|
- ret = True
|
||||||
|
+ #elif self.args.unix and netid == "unix":
|
||||||
|
+ # ret = True
|
||||||
|
+ #elif self.args.raw and netid == "raw":
|
||||||
|
+ # ret = True
|
||||||
|
return ret
|
||||||
|
|
||||||
|
def filter_ipv46(self, inst):
|
||||||
|
Loading…
Reference in New Issue
Block a user