Rebase to pcp-6.0.1-1 with a PowerPC+Arm64 patch for vendor libbpf builds
Resolves: rhbz#1941873 Resolves: rhbz#2117074 Resolves: rhbz#2127037
This commit is contained in:
parent
73db89f91d
commit
0312f7febd
2
pcp.spec
2
pcp.spec
@ -12,7 +12,7 @@ Source1: %{pcp_git_url}/main/debian/pcp-testsuite.sysusers
|
||||
Source2: %{pcp_git_url}/main/debian/pcp.sysusers
|
||||
|
||||
Patch0: redhat-bugzilla-2117074-vendored_vmlinux.h.patch
|
||||
Patch1: redhat-bugzilla-2117074-powerpc_vmlinux.h.patch
|
||||
Patch1: redhat-bugzilla-2117074-ppc_arm_vmlinux.h.patch
|
||||
|
||||
# The additional linker flags break out-of-tree PMDAs.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2043092
|
||||
|
@ -1,3 +1,47 @@
|
||||
diff --git a/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h b/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
index f84b1347bf..353bef0797 100644
|
||||
--- a/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
+++ b/vendor/github.com/iovisor/bcc/libbpf-tools/arm64/vmlinux_510.h
|
||||
@@ -1678,6 +1678,7 @@ struct perf_event {
|
||||
int pending_wakeup;
|
||||
int pending_kill;
|
||||
int pending_disable;
|
||||
+ long unsigned int pending_addr;
|
||||
struct irq_work pending;
|
||||
atomic_t event_limit;
|
||||
struct perf_addr_filters_head addr_filters;
|
||||
@@ -1693,6 +1694,7 @@ struct perf_event {
|
||||
void *overflow_handler_context;
|
||||
perf_overflow_handler_t orig_overflow_handler;
|
||||
struct bpf_prog *prog;
|
||||
+ u64 bpf_cookie;
|
||||
struct trace_event_call *tp_event;
|
||||
struct event_filter *filter;
|
||||
struct ftrace_ops ftrace_ops;
|
||||
@@ -26070,7 +26072,10 @@ enum bpf_link_type {
|
||||
BPF_LINK_TYPE_ITER = 4,
|
||||
BPF_LINK_TYPE_NETNS = 5,
|
||||
BPF_LINK_TYPE_XDP = 6,
|
||||
- MAX_BPF_LINK_TYPE = 7,
|
||||
+ BPF_LINK_TYPE_PERF_EVENT = 7,
|
||||
+ BPF_LINK_TYPE_KPROBE_MULTI = 8,
|
||||
+ BPF_LINK_TYPE_STRUCT_OPS = 9,
|
||||
+ MAX_BPF_LINK_TYPE = 10,
|
||||
};
|
||||
|
||||
struct bpf_link_info {
|
||||
@@ -30363,6 +30368,11 @@ struct bpf_raw_tp_link {
|
||||
struct bpf_raw_event_map *btp;
|
||||
};
|
||||
|
||||
+struct bpf_perf_link {
|
||||
+ struct bpf_link link;
|
||||
+ file *perf_file;
|
||||
+};
|
||||
+
|
||||
struct btf_member {
|
||||
__u32 name_off;
|
||||
__u32 type;
|
||||
diff --git a/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h b/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
||||
index 3b1b0127d1..052db391d4 100644
|
||||
--- a/vendor/github.com/iovisor/bcc/libbpf-tools/powerpc/vmlinux_510.h
|
Loading…
Reference in New Issue
Block a user