pciutils/pciutils-strip.patch
cvsdist 668e42c621 auto-import changelog data from pciutils-2.1.11-4.src.rpm
Mon Dec 08 2003 Bill Nottingham <notting@redhat.com> 2.1.11-4
- fix paths for pci.ids, etc. (#111665)
Tue Nov 25 2003 Bill Nottingham <notting@redhat.com> 2.1.11-3
- remove a few calls to ->error() in the sysfs code
Fri Nov 21 2003 Jeremy Katz <katzj@redhat.com> 2.1.11-2
- build a diet libpci_loader.a on i386
- always assume pread exists, it does with diet and all vaguely recent
    glibc
Fri Nov 21 2003 Bill Nottingham <notting@redhat.com> 2.1.11-1
- update to 2.1.11
- add patch for sysfs & pci domains support (<willy@debian.org>)
2004-09-09 10:02:02 +00:00

43 lines
1.4 KiB
Diff

--- pciutils-2.1.10/Makefile.strip 2002-03-30 10:42:16.000000000 -0500
+++ pciutils-2.1.10/Makefile 2002-07-18 21:15:59.000000000 -0400
@@ -2,7 +2,7 @@
# Makefile for Linux PCI Utilities
# (c) 1998--2002 Martin Mares <mj@ucw.cz>
-OPT=-O2 -fomit-frame-pointer
+OPT=-O2
#OPT=-O2 -g
CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes
@@ -59,7 +59,7 @@
install: all
# -c is ignored on Linux, but required on FreeBSD
$(DIRINSTALL) -m 755 $(SBINDIR) $(SHAREDIR) $(MANDIR)/man8
- $(INSTALL) -c -m 755 -s lspci setpci $(SBINDIR)
+ $(INSTALL) -c -m 755 lspci setpci $(SBINDIR)
$(INSTALL) -c -m 755 update-pciids $(SBINDIR)
$(INSTALL) -c -m 644 pci.ids $(SHAREDIR)
$(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(MANDIR)/man8
--- pciutils-2.1.9/lspci.c.old Tue May 28 23:54:03 2002
+++ pciutils-2.1.9/lspci.c Wed May 29 00:29:39 2002
@@ -1506,7 +1506,7 @@
break;
case 's':
if (msg = pci_filter_parse_slot(&filter, optarg))
- die("-f: %s", msg);
+ die("-s: %s", msg);
break;
case 'd':
if (msg = pci_filter_parse_id(&filter, optarg))
--- pciutils-2.1.10/Makefile.foo 2002-10-15 15:37:50.000000000 -0400
+++ pciutils-2.1.10/Makefile 2002-10-15 15:36:57.000000000 -0400
@@ -36,7 +36,7 @@
all: lib lspci setpci lspci.8 setpci.8 pci.ids
lib: lib/config.h
- $(MAKE) -C lib all
+ CFLAGS="$(CFLAGS) -fPIC" $(MAKE) -C lib all
lib/config.h:
cd lib && ./configure $(PREFIX) $(VERSION)