Upstream patch to fix removal of empty directories (bug #919489).
Resolves: rhbz#919489
This commit is contained in:
parent
c29b7a7132
commit
caefda1113
57
patch-remove-empty-dir.patch
Normal file
57
patch-remove-empty-dir.patch
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
diff -up patch-2.7.1/src/patch.c.remove-empty-dir patch-2.7.1/src/patch.c
|
||||||
|
--- patch-2.7.1/src/patch.c.remove-empty-dir 2012-10-18 17:57:41.708586721 +0100
|
||||||
|
+++ patch-2.7.1/src/patch.c 2013-03-11 11:35:54.607901400 +0000
|
||||||
|
@@ -646,8 +646,8 @@ main (int argc, char **argv)
|
||||||
|
if (outstate.ofp && (ferror (outstate.ofp) || fclose (outstate.ofp) != 0))
|
||||||
|
write_fatal ();
|
||||||
|
output_files (NULL);
|
||||||
|
- delete_files ();
|
||||||
|
cleanup ();
|
||||||
|
+ delete_files ();
|
||||||
|
if (somefailed)
|
||||||
|
exit (1);
|
||||||
|
return 0;
|
||||||
|
diff -up patch-2.7.1/tests/Makefile.am.remove-empty-dir patch-2.7.1/tests/Makefile.am
|
||||||
|
--- patch-2.7.1/tests/Makefile.am.remove-empty-dir 2012-09-14 10:15:22.000000000 +0100
|
||||||
|
+++ patch-2.7.1/tests/Makefile.am 2013-03-11 11:35:54.619901466 +0000
|
||||||
|
@@ -49,6 +49,7 @@ TESTS = \
|
||||||
|
reject-format \
|
||||||
|
remember-backup-files \
|
||||||
|
remember-reject-files \
|
||||||
|
+ remove-directories \
|
||||||
|
symlinks \
|
||||||
|
unmodified-files
|
||||||
|
|
||||||
|
diff -up patch-2.7.1/tests/remove-directories.remove-empty-dir patch-2.7.1/tests/remove-directories
|
||||||
|
--- patch-2.7.1/tests/remove-directories.remove-empty-dir 2013-03-11 11:35:54.619901466 +0000
|
||||||
|
+++ patch-2.7.1/tests/remove-directories 2013-03-11 11:35:54.619901466 +0000
|
||||||
|
@@ -0,0 +1,29 @@
|
||||||
|
+# Copyright (C) 2013 Free Software Foundation, Inc.
|
||||||
|
+#
|
||||||
|
+# Copying and distribution of this file, with or without modification,
|
||||||
|
+# in any medium, are permitted without royalty provided the copyright
|
||||||
|
+# notice and this notice are preserved.
|
||||||
|
+
|
||||||
|
+. $srcdir/test-lib.sh
|
||||||
|
+
|
||||||
|
+require_cat
|
||||||
|
+use_local_patch
|
||||||
|
+use_tmpdir
|
||||||
|
+
|
||||||
|
+# ==============================================================
|
||||||
|
+# Remove empty parent diectories when removing a file
|
||||||
|
+
|
||||||
|
+mkdir dir
|
||||||
|
+echo foobar > dir/file
|
||||||
|
+cat > apatch <<EOF
|
||||||
|
+--- dir/file
|
||||||
|
++++ /dev/null
|
||||||
|
+@@ -1 +0,0 @@
|
||||||
|
+-foobar
|
||||||
|
+EOF
|
||||||
|
+
|
||||||
|
+check 'patch -p0 -E < apatch' <<EOF
|
||||||
|
+patching file dir/file
|
||||||
|
+EOF
|
||||||
|
+
|
||||||
|
+ncheck '! test -e dir'
|
@ -1,11 +1,12 @@
|
|||||||
Summary: Utility for modifying/upgrading files
|
Summary: Utility for modifying/upgrading files
|
||||||
Name: patch
|
Name: patch
|
||||||
Version: 2.7.1
|
Version: 2.7.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/patch/patch.html
|
URL: http://www.gnu.org/software/patch/patch.html
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Source: ftp://ftp.gnu.org/gnu/patch/patch-%{version}.tar.xz
|
Source: ftp://ftp.gnu.org/gnu/patch/patch-%{version}.tar.xz
|
||||||
|
Patch1: patch-remove-empty-dir.patch
|
||||||
Patch100: patch-selinux.patch
|
Patch100: patch-selinux.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -25,6 +26,9 @@ applications.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
# Upstream patch to fix removal of empty directories (bug #919489).
|
||||||
|
%patch1 -p1 -b .remove-empty-dir
|
||||||
|
|
||||||
# SELinux support.
|
# SELinux support.
|
||||||
%patch100 -p1 -b .selinux
|
%patch100 -p1 -b .selinux
|
||||||
|
|
||||||
@ -53,6 +57,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 11 2013 Tim Waugh <twaugh@redhat.com> 2.7.1-3
|
||||||
|
- Upstream patch to fix removal of empty directories (bug #919489).
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user