Merge branch 'f12' into f13
This commit is contained in:
commit
a1c89f8d7e
12
patch-get-arg.patch
Normal file
12
patch-get-arg.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up patch-2.6.1/src/patch.c.get-arg patch-2.6.1/src/patch.c
|
||||
--- patch-2.6.1/src/patch.c.get-arg 2010-07-27 18:05:26.217150510 +0100
|
||||
+++ patch-2.6.1/src/patch.c 2010-07-27 18:05:47.464150892 +0100
|
||||
@@ -558,7 +558,7 @@ static struct option const longopts[] =
|
||||
{"remove-empty-files", no_argument, NULL, 'E'},
|
||||
{"force", no_argument, NULL, 'f'},
|
||||
{"fuzz", required_argument, NULL, 'F'},
|
||||
- {"get", no_argument, NULL, 'g'},
|
||||
+ {"get", required_argument, NULL, 'g'},
|
||||
{"input", required_argument, NULL, 'i'},
|
||||
{"ignore-whitespace", no_argument, NULL, 'l'},
|
||||
#ifdef ENABLE_MERGE
|
@ -83,7 +83,7 @@ diff -up patch-2.6/src/patch.c.selinux patch-2.6/src/patch.c
|
||||
+ if (! inerrno && incontext)
|
||||
+ {
|
||||
+ security_context_t outcontext;
|
||||
+ if (! getfilecon (outname, &outcontext) &&
|
||||
+ if (getfilecon (outname, &outcontext) != -1 &&
|
||||
+ outcontext &&
|
||||
+ strcmp(outcontext, incontext) &&
|
||||
+ setfilecon (outname, incontext) != 0)
|
||||
|
16
patch.spec
16
patch.spec
@ -1,12 +1,13 @@
|
||||
Summary: Utility for modifying/upgrading files
|
||||
Name: patch
|
||||
Version: 2.6.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv2+
|
||||
URL: http://www.gnu.org/software/patch/patch.html
|
||||
Group: Development/Tools
|
||||
Source: ftp://ftp.gnu.org/gnu/patch/patch-%{version}.tar.xz
|
||||
Patch1: patch-2.5.4-sigsegv.patch
|
||||
Patch2: patch-get-arg.patch
|
||||
Patch100: patch-selinux.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -29,11 +30,17 @@ applications.
|
||||
# Avoid segfault.
|
||||
%patch1 -p1 -b .sigsegv
|
||||
|
||||
# Fixed argument type for --get (bug #553624).
|
||||
%patch2 -p1 -b .get-arg
|
||||
|
||||
# SELinux support.
|
||||
%patch100 -p1 -b .selinux
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
||||
%ifarch sparcv9
|
||||
CFLAGS=`echo $CFLAGS|sed -e 's|-fstack-protector||g'`
|
||||
%endif
|
||||
%configure
|
||||
make %{?smp_mflags}
|
||||
|
||||
@ -54,6 +61,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Fri Aug 6 2010 Tim Waugh <twaugh@redhat.com> 2.6.1-3
|
||||
- Fixed interpretation of return value from getfilecon().
|
||||
- Fixed argument type for --get (bug #553624).
|
||||
|
||||
* Wed Mar 10 2010 Dennis Gilmore <dennis@ausil.us>
|
||||
- using -fstack-projector causes weirdness on 32 bit sparc so disabling for now
|
||||
|
||||
* Wed Mar 3 2010 Tim Waugh <twaugh@redhat.com> 2.6.1-2
|
||||
- Added comments for all patches.
|
||||
- Ship COPYING file.
|
||||
|
Loading…
Reference in New Issue
Block a user