- Fix selinux patch and apply it.
This commit is contained in:
parent
a1ecfbae1c
commit
638a40acb1
@ -1,6 +1,6 @@
|
|||||||
diff -up patch-2.5.4/patch.c.selinux patch-2.5.4/patch.c
|
diff -up patch-2.5.4/patch.c.selinux patch-2.5.4/patch.c
|
||||||
--- patch-2.5.4/patch.c.selinux 2007-10-04 16:58:38.000000000 +0100
|
--- patch-2.5.4/patch.c.selinux 2008-06-12 11:09:17.000000000 +0100
|
||||||
+++ patch-2.5.4/patch.c 2007-10-04 16:58:38.000000000 +0100
|
+++ patch-2.5.4/patch.c 2008-06-12 11:09:17.000000000 +0100
|
||||||
@@ -414,6 +414,13 @@ main (int argc, char **argv)
|
@@ -414,6 +414,13 @@ main (int argc, char **argv)
|
||||||
if (! inerrno && chmod (outname, instat.st_mode) != 0)
|
if (! inerrno && chmod (outname, instat.st_mode) != 0)
|
||||||
pfatal ("Can't set permissions on file %s",
|
pfatal ("Can't set permissions on file %s",
|
||||||
@ -15,77 +15,10 @@ diff -up patch-2.5.4/patch.c.selinux patch-2.5.4/patch.c
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
diff -up patch-2.5.4/common.h.selinux patch-2.5.4/common.h
|
|
||||||
--- patch-2.5.4/common.h.selinux 1999-08-30 07:20:08.000000000 +0100
|
|
||||||
+++ patch-2.5.4/common.h 2007-10-04 16:58:38.000000000 +0100
|
|
||||||
@@ -39,6 +39,8 @@
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <time.h>
|
|
||||||
|
|
||||||
+#include <selinux/selinux.h>
|
|
||||||
+
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#if ! defined S_ISDIR && defined S_IFDIR
|
|
||||||
# define S_ISDIR(m) (((m) & S_IFMT) == S_IFDIR)
|
|
||||||
@@ -168,6 +170,7 @@ XTERN char *outfile;
|
|
||||||
XTERN int inerrno;
|
|
||||||
XTERN int invc;
|
|
||||||
XTERN struct stat instat;
|
|
||||||
+XTERN security_context_t incontext;
|
|
||||||
XTERN bool dry_run;
|
|
||||||
XTERN bool posixly_correct;
|
|
||||||
|
|
||||||
diff -up patch-2.5.4/inp.c.selinux patch-2.5.4/inp.c
|
|
||||||
--- patch-2.5.4/inp.c.selinux 2007-10-04 16:58:38.000000000 +0100
|
|
||||||
+++ patch-2.5.4/inp.c 2007-10-04 16:58:38.000000000 +0100
|
|
||||||
@@ -154,7 +154,15 @@ get_input_file (char const *filename, ch
|
|
||||||
char *getbuf;
|
|
||||||
|
|
||||||
if (inerrno == -1)
|
|
||||||
- inerrno = stat (inname, &instat) == 0 ? 0 : errno;
|
|
||||||
+ {
|
|
||||||
+ inerrno = stat (inname, &instat) == 0 ? 0 : errno;
|
|
||||||
+ inerrno = getfilecon (inname, &incontext) == 0 ? 0 : errno;
|
|
||||||
+ if (inerrno == ENODATA || inerrno == ENOTSUP)
|
|
||||||
+ {
|
|
||||||
+ inerrno = 0;
|
|
||||||
+ incontext = NULL;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* Perhaps look for RCS or SCCS versions. */
|
|
||||||
if (patch_get
|
|
||||||
@@ -196,7 +204,7 @@ get_input_file (char const *filename, ch
|
|
||||||
}
|
|
||||||
|
|
||||||
if (cs && version_get (filename, cs, ! inerrno, elsewhere, getbuf,
|
|
||||||
- &instat))
|
|
||||||
+ &instat, &incontext))
|
|
||||||
inerrno = 0;
|
|
||||||
|
|
||||||
free (getbuf);
|
|
||||||
@@ -213,6 +221,7 @@ get_input_file (char const *filename, ch
|
|
||||||
{
|
|
||||||
instat.st_mode = S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH;
|
|
||||||
instat.st_size = 0;
|
|
||||||
+ incontext = NULL;
|
|
||||||
}
|
|
||||||
else if (! S_ISREG (instat.st_mode))
|
|
||||||
fatal ("File %s is not a regular file -- can't patch",
|
|
||||||
diff -up patch-2.5.4/util.c.selinux patch-2.5.4/util.c
|
diff -up patch-2.5.4/util.c.selinux patch-2.5.4/util.c
|
||||||
--- patch-2.5.4/util.c.selinux 2007-10-04 16:58:38.000000000 +0100
|
--- patch-2.5.4/util.c.selinux 2008-06-12 11:09:17.000000000 +0100
|
||||||
+++ patch-2.5.4/util.c 2007-10-04 16:58:38.000000000 +0100
|
+++ patch-2.5.4/util.c 2008-06-12 11:12:01.000000000 +0100
|
||||||
@@ -266,7 +266,8 @@ static char const CLEARTOOL_CO[] = "clea
|
@@ -375,7 +375,8 @@ version_controller (char const *filename
|
||||||
*GETBUF and *DIFFBUF must be freed by the caller. */
|
|
||||||
char const *
|
|
||||||
version_controller (char const *filename, int readonly,
|
|
||||||
- struct stat const *filestat, char **getbuf, char **diffbuf)
|
|
||||||
+ struct stat const *filestat,
|
|
||||||
+ char **getbuf, char **diffbuf)
|
|
||||||
{
|
|
||||||
struct stat cstat;
|
|
||||||
char const *filebase = base_name (filename);
|
|
||||||
@@ -375,7 +376,8 @@ version_controller (char const *filename
|
|
||||||
Return nonzero if successful. */
|
Return nonzero if successful. */
|
||||||
int
|
int
|
||||||
version_get (char const *filename, char const *cs, int exists, int readonly,
|
version_get (char const *filename, char const *cs, int exists, int readonly,
|
||||||
@ -95,11 +28,11 @@ diff -up patch-2.5.4/util.c.selinux patch-2.5.4/util.c
|
|||||||
{
|
{
|
||||||
if (patch_get < 0)
|
if (patch_get < 0)
|
||||||
{
|
{
|
||||||
@@ -400,6 +402,13 @@ version_get (char const *filename, char
|
@@ -400,6 +401,13 @@ version_get (char const *filename, char
|
||||||
fatal ("Can't get file %s from %s", quotearg (filename), cs);
|
fatal ("Can't get file %s from %s", quotearg (filename), cs);
|
||||||
if (stat (filename, filestat) != 0)
|
if (stat (filename, filestat) != 0)
|
||||||
pfatal ("%s", quotearg (filename));
|
pfatal ("%s", quotearg (filename));
|
||||||
+ if (filecontext && getfilecon (filename, filecontext) != 0)
|
+ if (filecontext && getfilecon (filename, filecontext) == -1)
|
||||||
+ {
|
+ {
|
||||||
+ if (errno == ENODATA || errno == ENOTSUP)
|
+ if (errno == ENODATA || errno == ENOTSUP)
|
||||||
+ *filecontext = NULL;
|
+ *filecontext = NULL;
|
||||||
@ -111,7 +44,7 @@ diff -up patch-2.5.4/util.c.selinux patch-2.5.4/util.c
|
|||||||
return 1;
|
return 1;
|
||||||
diff -up patch-2.5.4/util.h.selinux patch-2.5.4/util.h
|
diff -up patch-2.5.4/util.h.selinux patch-2.5.4/util.h
|
||||||
--- patch-2.5.4/util.h.selinux 1999-08-30 07:20:08.000000000 +0100
|
--- patch-2.5.4/util.h.selinux 1999-08-30 07:20:08.000000000 +0100
|
||||||
+++ patch-2.5.4/util.h 2007-10-04 16:58:38.000000000 +0100
|
+++ patch-2.5.4/util.h 2008-06-12 11:09:17.000000000 +0100
|
||||||
@@ -21,7 +21,7 @@ char *fetchname PARAMS ((char *, int, ti
|
@@ -21,7 +21,7 @@ char *fetchname PARAMS ((char *, int, ti
|
||||||
char *savebuf PARAMS ((char const *, size_t));
|
char *savebuf PARAMS ((char const *, size_t));
|
||||||
char *savestr PARAMS ((char const *));
|
char *savestr PARAMS ((char const *));
|
||||||
@ -121,15 +54,69 @@ diff -up patch-2.5.4/util.h.selinux patch-2.5.4/util.h
|
|||||||
int create_file PARAMS ((char const *, int, mode_t));
|
int create_file PARAMS ((char const *, int, mode_t));
|
||||||
int systemic PARAMS ((char const *));
|
int systemic PARAMS ((char const *));
|
||||||
char *format_linenum PARAMS ((char[LINENUM_LENGTH_BOUND + 1], LINENUM));
|
char *format_linenum PARAMS ((char[LINENUM_LENGTH_BOUND + 1], LINENUM));
|
||||||
|
diff -up patch-2.5.4/Makefile.in.selinux patch-2.5.4/Makefile.in
|
||||||
|
--- patch-2.5.4/Makefile.in.selinux 1999-08-30 07:37:54.000000000 +0100
|
||||||
|
+++ patch-2.5.4/Makefile.in 2008-06-12 11:09:17.000000000 +0100
|
||||||
|
@@ -36,7 +36,7 @@ DEFS = @DEFS@
|
||||||
|
EXEEXT = @EXEEXT@
|
||||||
|
LDFLAGS = @LDFLAGS@
|
||||||
|
LIBOBJS = @LIBOBJS@
|
||||||
|
-LIBS = @LIBS@
|
||||||
|
+LIBS = @LIBS@ -lselinux
|
||||||
|
PACKAGE = @PACKAGE@
|
||||||
|
U = @U@
|
||||||
|
VERSION = @VERSION@
|
||||||
|
diff -up patch-2.5.4/inp.c.selinux patch-2.5.4/inp.c
|
||||||
|
--- patch-2.5.4/inp.c.selinux 2008-06-12 11:09:17.000000000 +0100
|
||||||
|
+++ patch-2.5.4/inp.c 2008-06-12 11:11:08.000000000 +0100
|
||||||
|
@@ -154,7 +154,20 @@ get_input_file (char const *filename, ch
|
||||||
|
char *getbuf;
|
||||||
|
|
||||||
|
if (inerrno == -1)
|
||||||
|
- inerrno = stat (inname, &instat) == 0 ? 0 : errno;
|
||||||
|
+ {
|
||||||
|
+ inerrno = stat (inname, &instat) == 0 ? 0 : errno;
|
||||||
|
+ if (inerrno == 0)
|
||||||
|
+ {
|
||||||
|
+ inerrno = getfilecon (inname, &incontext) == -1 ? errno : 0;
|
||||||
|
+ if (inerrno == ENODATA || inerrno == ENOTSUP)
|
||||||
|
+ {
|
||||||
|
+ inerrno = 0;
|
||||||
|
+ incontext = NULL;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ incontext = NULL;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
/* Perhaps look for RCS or SCCS versions. */
|
||||||
|
if (patch_get
|
||||||
|
@@ -196,7 +209,7 @@ get_input_file (char const *filename, ch
|
||||||
|
}
|
||||||
|
|
||||||
|
if (cs && version_get (filename, cs, ! inerrno, elsewhere, getbuf,
|
||||||
|
- &instat))
|
||||||
|
+ &instat, &incontext))
|
||||||
|
inerrno = 0;
|
||||||
|
|
||||||
|
free (getbuf);
|
||||||
|
@@ -213,6 +226,7 @@ get_input_file (char const *filename, ch
|
||||||
|
{
|
||||||
|
instat.st_mode = S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH;
|
||||||
|
instat.st_size = 0;
|
||||||
|
+ incontext = NULL;
|
||||||
|
}
|
||||||
|
else if (! S_ISREG (instat.st_mode))
|
||||||
|
fatal ("File %s is not a regular file -- can't patch",
|
||||||
diff -up patch-2.5.4/pch.c.selinux patch-2.5.4/pch.c
|
diff -up patch-2.5.4/pch.c.selinux patch-2.5.4/pch.c
|
||||||
--- patch-2.5.4/pch.c.selinux 2007-10-04 16:58:38.000000000 +0100
|
--- patch-2.5.4/pch.c.selinux 2008-06-12 11:09:17.000000000 +0100
|
||||||
+++ patch-2.5.4/pch.c 2007-10-04 16:58:38.000000000 +0100
|
+++ patch-2.5.4/pch.c 2008-06-12 11:11:48.000000000 +0100
|
||||||
@@ -258,7 +258,12 @@ there_is_another_patch (void)
|
@@ -258,7 +258,12 @@ there_is_another_patch (void)
|
||||||
{
|
{
|
||||||
if (stat (inname, &instat) == 0)
|
if (stat (inname, &instat) == 0)
|
||||||
{
|
{
|
||||||
- inerrno = 0;
|
- inerrno = 0;
|
||||||
+ inerrno = getfilecon (inname, &incontext) == 0 ? 0 : errno;
|
+ inerrno = getfilecon (inname, &incontext) == -1 ? errno : 0;
|
||||||
+ if (inerrno == ENODATA || inerrno == ENOTSUP)
|
+ if (inerrno == ENODATA || inerrno == ENOTSUP)
|
||||||
+ {
|
+ {
|
||||||
+ inerrno = 0;
|
+ inerrno = 0;
|
||||||
@ -147,15 +134,31 @@ diff -up patch-2.5.4/pch.c.selinux patch-2.5.4/pch.c
|
|||||||
stat_errno[i] = 0;
|
stat_errno[i] = 0;
|
||||||
else
|
else
|
||||||
version_controlled[i] = 0;
|
version_controlled[i] = 0;
|
||||||
diff -up patch-2.5.4/Makefile.in.selinux patch-2.5.4/Makefile.in
|
@@ -641,6 +646,7 @@ intuit_diff_type (void)
|
||||||
--- patch-2.5.4/Makefile.in.selinux 2007-10-04 16:59:09.000000000 +0100
|
inerrno = stat_errno[i];
|
||||||
+++ patch-2.5.4/Makefile.in 2007-10-04 17:00:59.000000000 +0100
|
invc = version_controlled[i];
|
||||||
@@ -36,7 +36,7 @@ DEFS = @DEFS@
|
instat = st[i];
|
||||||
EXEEXT = @EXEEXT@
|
+ getfilecon (inname, &incontext);
|
||||||
LDFLAGS = @LDFLAGS@
|
}
|
||||||
LIBOBJS = @LIBOBJS@
|
|
||||||
-LIBS = @LIBS@
|
for (i = OLD; i <= INDEX; i++)
|
||||||
+LIBS = @LIBS@ -lselinux
|
diff -up patch-2.5.4/common.h.selinux patch-2.5.4/common.h
|
||||||
PACKAGE = @PACKAGE@
|
--- patch-2.5.4/common.h.selinux 1999-08-30 07:20:08.000000000 +0100
|
||||||
U = @U@
|
+++ patch-2.5.4/common.h 2008-06-12 11:09:17.000000000 +0100
|
||||||
VERSION = @VERSION@
|
@@ -39,6 +39,8 @@
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <time.h>
|
||||||
|
|
||||||
|
+#include <selinux/selinux.h>
|
||||||
|
+
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#if ! defined S_ISDIR && defined S_IFDIR
|
||||||
|
# define S_ISDIR(m) (((m) & S_IFMT) == S_IFDIR)
|
||||||
|
@@ -168,6 +170,7 @@ XTERN char *outfile;
|
||||||
|
XTERN int inerrno;
|
||||||
|
XTERN int invc;
|
||||||
|
XTERN struct stat instat;
|
||||||
|
+XTERN security_context_t incontext;
|
||||||
|
XTERN bool dry_run;
|
||||||
|
XTERN bool posixly_correct;
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: The GNU patch command, for modifying/upgrading files
|
Summary: The GNU patch command, for modifying/upgrading files
|
||||||
Name: patch
|
Name: patch
|
||||||
Version: 2.5.4
|
Version: 2.5.4
|
||||||
Release: 32%{?dist}
|
Release: 33%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnu.org/software/patch/patch.html
|
URL: http://www.gnu.org/software/patch/patch.html
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -37,7 +37,7 @@ applications.
|
|||||||
%patch6 -p1 -b .stripcr
|
%patch6 -p1 -b .stripcr
|
||||||
%patch7 -p1 -b .parse
|
%patch7 -p1 -b .parse
|
||||||
%patch8 -p1 -b .allow-spaces
|
%patch8 -p1 -b .allow-spaces
|
||||||
#%patch9 -p1 -b .selinux
|
%patch9 -p1 -b .selinux
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
||||||
@ -64,6 +64,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 12 2008 Tim Waugh <twaugh@redhat.com> 2.5.4-33
|
||||||
|
- Fix selinux patch and apply it.
|
||||||
|
|
||||||
* Fri Feb 8 2008 Tim Waugh <twaugh@redhat.com> 2.5.4-32
|
* Fri Feb 8 2008 Tim Waugh <twaugh@redhat.com> 2.5.4-32
|
||||||
- Applied patch from 2.5.9 to allow spaces in filenames (bug #431887).
|
- Applied patch from 2.5.9 to allow spaces in filenames (bug #431887).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user