disable -fstack-protector on 32 bit sparc for now
This commit is contained in:
parent
5e47e3921e
commit
45dc7c0183
@ -1,11 +0,0 @@
|
|||||||
--- patch-2.6.1/src/bestmatch.h.BAD 2010-03-10 17:55:53.000000000 +0000
|
|
||||||
+++ patch-2.6.1/src/bestmatch.h 2010-03-10 17:57:04.000000000 +0000
|
|
||||||
@@ -150,7 +150,7 @@
|
|
||||||
|
|
||||||
done:
|
|
||||||
if (py)
|
|
||||||
- *py = ymax;
|
|
||||||
+ *py = (signed int)ymax;
|
|
||||||
return c;
|
|
||||||
}
|
|
||||||
|
|
12
patch.spec
12
patch.spec
@ -7,7 +7,6 @@ URL: http://www.gnu.org/software/patch/patch.html
|
|||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Source: ftp://ftp.gnu.org/gnu/patch/patch-%{version}.tar.xz
|
Source: ftp://ftp.gnu.org/gnu/patch/patch-%{version}.tar.xz
|
||||||
Patch1: patch-2.5.4-sigsegv.patch
|
Patch1: patch-2.5.4-sigsegv.patch
|
||||||
Patch2: patch-2.6.1-merge-sigbus.patch
|
|
||||||
Patch100: patch-selinux.patch
|
Patch100: patch-selinux.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -28,18 +27,15 @@ applications.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .sigsegv
|
%patch1 -p1 -b .sigsegv
|
||||||
%patch100 -p1 -b .selinux
|
%patch100 -p1 -b .selinux
|
||||||
%patch2 -p1 -b .sigbus
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
||||||
|
%ifarch sparcv9
|
||||||
|
CFLAGS=`echo $CFLAGS|sed -e 's|-fstack-protector||g'`
|
||||||
|
%endif
|
||||||
%configure
|
%configure
|
||||||
|
|
||||||
# XXX unset CPPFLAGS on (ultra?)sparc to avoid large file system support
|
|
||||||
%ifarch %{sparc}
|
|
||||||
make CPPFLAGS=""
|
|
||||||
%else
|
|
||||||
make %{?smp_mflags}
|
make %{?smp_mflags}
|
||||||
%endif
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make check
|
make check
|
||||||
@ -59,7 +55,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Mar 10 2010 Dennis Gilmore <dennis@ausil.us> 2.6.1-2
|
* Wed Mar 10 2010 Dennis Gilmore <dennis@ausil.us> 2.6.1-2
|
||||||
- add patch to fix sigbus in merge code
|
- using -fstack-projector causes weirdness on 32 bit sparc so disabling for now
|
||||||
|
|
||||||
* Mon Jan 4 2010 Tim Waugh <twaugh@redhat.com> 2.6.1-1
|
* Mon Jan 4 2010 Tim Waugh <twaugh@redhat.com> 2.6.1-1
|
||||||
- 2.6.1 (bug #551569). No longer need best-name patch.
|
- 2.6.1 (bug #551569). No longer need best-name patch.
|
||||||
|
Loading…
Reference in New Issue
Block a user