Merge branch 'f22'

This commit is contained in:
Tim Waugh 2015-03-09 09:40:19 +00:00
commit 4223c430fb
2 changed files with 68 additions and 59 deletions

View File

@ -1,6 +1,6 @@
diff -up patch-2.7.4/src/common.h.selinux patch-2.7.4/src/common.h
--- patch-2.7.4/src/common.h.selinux 2015-01-31 16:09:46.000000000 +0000
+++ patch-2.7.4/src/common.h 2015-02-01 12:46:56.922818144 +0000
diff -up patch-2.7.5/src/common.h.selinux patch-2.7.5/src/common.h
--- patch-2.7.5/src/common.h.selinux 2015-02-28 16:02:30.000000000 +0000
+++ patch-2.7.5/src/common.h 2015-03-09 09:29:46.083415914 +0000
@@ -30,6 +30,8 @@
#include <sys/types.h>
#include <time.h>
@ -18,9 +18,9 @@ diff -up patch-2.7.4/src/common.h.selinux patch-2.7.4/src/common.h
XTERN bool dry_run;
XTERN bool posixly_correct;
diff -up patch-2.7.4/src/inp.c.selinux patch-2.7.4/src/inp.c
--- patch-2.7.4/src/inp.c.selinux 2015-01-31 21:13:45.000000000 +0000
+++ patch-2.7.4/src/inp.c 2015-02-01 12:46:56.922818144 +0000
diff -up patch-2.7.5/src/inp.c.selinux patch-2.7.5/src/inp.c
--- patch-2.7.5/src/inp.c.selinux 2015-03-07 00:34:20.000000000 +0000
+++ patch-2.7.5/src/inp.c 2015-03-09 09:29:46.084415918 +0000
@@ -145,7 +145,7 @@ get_input_file (char const *filename, ch
char *getbuf;
@ -47,34 +47,34 @@ diff -up patch-2.7.4/src/inp.c.selinux patch-2.7.4/src/inp.c
}
else if (! ((S_ISREG (file_type) || S_ISLNK (file_type))
&& (file_type & S_IFMT) == (instat.st_mode & S_IFMT)))
diff -up patch-2.7.4/src/Makefile.am.selinux patch-2.7.4/src/Makefile.am
--- patch-2.7.4/src/Makefile.am.selinux 2015-01-31 21:12:47.000000000 +0000
+++ patch-2.7.4/src/Makefile.am 2015-02-01 12:46:56.922818144 +0000
@@ -36,7 +36,7 @@ patch_SOURCES = \
diff -up patch-2.7.5/src/Makefile.am.selinux patch-2.7.5/src/Makefile.am
--- patch-2.7.5/src/Makefile.am.selinux 2015-03-07 00:34:20.000000000 +0000
+++ patch-2.7.5/src/Makefile.am 2015-03-09 09:29:46.084415918 +0000
@@ -37,7 +37,7 @@ patch_SOURCES = \
AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
patch_LDADD = $(LDADD) $(top_builddir)/lib/libpatch.a $(LIB_CLOCK_GETTIME) \
- $(LIB_XATTR)
+ $(LIB_XATTR) -lselinux
- $(LIB_XATTR) $(LIB_EACCESS)
+ $(LIB_XATTR) $(LIB_EACCESS) -lselinux
if ENABLE_MERGE
patch_SOURCES += merge.c
diff -up patch-2.7.4/src/Makefile.in.selinux patch-2.7.4/src/Makefile.in
--- patch-2.7.4/src/Makefile.in.selinux 2015-01-31 21:14:45.000000000 +0000
+++ patch-2.7.4/src/Makefile.in 2015-02-01 12:46:56.923818145 +0000
@@ -1062,7 +1062,7 @@ patch_SOURCES = bestmatch.h common.h inp
diff -up patch-2.7.5/src/Makefile.in.selinux patch-2.7.5/src/Makefile.in
--- patch-2.7.5/src/Makefile.in.selinux 2015-03-07 00:34:34.000000000 +0000
+++ patch-2.7.5/src/Makefile.in 2015-03-09 09:29:46.084415918 +0000
@@ -1068,7 +1068,7 @@ patch_SOURCES = bestmatch.h common.h inp
AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib \
$(am__append_2)
patch_LDADD = $(LDADD) $(top_builddir)/lib/libpatch.a $(LIB_CLOCK_GETTIME) \
- $(LIB_XATTR)
+ $(LIB_XATTR) -lselinux
- $(LIB_XATTR) $(LIB_EACCESS)
+ $(LIB_XATTR) $(LIB_EACCESS) -lselinux
all: all-am
diff -up patch-2.7.4/src/patch.c.selinux patch-2.7.4/src/patch.c
--- patch-2.7.4/src/patch.c.selinux 2015-01-31 21:14:01.000000000 +0000
+++ patch-2.7.4/src/patch.c 2015-02-01 12:46:56.923818145 +0000
@@ -261,19 +261,19 @@ main (int argc, char **argv)
diff -up patch-2.7.5/src/patch.c.selinux patch-2.7.5/src/patch.c
--- patch-2.7.5/src/patch.c.selinux 2015-03-07 00:34:20.000000000 +0000
+++ patch-2.7.5/src/patch.c 2015-03-09 09:29:46.085415923 +0000
@@ -263,19 +263,19 @@ main (int argc, char **argv)
if (! strcmp (inname, outname))
{
if (inerrno == -1)
@ -97,7 +97,7 @@ diff -up patch-2.7.4/src/patch.c.selinux patch-2.7.4/src/patch.c
inerrno = -1;
}
if (! outerrno)
@@ -570,7 +570,7 @@ main (int argc, char **argv)
@@ -588,7 +588,7 @@ main (int argc, char **argv)
mode, &new_time);
else
{
@ -106,7 +106,7 @@ diff -up patch-2.7.4/src/patch.c.selinux patch-2.7.4/src/patch.c
set_file_attributes (TMPOUTNAME, attr, inname, &instat,
mode, &new_time);
}
@@ -630,7 +630,7 @@ main (int argc, char **argv)
@@ -648,7 +648,7 @@ main (int argc, char **argv)
struct stat oldst;
int olderrno;
@ -115,7 +115,7 @@ diff -up patch-2.7.4/src/patch.c.selinux patch-2.7.4/src/patch.c
if (olderrno && olderrno != ENOENT)
write_fatal ();
if (! olderrno && lookup_file_id (&oldst) == CREATED)
@@ -1760,7 +1760,7 @@ delete_file_later (const char *name, con
@@ -1780,7 +1780,7 @@ delete_file_later (const char *name, con
if (! st)
{
@ -124,9 +124,9 @@ diff -up patch-2.7.4/src/patch.c.selinux patch-2.7.4/src/patch.c
pfatal ("Can't get file attributes of %s %s", "file", name);
st = &st_tmp;
}
diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
--- patch-2.7.4/src/pch.c.selinux 2015-01-31 21:14:01.000000000 +0000
+++ patch-2.7.4/src/pch.c 2015-02-01 12:46:56.924818146 +0000
diff -up patch-2.7.5/src/pch.c.selinux patch-2.7.5/src/pch.c
--- patch-2.7.5/src/pch.c.selinux 2015-03-07 00:34:20.000000000 +0000
+++ patch-2.7.5/src/pch.c 2015-03-09 09:29:46.085415923 +0000
@@ -1,6 +1,6 @@
/* reading patches */
@ -135,7 +135,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
Copyright (C) 1990-1993, 1997-2003, 2006, 2009-2012 Free Software
Foundation, Inc.
@@ -293,7 +293,7 @@ there_is_another_patch (bool need_header
@@ -296,7 +296,7 @@ there_is_another_patch (bool need_header
if (t > buf + 1 && *(t - 1) == '\n')
{
inname = xmemdup0 (buf, t - buf - 1);
@ -144,7 +144,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
if (inerrno)
{
perror (inname);
@@ -430,6 +430,7 @@ intuit_diff_type (bool need_header, mode
@@ -433,6 +433,7 @@ intuit_diff_type (bool need_header, mode
bool extended_headers = false;
enum nametype i;
struct stat st[3];
@ -152,7 +152,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
int stat_errno[3];
int version_controlled[3];
enum diff retval;
@@ -470,6 +471,7 @@ intuit_diff_type (bool need_header, mode
@@ -473,6 +474,7 @@ intuit_diff_type (bool need_header, mode
version_controlled[OLD] = -1;
version_controlled[NEW] = -1;
version_controlled[INDEX] = -1;
@ -160,7 +160,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
p_rfc934_nesting = 0;
p_timestamp[OLD].tv_sec = p_timestamp[NEW].tv_sec = -1;
p_says_nonexistent[OLD] = p_says_nonexistent[NEW] = 0;
@@ -879,7 +881,7 @@ intuit_diff_type (bool need_header, mode
@@ -882,7 +884,7 @@ intuit_diff_type (bool need_header, mode
}
else
{
@ -169,7 +169,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
if (! stat_errno[i])
{
if (lookup_file_id (&st[i]) == DELETE_LATER)
@@ -918,7 +920,7 @@ intuit_diff_type (bool need_header, mode
@@ -921,7 +923,7 @@ intuit_diff_type (bool need_header, mode
if (cs)
{
if (version_get (p_name[i], cs, false, readonly,
@ -178,7 +178,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
stat_errno[i] = 0;
else
version_controlled[i] = 0;
@@ -981,7 +983,7 @@ intuit_diff_type (bool need_header, mode
@@ -984,7 +986,7 @@ intuit_diff_type (bool need_header, mode
{
if (inname)
{
@ -187,7 +187,7 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
if (inerrno || (instat.st_mode & S_IFMT) == file_type)
maybe_reverse (inname, inerrno, inerrno || instat.st_size == 0);
}
@@ -994,8 +996,14 @@ intuit_diff_type (bool need_header, mode
@@ -997,8 +999,14 @@ intuit_diff_type (bool need_header, mode
inerrno = stat_errno[i];
invc = version_controlled[i];
instat = st[i];
@ -202,30 +202,34 @@ diff -up patch-2.7.4/src/pch.c.selinux patch-2.7.4/src/pch.c
return retval;
}
diff -up patch-2.7.4/src/util.c.selinux patch-2.7.4/src/util.c
--- patch-2.7.4/src/util.c.selinux 2015-01-31 21:14:01.000000000 +0000
+++ patch-2.7.4/src/util.c 2015-02-01 12:51:16.584224140 +0000
@@ -300,6 +300,19 @@ set_file_attributes (char const *to, enu
diff -up patch-2.7.5/src/util.c.selinux patch-2.7.5/src/util.c
--- patch-2.7.5/src/util.c.selinux 2015-03-07 00:34:20.000000000 +0000
+++ patch-2.7.5/src/util.c 2015-03-09 09:36:02.025206352 +0000
@@ -300,6 +300,23 @@ set_file_attributes (char const *to, enu
S_ISLNK (mode) ? "symbolic link" : "file",
quotearg (to));
}
+ if (attr & FA_SECCONTEXT)
+ {
+ security_context_t outcontext;
+ if (incontext && getfilecon (to, &outcontext) != -1 &&
+ outcontext &&
+ strcmp (outcontext, incontext) &&
+ setfilecon (to, incontext) != 0)
+ if (incontext && getfilecon (to, &outcontext) != -1 && outcontext)
+ {
+ if (errno != ENOTSUP && errno != EPERM)
+ pfatal ("Can't set security context on file %s",
+ quotearg (to));
+ if (strcmp (outcontext, incontext) &&
+ setfilecon (to, incontext) != 0)
+ {
+ freecon (outcontext);
+ if (errno != ENOTSUP && errno != EPERM)
+ pfatal ("Can't set security context on file %s",
+ quotearg (to));
+ }
+ else
+ freecon (outcontext);
+ }
+ }
}
static void
@@ -446,7 +459,7 @@ move_file (char const *from, bool *from_
@@ -446,7 +463,7 @@ move_file (char const *from, bool *from_
struct stat to_st;
int to_errno;
@ -234,7 +238,7 @@ diff -up patch-2.7.4/src/util.c.selinux patch-2.7.4/src/util.c
if (backup)
create_backup (to, to_errno ? NULL : &to_st, false);
if (! to_errno)
@@ -816,7 +829,8 @@ version_controller (char const *filename
@@ -816,7 +833,8 @@ version_controller (char const *filename
Return true if successful. */
bool
version_get (char const *filename, char const *cs, bool exists, bool readonly,
@ -244,7 +248,7 @@ diff -up patch-2.7.4/src/util.c.selinux patch-2.7.4/src/util.c
{
if (patch_get < 0)
{
@@ -841,6 +855,13 @@ version_get (char const *filename, char
@@ -841,6 +859,13 @@ version_get (char const *filename, char
fatal ("Can't get file %s from %s", quotearg (filename), cs);
if (safe_stat (filename, filestat) != 0)
pfatal ("%s", quotearg (filename));
@ -258,8 +262,8 @@ diff -up patch-2.7.4/src/util.c.selinux patch-2.7.4/src/util.c
}
return 1;
@@ -1664,12 +1685,28 @@ make_tempfile (char const **name, char l
}
@@ -1664,12 +1689,28 @@ make_tempfile (char const **name, char l
return fd;
}
-int stat_file (char const *filename, struct stat *st)
@ -277,21 +281,21 @@ diff -up patch-2.7.4/src/util.c.selinux patch-2.7.4/src/util.c
+ if (xgetfilecon (filename, con) != -1 ||
+ errno == ENODATA || errno == ENOTSUP)
+ return 0;
+
- return xstat (filename, st) == 0 ? 0 : errno;
+ *con = NULL;
+ }
+ else
+ return 0;
+ }
- return xstat (filename, st) == 0 ? 0 : errno;
+
+ return errno;
}
/* Check if a filename is relative and free of ".." components.
diff -up patch-2.7.4/src/util.h.selinux patch-2.7.4/src/util.h
--- patch-2.7.4/src/util.h.selinux 2015-01-31 21:14:01.000000000 +0000
+++ patch-2.7.4/src/util.h 2015-02-01 12:46:56.925818147 +0000
diff -up patch-2.7.5/src/util.h.selinux patch-2.7.5/src/util.h
--- patch-2.7.5/src/util.h.selinux 2015-01-31 21:14:01.000000000 +0000
+++ patch-2.7.5/src/util.h 2015-03-09 09:29:46.085415923 +0000
@@ -44,7 +44,7 @@ char *parse_name (char const *, int, cha
char *savebuf (char const *, size_t);
char *savestr (char const *);

View File

@ -1,7 +1,7 @@
Summary: Utility for modifying/upgrading files
Name: patch
Version: 2.7.4
Release: 2%{?dist}
Version: 2.7.5
Release: 1%{?dist}
License: GPLv3+
URL: http://www.gnu.org/software/patch/patch.html
Group: Development/Tools
@ -54,6 +54,11 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/*/*
%changelog
* Mon Mar 9 2015 Tim Waugh <twaugh@redhat.com> - 2.7.5-1
- Fixed memory leak in selinux patch.
- 2.7.5, including an even better fix for CVE-2015-1196 that still
allows relative symlinks to be created/used.
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 2.7.4-2
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code