auto-import changelog data from patch-2.5.4-11.src.rpm
Tue Mar 05 2002 Tim Waugh <twaugh@redhat.com> 2.5.4-11 - s/Copyright:/License:/. - Fix -D behaviour (bug #60688).
This commit is contained in:
parent
191b24e700
commit
0761d2269c
70
patch-2.5.4-ifdef.patch
Normal file
70
patch-2.5.4-ifdef.patch
Normal file
@ -0,0 +1,70 @@
|
||||
--- patch-2.5.4/patch.c.ifdef Tue Mar 5 09:42:45 2002
|
||||
+++ patch-2.5.4/patch.c Tue Mar 5 09:42:47 2002
|
||||
@@ -88,8 +88,9 @@
|
||||
|
||||
static char const *do_defines; /* symbol to patch using ifdef, ifndef, etc. */
|
||||
static char const if_defined[] = "\n#ifdef %s\n";
|
||||
-static char const not_defined[] = "#ifndef %s\n";
|
||||
-static char const else_defined[] = "\n#else\n";
|
||||
+static char const not_defined[] = "\n#ifndef %s\n";
|
||||
+static char const elseis_defined[] = "\n#else /* %s */\n";
|
||||
+static char const elsenot_defined[] = "\n#else /* not %s */\n";
|
||||
static char const end_defined[] = "\n#endif /* %s */\n";
|
||||
|
||||
static int Argc;
|
||||
@@ -1014,12 +1015,13 @@
|
||||
return FALSE;
|
||||
if (R_do_defines) {
|
||||
if (def_state == OUTSIDE) {
|
||||
- fprintf (fp, outstate->after_newline + if_defined,
|
||||
+ fprintf (fp, outstate->after_newline + not_defined,
|
||||
R_do_defines);
|
||||
def_state = IN_IFNDEF;
|
||||
}
|
||||
else if (def_state == IN_IFDEF) {
|
||||
- fprintf (fp, outstate->after_newline + else_defined);
|
||||
+ fprintf (fp, outstate->after_newline + elsenot_defined,
|
||||
+ R_do_defines);
|
||||
def_state = IN_ELSE;
|
||||
}
|
||||
if (ferror (fp))
|
||||
@@ -1038,7 +1040,8 @@
|
||||
return FALSE;
|
||||
if (R_do_defines) {
|
||||
if (def_state == IN_IFNDEF) {
|
||||
- fprintf (fp, outstate->after_newline + else_defined);
|
||||
+ fprintf (fp, outstate->after_newline + elseis_defined,
|
||||
+ R_do_defines);
|
||||
def_state = IN_ELSE;
|
||||
}
|
||||
else if (def_state == OUTSIDE) {
|
||||
@@ -1069,7 +1072,8 @@
|
||||
return FALSE;
|
||||
assert (outstate->after_newline);
|
||||
if (R_do_defines) {
|
||||
- fprintf (fp, not_defined, R_do_defines);
|
||||
+ fprintf (fp, outstate->after_newline + not_defined,
|
||||
+ R_do_defines);
|
||||
if (ferror (fp))
|
||||
write_fatal ();
|
||||
def_state = IN_IFNDEF;
|
||||
@@ -1086,7 +1090,8 @@
|
||||
while (pch_char (old) == '!');
|
||||
|
||||
if (R_do_defines) {
|
||||
- fprintf (fp, outstate->after_newline + else_defined);
|
||||
+ fprintf (fp, outstate->after_newline + elseis_defined,
|
||||
+ R_do_defines);
|
||||
if (ferror (fp))
|
||||
write_fatal ();
|
||||
def_state = IN_ELSE;
|
||||
@@ -1124,7 +1129,8 @@
|
||||
def_state = IN_IFDEF;
|
||||
}
|
||||
else if (def_state == IN_IFNDEF) {
|
||||
- fprintf (fp, outstate->after_newline + else_defined);
|
||||
+ fprintf (fp, outstate->after_newline + elseis_defined,
|
||||
+ R_do_defines);
|
||||
def_state = IN_ELSE;
|
||||
}
|
||||
if (ferror (fp))
|
12
patch.spec
12
patch.spec
@ -1,14 +1,15 @@
|
||||
Summary: The GNU patch command, for modifying/upgrading files.
|
||||
Name: patch
|
||||
Version: 2.5.4
|
||||
Release: 10
|
||||
Copyright: GPL
|
||||
Release: 11
|
||||
License: GPL
|
||||
URL: http://www.gnu.org/software/patch/patch.html
|
||||
Group: Development/Tools
|
||||
Source: ftp://ftp.gnu.org/gnu/patch/patch-%{version}.tar.gz
|
||||
Patch1: patch-2.5-stderr.patch
|
||||
Patch2: patch-2.5.4-suffix.patch
|
||||
Patch3: patch-2.5.4-sigsegv.patch
|
||||
Patch4: patch-2.5.4-ifdef.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -26,6 +27,7 @@ applications.
|
||||
%patch1 -p1 -b .stderr
|
||||
%patch2 -p1 -b .suffix
|
||||
%patch3 -p1 -b .sigsegv
|
||||
%patch4 -p1 -b .ifdef
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
||||
@ -52,7 +54,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Tue May 29 2001 Tim Waugh <twaugh@redhat.com>
|
||||
* Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 2.5.4-11
|
||||
- s/Copyright:/License:/.
|
||||
- Fix -D behaviour (bug #60688).
|
||||
|
||||
* Tue May 29 2001 Tim Waugh <twaugh@redhat.com> 2.5.4-10
|
||||
- Merge Mandrake patch:
|
||||
- fix possible segfault
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user