e9e9dec33a
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
19 lines
674 B
Diff
19 lines
674 B
Diff
Avoid an implicit int, to prevent build failures with future compilers.
|
|
|
|
Submitted upstream: <https://bugs.passt.top/show_bug.cgi?id=42>
|
|
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 1dc2df5884d3b597..cd62900e7406e155 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -95,7 +95,7 @@ ifeq ($(shell :|$(CC) -fstack-protector-strong -S -xc - -o - >/dev/null 2>&1; ec
|
|
FLAGS += -fstack-protector-strong
|
|
endif
|
|
|
|
-C := \#define _GNU_SOURCE\n\#include <fcntl.h>\nx = FALLOC_FL_COLLAPSE_RANGE;
|
|
+C := \#define _GNU_SOURCE\n\#include <fcntl.h>\nint x = FALLOC_FL_COLLAPSE_RANGE;
|
|
ifeq ($(shell printf "$(C)" | $(CC) -S -xc - -o - >/dev/null 2>&1; echo $$?),0)
|
|
EXTRA_SYSCALLS += fallocate
|
|
endif
|