8e3b457f0f
Fix bug in nilfs2 probe with short partitions (#728949) Fix bug in hfs probe code (#714758) Make pc98 detection depend on specific signatures (#646053)
76 lines
2.4 KiB
Diff
76 lines
2.4 KiB
Diff
From 1a6336b7a903a6720604d7e8983f99939ec4b070 Mon Sep 17 00:00:00 2001
|
|
From: "Brian C. Lane" <bcl@redhat.com>
|
|
Date: Fri, 7 Oct 2011 11:41:25 -0700
|
|
Subject: [PATCH 2/2] tests: add tests for new pc98 signatures (#646053)
|
|
|
|
* tests/t2201-pc98-label-recog.sh: New file
|
|
* tests/Makefile.am: Add test
|
|
---
|
|
tests/Makefile.am | 1 +
|
|
tests/t2201-pc98-label-recog.sh | 41 +++++++++++++++++++++++++++++++++++++++
|
|
2 files changed, 42 insertions(+), 0 deletions(-)
|
|
create mode 100755 tests/t2201-pc98-label-recog.sh
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index 903ca64..525ec99 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -25,6 +25,7 @@ TESTS = \
|
|
t1101-busy-partition.sh \
|
|
t1700-probe-fs.sh \
|
|
t2200-dos-label-recog.sh \
|
|
+ t2201-pc98-label-recog.sh \
|
|
t2300-dos-label-extended-bootcode.sh \
|
|
t2310-dos-extended-2-sector-min-offset.sh \
|
|
t2400-dos-hfs-partition-type.sh \
|
|
diff --git a/tests/t2201-pc98-label-recog.sh b/tests/t2201-pc98-label-recog.sh
|
|
new file mode 100755
|
|
index 0000000..6228159
|
|
--- /dev/null
|
|
+++ b/tests/t2201-pc98-label-recog.sh
|
|
@@ -0,0 +1,41 @@
|
|
+#!/bin/sh
|
|
+# Recognize PC98 labeled disks
|
|
+
|
|
+# Copyright (C) 2011 Free Software Foundation, Inc.
|
|
+
|
|
+# This program is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation; either version 3 of the License, or
|
|
+# (at your option) any later version.
|
|
+
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+. "${srcdir=.}/init.sh"; path_prepend_ ../parted
|
|
+
|
|
+require_512_byte_sector_size_
|
|
+
|
|
+ss=$sector_size_
|
|
+N=8192
|
|
+dev=loop-file
|
|
+
|
|
+# create a file to simulate the underlying device
|
|
+dd if=/dev/null of=$dev bs=$ss seek=$N 2> /dev/null || fail=1
|
|
+
|
|
+# label the test disk
|
|
+parted -s $dev mklabel pc98 > out 2>&1 || fail=1
|
|
+compare out /dev/null || fail=1 # expect no output
|
|
+
|
|
+parted -s $dev p | grep "^Partition Table: pc98" || fail=1
|
|
+
|
|
+for s in "Linux 98" "GRUB/98 "; do
|
|
+ printf "$s" | dd bs=1c seek=4 of=$dev conv=notrunc || fail=1
|
|
+ parted -s $dev p | grep "^Partition Table: pc98" || fail=1
|
|
+done
|
|
+
|
|
+Exit $fail
|
|
--
|
|
1.7.6.4
|
|
|