3cb85c39f2
This changes the spec to run autoreconf so that patches to .am files will be picked up without having to resort to hand-patching .in files. This should make parted more maintainable in the future. Add patch to Fix snap radius and don't allow values < 1 (#665496) Add tests for the snap radius fix.
67 lines
2.1 KiB
Diff
67 lines
2.1 KiB
Diff
From b8f017f18fa99f9377ef461cbbd3264c7878a9aa Mon Sep 17 00:00:00 2001
|
|
From: Brian C. Lane <bcl@redhat.com>
|
|
Date: Tue, 21 Jun 2011 10:44:18 -0700
|
|
Subject: [PATCH 4/4] tests: add test for value less than 1
|
|
|
|
* tests/t9023-value-lt-one.sh: New file.
|
|
* tests/Makefile.am (TESTS): Add it.
|
|
---
|
|
tests/Makefile.am | 1 +
|
|
tests/t9023-value-lt-one.sh | 32 ++++++++++++++++++++++++++++++++
|
|
2 files changed, 33 insertions(+), 0 deletions(-)
|
|
create mode 100644 tests/t9023-value-lt-one.sh
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index 7487a5d..b57142b 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -45,6 +45,7 @@ TESTS = \
|
|
t9020-alignment.sh \
|
|
t9021-maxima.sh \
|
|
t9022-one-unit-snap.sh \
|
|
+ t9023-value-lt-one.sh \
|
|
t9030-align-check.sh \
|
|
t9040-many-partitions.sh \
|
|
t9041-undetected-in-use-16th-partition.sh \
|
|
diff --git a/tests/t9023-value-lt-one.sh b/tests/t9023-value-lt-one.sh
|
|
new file mode 100644
|
|
index 0000000..67be8d6
|
|
--- /dev/null
|
|
+++ b/tests/t9023-value-lt-one.sh
|
|
@@ -0,0 +1,32 @@
|
|
+#!/bin/sh
|
|
+# Confirm that a value between 0 and 1 throws an error
|
|
+
|
|
+# Copyright (C) 2011 Free Software Foundation, Inc.
|
|
+
|
|
+# This program is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation; either version 3 of the License, or
|
|
+# (at your option) any later version.
|
|
+
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+. "${srcdir=.}/init.sh"; path_prepend_ ../parted
|
|
+
|
|
+ss=$sector_size_
|
|
+n_sectors=3000
|
|
+dev=dev-file
|
|
+
|
|
+echo 'Error: Use a smaller unit instead of a value < 1' > exp
|
|
+
|
|
+dd if=/dev/null of=$dev bs=$ss seek=$n_sectors || fail=1
|
|
+parted --align=none -s $dev mklabel msdos mkpart pri 0 0.5MB \
|
|
+ > err 2>&1
|
|
+compare err exp || fail=1
|
|
+
|
|
+Exit $fail
|
|
--
|
|
1.7.4.4
|
|
|