d75d85cc43
- tests/t1701-rescue-fs wait for the device to appear. (bcl) - Increase timeout for rmmod scsi_debug and make it a framework failure (bcl) - libparted/dasd: add test cases for the new fdasd functions (dongdwdw) - libparted/dasd: add an exception for changing DASD-LDL partition table (dongdwdw) - libpartd/dasd: improve flag processing for DASD-LDL (dongdwdw) - parted/ui: remove unneccesary information of command line (dongdwdw) - parted: check the name of partition first when to name a partition (dongdwdw) - Add support for RAM drives (sparschauer) - Fix crash when localized (psusi) - libparted: Fix typo in hfs error message (sebras) - libparted: Fix MacOS boot support (laurent) - mac: copy partition type and name correctly (saproj) - libparted: Add support for atari partition tables (glaubitz) - libparted:tests: Move get_sector_size() to common.c (glaubitz) - tests: Update t0220 and t0280 for the swap flag. (bcl) - libparted: set swap flag on GPT partitions (aschnell) - libparted/dasd: add test cases for the new fdasd functions (dongdwdw) - libparted/dasd: add new fdasd functions (dongdwdw) - libparted/dasd: update and improve fdasd functions (dongdwdw) - libparted/dasd: unify vtoc handling for cdl/ldl (dongdwdw) - libparted: Don't warn if no HDIO_GET_IDENTITY ioctl (sparschauer) - libparted: Fix starting CHS in protective MBR (petr.uzel) - tests: Stop timing t9040 (#1172675) (bcl)
44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From 6872c0d2fd2038b366cc8086588a272465d6a553 Mon Sep 17 00:00:00 2001
|
|
From: Wang Dong <dongdwdw@linux.vnet.ibm.com>
|
|
Date: Wed, 26 Oct 2016 04:22:49 +0200
|
|
Subject: [PATCH 61/75] libparted/dasd: add test cases for the new fdasd
|
|
functions
|
|
|
|
The test case uses a temporary file in libparted/tests under
|
|
Check framwork. It can be issued by "make check" in the test dir.
|
|
|
|
Signed-off-by: Wang Dong <dongdwdw@linux.vnet.ibm.com>
|
|
Signed-off-by: Hendrik Brueckner <brueckner@linux.vnet.ibm.com>
|
|
Signed-off-by: Brian C. Lane <bcl@redhat.com>
|
|
---
|
|
libparted/tests/Makefile.am | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libparted/tests/Makefile.am b/libparted/tests/Makefile.am
|
|
index c7c10a9..9689fb3 100644
|
|
--- a/libparted/tests/Makefile.am
|
|
+++ b/libparted/tests/Makefile.am
|
|
@@ -3,9 +3,9 @@
|
|
#
|
|
# This file may be modified and/or distributed without restriction.
|
|
|
|
-TESTS = t1000-label.sh t2000-disk.sh t2100-zerolen.sh t3000-symlink.sh
|
|
+TESTS = t1000-label.sh t2000-disk.sh t2100-zerolen.sh t3000-symlink.sh t4000-volser.sh
|
|
EXTRA_DIST = $(TESTS)
|
|
-check_PROGRAMS = label disk zerolen symlink
|
|
+check_PROGRAMS = label disk zerolen symlink volser
|
|
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
|
|
|
|
LDADD = \
|
|
@@ -23,6 +23,7 @@ label_SOURCES = common.h common.c label.c
|
|
disk_SOURCES = common.h common.c disk.c
|
|
zerolen_SOURCES = common.h common.c zerolen.c
|
|
symlink_SOURCES = common.h common.c symlink.c
|
|
+volser_SOURCES = common.h common.c volser.c
|
|
|
|
# Arrange to symlink to tests/init.sh.
|
|
CLEANFILES = init.sh
|
|
--
|
|
2.9.3
|
|
|