0b7af917e2
- Drop patches incorporated into upstream - Still adds the various DASD patches
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
From d3a81337ff149294b7cf63c45a61ffa24fa542c5 Mon Sep 17 00:00:00 2001
|
|
From: Eric Blake <eblake@redhat.com>
|
|
Date: Tue, 23 Oct 2012 11:07:29 +0200
|
|
Subject: [PATCH 44/89] build: default to --enable-gcc-warnings in a git tree
|
|
|
|
Anyone building from cloned sources can be assumed to have a new
|
|
enough environment, such that enabling gcc warnings by default will
|
|
be useful. Tarballs still default to no warnings, and the default
|
|
can still be overridden with --disable-gcc-warnings.
|
|
* configure.ac (gl_gcc_warnings): Set default based on environment.
|
|
---
|
|
configure.ac | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 832fc20..417f325 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -187,7 +187,11 @@ AC_ARG_ENABLE([gcc-warnings],
|
|
*) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
|
|
esac
|
|
gl_gcc_warnings=$enableval],
|
|
- [gl_gcc_warnings=no]
|
|
+ [if test -d "$srcdir"/.git; then
|
|
+ gl_gcc_warnings=yes
|
|
+ else
|
|
+ gl_gcc_warnings=no
|
|
+ fi]
|
|
)
|
|
|
|
if test "$gl_gcc_warnings" = yes; then
|
|
--
|
|
1.8.5.3
|
|
|