- Add KNOWN ISSUES section to parted(8) man page explaining that we cannot
currently do ext3 resizing inside parted (#367101) - Update the xvd patch to include 'xvd' in the string table that parted uses when printing device types (#366971) - Do not install the linux.h or gnu.h headers
This commit is contained in:
parent
75660056b6
commit
f6ed55a348
22
parted-1.8.6-manpage.patch
Normal file
22
parted-1.8.6-manpage.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -up parted-1.8.6/doc/C/parted.8.manpage parted-1.8.6/doc/C/parted.8
|
||||
--- parted-1.8.6/doc/C/parted.8.manpage 2007-03-13 13:01:09.000000000 -0400
|
||||
+++ parted-1.8.6/doc/C/parted.8 2007-11-05 13:55:18.000000000 -0500
|
||||
@@ -108,6 +108,18 @@ supported are: "boot", "root", "swap", "
|
||||
"palo".
|
||||
\fIstate\fP should be either "on" or "off"
|
||||
.RE
|
||||
+.SH KNOWN ISSUES
|
||||
+ext3 filesystem resizing does not currently work, please use
|
||||
+.BR resize2fs (8)
|
||||
+instead.
|
||||
+
|
||||
+Resizing partitions with an ext3 filesystem will not generally work because
|
||||
+of the above issue. Use
|
||||
+.BR resize2fs (8)
|
||||
+to resize the filesystem and resize the partition manually using
|
||||
+.BR fdisk (8)
|
||||
+or a similar tool. For LVM situations, you will need to use the LVM commands
|
||||
+to resize the LVM elements.
|
||||
.SH REPORTING BUGS
|
||||
Report bugs to <bug-parted@gnu.org>
|
||||
.SH SEE ALSO
|
@ -1,7 +1,17 @@
|
||||
diff -up parted-1.8.6/include/parted/Makefile.am.hdrs parted-1.8.6/include/parted/Makefile.am
|
||||
--- parted-1.8.6/include/parted/Makefile.am.hdrs 2007-03-19 20:58:55.000000000 -0400
|
||||
+++ parted-1.8.6/include/parted/Makefile.am 2007-10-30 14:39:11.000000000 -0400
|
||||
@@ -12,11 +12,11 @@ partedinclude_HEADERS = gnu.h \
|
||||
diff -up parted-1.8.6/include/parted/Makefile.am.noinst parted-1.8.6/include/parted/Makefile.am
|
||||
--- parted-1.8.6/include/parted/Makefile.am.noinst 2007-03-19 20:58:55.000000000 -0400
|
||||
+++ parted-1.8.6/include/parted/Makefile.am 2007-11-05 14:05:41.000000000 -0500
|
||||
@@ -1,8 +1,6 @@
|
||||
partedincludedir = $(includedir)/parted
|
||||
|
||||
-partedinclude_HEADERS = gnu.h \
|
||||
- linux.h \
|
||||
- constraint.h \
|
||||
+partedinclude_HEADERS = constraint.h \
|
||||
debug.h \
|
||||
device.h \
|
||||
disk.h \
|
||||
@@ -12,11 +10,13 @@ partedinclude_HEADERS = gnu.h \
|
||||
natmath.h \
|
||||
timer.h \
|
||||
unit.h \
|
||||
@ -14,6 +24,8 @@ diff -up parted-1.8.6/include/parted/Makefile.am.hdrs parted-1.8.6/include/parte
|
||||
- endian.h
|
||||
+ endian.h \
|
||||
+ fdasd.h \
|
||||
+ vtoc.h
|
||||
+ vtoc.h \
|
||||
+ linux.h \
|
||||
+ gnu.h
|
||||
|
||||
MAINTAINERCLEANFILES = Makefile.in
|
||||
|
@ -1,38 +1,6 @@
|
||||
diff -up parted-1.8.6/libparted/arch/linux.c.xvd parted-1.8.6/libparted/arch/linux.c
|
||||
--- parted-1.8.6/libparted/arch/linux.c.xvd 2007-08-07 14:05:59.000000000 -0400
|
||||
+++ parted-1.8.6/libparted/arch/linux.c 2007-08-07 14:07:13.000000000 -0400
|
||||
@@ -248,6 +248,7 @@ struct blkdev_ioctl_param {
|
||||
#define VIODASD_MAJOR 112
|
||||
#define SX8_MAJOR1 160
|
||||
#define SX8_MAJOR2 161
|
||||
+#define XVD_MAJOR 202
|
||||
|
||||
#define SCSI_BLK_MAJOR(M) ( \
|
||||
(M) == SCSI_DISK0_MAJOR \
|
||||
@@ -450,6 +451,8 @@ _device_probe_type (PedDevice* dev)
|
||||
} else if (_is_dm_major(dev_major)) {
|
||||
dev->type = PED_DEVICE_DM;
|
||||
#endif
|
||||
+ } else if (dev_major == XVD_MAJOR && (dev_minor % 0x10 == 0)) {
|
||||
+ dev->type = PED_DEVICE_XVD;
|
||||
} else {
|
||||
dev->type = PED_DEVICE_UNKNOWN;
|
||||
}
|
||||
@@ -1152,6 +1155,11 @@ linux_new (const char* path)
|
||||
break;
|
||||
#endif
|
||||
|
||||
+ case PED_DEVICE_XVD:
|
||||
+ if (!init_generic (dev, _("Xen Virtual Block Device")))
|
||||
+ goto error_free_arch_specific;
|
||||
+ break;
|
||||
+
|
||||
case PED_DEVICE_UNKNOWN:
|
||||
if (!init_generic (dev, _("Unknown")))
|
||||
goto error_free_arch_specific;
|
||||
diff -up parted-1.8.6/include/parted/device.h.xvd parted-1.8.6/include/parted/device.h
|
||||
--- parted-1.8.6/include/parted/device.h.xvd 2007-01-12 10:15:10.000000000 -0500
|
||||
+++ parted-1.8.6/include/parted/device.h 2007-08-07 14:07:13.000000000 -0400
|
||||
+++ parted-1.8.6/include/parted/device.h 2007-11-05 14:00:59.000000000 -0500
|
||||
@@ -45,11 +45,11 @@ typedef enum {
|
||||
PED_DEVICE_UBD = 8,
|
||||
PED_DEVICE_DASD = 9,
|
||||
@ -48,3 +16,51 @@ diff -up parted-1.8.6/include/parted/device.h.xvd parted-1.8.6/include/parted/de
|
||||
} PedDeviceType;
|
||||
|
||||
typedef struct _PedDevice PedDevice;
|
||||
diff -up parted-1.8.6/libparted/arch/linux.c.xvd parted-1.8.6/libparted/arch/linux.c
|
||||
--- parted-1.8.6/libparted/arch/linux.c.xvd 2007-03-19 20:57:51.000000000 -0400
|
||||
+++ parted-1.8.6/libparted/arch/linux.c 2007-11-05 14:00:59.000000000 -0500
|
||||
@@ -254,6 +254,7 @@ struct blkdev_ioctl_param {
|
||||
#define VIODASD_MAJOR 112
|
||||
#define SX8_MAJOR1 160
|
||||
#define SX8_MAJOR2 161
|
||||
+#define XVD_MAJOR 202
|
||||
|
||||
#define SCSI_BLK_MAJOR(M) ( \
|
||||
(M) == SCSI_DISK0_MAJOR \
|
||||
@@ -456,6 +457,8 @@ _device_probe_type (PedDevice* dev)
|
||||
} else if (_is_dm_major(dev_major)) {
|
||||
dev->type = PED_DEVICE_DM;
|
||||
#endif
|
||||
+ } else if (dev_major == XVD_MAJOR && (dev_minor % 0x10 == 0)) {
|
||||
+ dev->type = PED_DEVICE_XVD;
|
||||
} else {
|
||||
dev->type = PED_DEVICE_UNKNOWN;
|
||||
}
|
||||
@@ -1158,6 +1161,11 @@ linux_new (const char* path)
|
||||
break;
|
||||
#endif
|
||||
|
||||
+ case PED_DEVICE_XVD:
|
||||
+ if (!init_generic (dev, _("Xen Virtual Block Device")))
|
||||
+ goto error_free_arch_specific;
|
||||
+ break;
|
||||
+
|
||||
case PED_DEVICE_UNKNOWN:
|
||||
if (!init_generic (dev, _("Unknown")))
|
||||
goto error_free_arch_specific;
|
||||
diff -up parted-1.8.6/parted/parted.c.xvd parted-1.8.6/parted/parted.c
|
||||
--- parted-1.8.6/parted/parted.c.xvd 2007-11-05 14:00:59.000000000 -0500
|
||||
+++ parted-1.8.6/parted/parted.c 2007-11-05 14:02:10.000000000 -0500
|
||||
@@ -1227,9 +1227,10 @@ do_print (PedDevice** dev)
|
||||
int has_free_arg = 0;
|
||||
int has_list_arg = 0;
|
||||
int has_num_arg = 0;
|
||||
- char* transport[13] = {"unknown", "scsi", "ide", "dac960",
|
||||
+ char* transport[14] = {"unknown", "scsi", "ide", "dac960",
|
||||
"cpqarray", "file", "ataraid", "i2o",
|
||||
- "ubd", "dasd", "viodasd", "sx8", "dm"};
|
||||
+ "ubd", "dasd", "viodasd", "sx8", "dm",
|
||||
+ "xvd"};
|
||||
char* peek_word;
|
||||
char* start;
|
||||
char* end;
|
||||
|
11
parted.spec
11
parted.spec
@ -4,7 +4,7 @@
|
||||
Summary: The GNU disk partition manipulation program
|
||||
Name: parted
|
||||
Version: 1.8.6
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://www.gnu.org/software/parted
|
||||
@ -17,6 +17,7 @@ Patch3: %{name}-1.8.6-primary-boundary.patch
|
||||
Patch4: %{name}-1.8.6-xvd.patch
|
||||
Patch5: %{name}-1.8.6-devmapper-header.patch
|
||||
Patch6: %{name}-1.8.6-noinst-headers.patch
|
||||
Patch7: %{name}-1.8.6-manpage.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: e2fsprogs-devel readline-devel ncurses-devel
|
||||
@ -53,6 +54,7 @@ Parted library, you need to install this package.
|
||||
%patch4 -p1 -b .xvd
|
||||
%patch5 -p1 -b .devmapper
|
||||
%patch6 -p1 -b .noinst
|
||||
%patch7 -p1 -b .manpage
|
||||
|
||||
%build
|
||||
%configure --enable-device-mapper --enable-selinux --disable-static
|
||||
@ -98,6 +100,13 @@ fi
|
||||
%{_libdir}/pkgconfig/libparted.pc
|
||||
|
||||
%changelog
|
||||
* Mon Nov 05 2007 David Cantrell <dcantrell@redhat.com> - 1.8.6-12
|
||||
- Add KNOWN ISSUES section to parted(8) man page explaining that we cannot
|
||||
currently do ext3 resizing inside parted (#367101)
|
||||
- Update the xvd patch to include 'xvd' in the string table that parted
|
||||
uses when printing device types (#366971)
|
||||
- Do not install the linux.h or gnu.h headers
|
||||
|
||||
* Tue Oct 30 2007 David Cantrell <dcantrell@redhat.com> - 1.8.6-11
|
||||
- Do not install fdasd.h and vtoc.h header files
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user