- Upgraded to GNU parted-1.8.8

- License for GNU parted is now GPLv3+
This commit is contained in:
David Cantrell 2008-01-03 02:26:18 +00:00
parent 69fc523eb4
commit eb51c16347
15 changed files with 88 additions and 236 deletions

View File

@ -1 +1 @@
parted-1.8.6.tar.bz2
parted-1.8.8.tar.bz2

View File

@ -1,13 +0,0 @@
diff -up parted-1.8.6/include/parted/device.h.devmapper parted-1.8.6/include/parted/device.h
--- parted-1.8.6/include/parted/device.h.devmapper 2007-10-04 15:39:27.000000000 -0400
+++ parted-1.8.6/include/parted/device.h 2007-10-04 15:40:11.000000000 -0400
@@ -46,9 +46,7 @@ typedef enum {
PED_DEVICE_DASD = 9,
PED_DEVICE_VIODASD = 10,
PED_DEVICE_SX8 = 11,
-#ifdef ENABLE_DEVICE_MAPPER
PED_DEVICE_DM = 12,
-#endif
PED_DEVICE_XVD = 13
} PedDeviceType;

View File

@ -1,14 +0,0 @@
diff -up parted-1.8.6/doc/C/parted.8.label-types parted-1.8.6/doc/C/parted.8
--- parted-1.8.6/doc/C/parted.8.label-types 2007-12-13 17:13:24.000000000 -1000
+++ parted-1.8.6/doc/C/parted.8 2007-12-13 17:14:41.000000000 -1000
@@ -104,8 +104,8 @@ a LVM logical volume if that is necessar
.TP
.B set \fIpartition\fP \fIflag\fP \fIstate\fP
change the state of the \fIflag\fP on \fIpartition\fP to \fIstate\fP. Flags
-supported are: "boot", "root", "swap", "hidden", "raid", "lvm", "lba" and
-"palo".
+supported are: "boot"(Mac, MS-DOS, PC98), "root"(Mac), "swap"(Mac), "hidden"(MS-DOS, PC98), "raid"(MS-DOS), "lvm"(MS-DOS), "lba"(MS-DOS) and
+"palo"(MS-DOS).
\fIstate\fP should be either "on" or "off"
.RE
.SH KNOWN ISSUES

View File

@ -1,22 +0,0 @@
diff -up parted-1.8.6/doc/C/parted.8.manpage parted-1.8.6/doc/C/parted.8
--- parted-1.8.6/doc/C/parted.8.manpage 2007-03-13 13:01:09.000000000 -0400
+++ parted-1.8.6/doc/C/parted.8 2007-11-05 13:55:18.000000000 -0500
@@ -108,6 +108,18 @@ supported are: "boot", "root", "swap", "
"palo".
\fIstate\fP should be either "on" or "off"
.RE
+.SH KNOWN ISSUES
+ext3 filesystem resizing does not currently work, please use
+.BR resize2fs (8)
+instead.
+
+Resizing partitions with an ext3 filesystem will not generally work because
+of the above issue. Use
+.BR resize2fs (8)
+to resize the filesystem and resize the partition manually using
+.BR fdisk (8)
+or a similar tool. For LVM situations, you will need to use the LVM commands
+to resize the LVM elements.
.SH REPORTING BUGS
Report bugs to <bug-parted@gnu.org>
.SH SEE ALSO

View File

@ -1,39 +0,0 @@
--- parted-1.8.6/parted/parted.c.notransname 2007-03-13 13:01:09.000000000 -0400
+++ parted-1.8.6/parted/parted.c 2007-03-21 10:50:35.000000000 -0400
@@ -1429,7 +1429,7 @@
part->fs_type->name : "");
if (has_name) {
- name = _(ped_partition_get_name (part));
+ name = ped_partition_get_name (part);
str_list_append (row, name);
}
--- parted-1.8.6/parted/table.c.notransname 2007-03-13 13:01:09.000000000 -0400
+++ parted-1.8.6/parted/table.c 2007-03-21 10:51:31.000000000 -0400
@@ -191,7 +191,8 @@
len += wcslen(COLSUFFIX);
newsize = (wcslen(*s) + len + 1) * sizeof(wchar_t);
- *s = realloc (*s, newsize);
+ *s = (wchar_t *) realloc (*s, newsize);
+ assert(*s != NULL);
for (i = 0; i < ncols; ++i)
{
@@ -199,6 +200,7 @@
int nspaces = max(t->widths[i] - wcswidth(row[i], MAX_WIDTH),
0);
wchar_t* pad = malloc ( (nspaces + 1) * sizeof(wchar_t) );
+ assert(pad != NULL);
for (j = 0; j < nspaces; ++j)
pad[j] = L' ';
@@ -211,6 +213,7 @@
wcscat (*s, DELIMITER);
free (pad);
+ pad = NULL;
}
wcscat (*s, COLSUFFIX);

View File

@ -1,25 +0,0 @@
--- parted-1.8.6/parted/parted.c.offbyone 2007-04-11 12:13:06.000000000 -0400
+++ parted-1.8.6/parted/parted.c 2007-04-11 12:13:21.000000000 -0400
@@ -1217,6 +1217,7 @@
static int
do_print (PedDevice** dev)
{
+ PedUnit default_unit;
PedDisk* disk;
Table* table;
StrList* row;
@@ -1303,11 +1304,12 @@
}
start = ped_unit_format (*dev, 0);
+ default_unit = ped_unit_get_default ();
end = ped_unit_format_byte (*dev, (*dev)->length * (*dev)->sector_size
- - 1 );
+ - (default_unit == PED_UNIT_CHS || default_unit == PED_UNIT_CYLINDER));
if (opt_machine_mode) {
- switch (ped_unit_get_default ()) {
+ switch (default_unit) {
case PED_UNIT_CHS: puts ("CHS;");
break;
case PED_UNIT_CYLINDER: puts ("CYL;");

View File

@ -1,12 +0,0 @@
--- parted-1.8.6/libparted/labels/dos.c.boundary 2007-03-13 13:01:09.000000000 -0400
+++ parted-1.8.6/libparted/labels/dos.c 2007-04-11 14:56:54.000000000 -0400
@@ -1696,8 +1696,7 @@
_primary_start_constraint (disk, part,
bios_geom, min_geom)));
- if (!solution)
- solution = _best_solution (part, bios_geom, solution,
+ solution = _best_solution (part, bios_geom, solution,
_try_constraint (part, constraint,
_primary_constraint (disk, bios_geom,
min_geom)));

View File

@ -1,11 +0,0 @@
--- parted-1.8.6/libparted/fs/linux_swap/linux_swap.c.warnings 2007-03-20 13:22:36.000000000 -0400
+++ parted-1.8.6/libparted/fs/linux_swap/linux_swap.c 2007-03-20 13:59:11.000000000 -0400
@@ -123,7 +123,7 @@
error_close_fs:
swap_close (fs);
-error:
+
return 0;
}
#endif /* !DISCOVER_ONLY */

View File

@ -1,66 +0,0 @@
diff -up parted-1.8.6/include/parted/device.h.xvd parted-1.8.6/include/parted/device.h
--- parted-1.8.6/include/parted/device.h.xvd 2007-01-12 10:15:10.000000000 -0500
+++ parted-1.8.6/include/parted/device.h 2007-11-05 14:00:59.000000000 -0500
@@ -45,11 +45,11 @@ typedef enum {
PED_DEVICE_UBD = 8,
PED_DEVICE_DASD = 9,
PED_DEVICE_VIODASD = 10,
- PED_DEVICE_SX8 = 11
+ PED_DEVICE_SX8 = 11,
#ifdef ENABLE_DEVICE_MAPPER
- ,
- PED_DEVICE_DM = 12
+ PED_DEVICE_DM = 12,
#endif
+ PED_DEVICE_XVD = 13
} PedDeviceType;
typedef struct _PedDevice PedDevice;
diff -up parted-1.8.6/libparted/arch/linux.c.xvd parted-1.8.6/libparted/arch/linux.c
--- parted-1.8.6/libparted/arch/linux.c.xvd 2007-03-19 20:57:51.000000000 -0400
+++ parted-1.8.6/libparted/arch/linux.c 2007-11-05 14:00:59.000000000 -0500
@@ -254,6 +254,7 @@ struct blkdev_ioctl_param {
#define VIODASD_MAJOR 112
#define SX8_MAJOR1 160
#define SX8_MAJOR2 161
+#define XVD_MAJOR 202
#define SCSI_BLK_MAJOR(M) ( \
(M) == SCSI_DISK0_MAJOR \
@@ -456,6 +457,8 @@ _device_probe_type (PedDevice* dev)
} else if (_is_dm_major(dev_major)) {
dev->type = PED_DEVICE_DM;
#endif
+ } else if (dev_major == XVD_MAJOR && (dev_minor % 0x10 == 0)) {
+ dev->type = PED_DEVICE_XVD;
} else {
dev->type = PED_DEVICE_UNKNOWN;
}
@@ -1158,6 +1161,11 @@ linux_new (const char* path)
break;
#endif
+ case PED_DEVICE_XVD:
+ if (!init_generic (dev, _("Xen Virtual Block Device")))
+ goto error_free_arch_specific;
+ break;
+
case PED_DEVICE_UNKNOWN:
if (!init_generic (dev, _("Unknown")))
goto error_free_arch_specific;
diff -up parted-1.8.6/parted/parted.c.xvd parted-1.8.6/parted/parted.c
--- parted-1.8.6/parted/parted.c.xvd 2007-11-05 14:00:59.000000000 -0500
+++ parted-1.8.6/parted/parted.c 2007-11-05 14:02:10.000000000 -0500
@@ -1227,9 +1227,10 @@ do_print (PedDevice** dev)
int has_free_arg = 0;
int has_list_arg = 0;
int has_num_arg = 0;
- char* transport[13] = {"unknown", "scsi", "ide", "dac960",
+ char* transport[14] = {"unknown", "scsi", "ide", "dac960",
"cpqarray", "file", "ataraid", "i2o",
- "ubd", "dasd", "viodasd", "sx8", "dm"};
+ "ubd", "dasd", "viodasd", "sx8", "dm",
+ "xvd"};
char* peek_word;
char* start;
char* end;

View File

@ -0,0 +1,13 @@
diff -up parted-1.8.8/include/parted/device.h.devmapper parted-1.8.8/include/parted/device.h
--- parted-1.8.8/include/parted/device.h.devmapper 2007-07-31 09:03:53.000000000 -1000
+++ parted-1.8.8/include/parted/device.h 2007-12-18 12:27:10.000000000 -1000
@@ -45,9 +45,7 @@ typedef enum {
PED_DEVICE_DASD = 9,
PED_DEVICE_VIODASD = 10,
PED_DEVICE_SX8 = 11,
-#ifdef ENABLE_DEVICE_MAPPER
PED_DEVICE_DM = 12,
-#endif
PED_DEVICE_XVD = 13
} PedDeviceType;

View File

@ -0,0 +1,32 @@
diff -up parted-1.8.8/doc/C/parted.8.manpage parted-1.8.8/doc/C/parted.8
--- parted-1.8.8/doc/C/parted.8.manpage 2007-05-14 05:24:17.000000000 -1000
+++ parted-1.8.8/doc/C/parted.8 2007-12-18 12:36:08.000000000 -1000
@@ -109,8 +109,7 @@ or an LVM logical volume if necessary.
.TP
.B set \fIpartition\fP \fIflag\fP \fIstate\fP
Change the state of the \fIflag\fP on \fIpartition\fP to \fIstate\fP.
-Supported flags are: "boot", "root", "swap", "hidden", "raid", "lvm", "lba",
-and "palo".
+Supported flags are: "boot" (Mac, MS-DOS, PC98), "root" (Mac), "swap" (Mac), "hidden" (MS-DOS, PC98), "raid" (MS-DOS), "lvm" (MS-DOS), "lba" (MS-DOS), and "palo" (MS-DOS).
\fIstate\fP should be either "on" or "off".
.TP
.B unit \fIunit\fP
@@ -124,6 +123,18 @@ and a human-friendly form for output).
.B version
Display version information and a copyright message.
.RE
+.SH KNOWN ISSUES
+ext3 filesystem resizing does not currently work, please use
+.BR resize2fs (8)
+instead.
+
+Resizing partitions with an ext3 filesystem will not generally work because
+of the above issue. Use
+.BR resize2fs (8)
+to resize the filesystem and resize the partition manually using
+.BR fdisk (8)
+or a similar tool. For LVM situations, you will need to use the LVM commands
+to resize the LVM elements.
.SH REPORTING BUGS
Report bugs to <bug-parted@gnu.org>
.SH SEE ALSO

View File

@ -1,7 +1,8 @@
diff -up parted-1.8.6/include/parted/Makefile.am.noinst parted-1.8.6/include/parted/Makefile.am
--- parted-1.8.6/include/parted/Makefile.am.noinst 2007-03-19 20:58:55.000000000 -0400
+++ parted-1.8.6/include/parted/Makefile.am 2007-11-05 14:05:41.000000000 -0500
@@ -1,8 +1,6 @@
diff -up parted-1.8.8/include/parted/Makefile.am.noinst parted-1.8.8/include/parted/Makefile.am
--- parted-1.8.8/include/parted/Makefile.am.noinst 2007-08-09 05:20:33.000000000 -1000
+++ parted-1.8.8/include/parted/Makefile.am 2007-12-18 12:30:34.000000000 -1000
@@ -6,9 +6,7 @@ endif
partedincludedir = $(includedir)/parted
-partedinclude_HEADERS = gnu.h \
@ -11,21 +12,19 @@ diff -up parted-1.8.6/include/parted/Makefile.am.noinst parted-1.8.6/include/par
debug.h \
device.h \
disk.h \
@@ -12,11 +10,13 @@ partedinclude_HEADERS = gnu.h \
@@ -18,10 +16,12 @@ partedinclude_HEADERS = gnu.h \
natmath.h \
timer.h \
unit.h \
- parted.h \
- fdasd.h \
- vtoc.h
- $(S390_HDRS)
+ parted.h
noinst_HEADERS = crc32.h \
- endian.h
+ endian.h \
+ fdasd.h \
+ vtoc.h \
+ gnu.h \
+ linux.h \
+ gnu.h
+ $(S390_HDRS)
MAINTAINERCLEANFILES = Makefile.in

16
parted-1.8.8-xvd.patch Normal file
View File

@ -0,0 +1,16 @@
diff -up parted-1.8.8/parted/parted.c.xvd parted-1.8.8/parted/parted.c
--- parted-1.8.8/parted/parted.c.xvd 2007-08-09 05:20:33.000000000 -1000
+++ parted-1.8.8/parted/parted.c 2007-12-18 12:25:16.000000000 -1000
@@ -1264,9 +1264,10 @@ do_print (PedDevice** dev)
int has_free_arg = 0;
int has_list_arg = 0;
int has_num_arg = 0;
- char* transport[13] = {"unknown", "scsi", "ide", "dac960",
+ char* transport[14] = {"unknown", "scsi", "ide", "dac960",
"cpqarray", "file", "ataraid", "i2o",
- "ubd", "dasd", "viodasd", "sx8", "dm"};
+ "ubd", "dasd", "viodasd", "sx8", "dm",
+ "xvd"};
char* peek_word;
char* start;
char* end;

View File

@ -3,22 +3,17 @@
Summary: The GNU disk partition manipulation program
Name: parted
Version: 1.8.6
Release: 13%{?dist}
License: GPLv2+
Version: 1.8.8
Release: 1%{?dist}
License: GPLv3+
Group: Applications/System
URL: http://www.gnu.org/software/parted
Source: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.bz2
Patch0: %{name}-1.8.6-warnings.patch
Patch1: %{name}-1.8.6-notransname.patch
Patch2: %{name}-1.8.6-off-by-one.patch
Patch3: %{name}-1.8.6-primary-boundary.patch
Patch4: %{name}-1.8.6-xvd.patch
Patch5: %{name}-1.8.6-devmapper-header.patch
Patch6: %{name}-1.8.6-noinst-headers.patch
Patch7: %{name}-1.8.6-manpage.patch
Patch8: %{name}-1.8.6-label-types.patch
Patch0: %{name}-1.8.8-xvd.patch
Patch1: %{name}-1.8.8-devmapper-header.patch
Patch2: %{name}-1.8.8-noinst-headers.patch
Patch3: %{name}-1.8.8-manpage.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: e2fsprogs-devel
@ -55,15 +50,10 @@ Parted library, you need to install this package.
%prep
%setup -q
%patch0 -p1 -b .warnings
%patch1 -p1 -b .notransname
%patch2 -p1 -b .offbyone
%patch3 -p1 -b .boundary
%patch4 -p1 -b .xvd
%patch5 -p1 -b .devmapper
%patch6 -p1 -b .noinst
%patch7 -p1 -b .manpage
%patch8 -p1 -b .label-types
%patch0 -p1 -b .xvd
%patch1 -p1 -b .devmapper
%patch2 -p1 -b .noinst
%patch3 -p1 -b .manpage
%build
%configure --enable-device-mapper --enable-selinux --disable-static
@ -74,7 +64,7 @@ Parted library, you need to install this package.
%{__make} install DESTDIR=%{buildroot}
%{__rm} -rf %{buildroot}%{_libdir}/*.la
%{__rm} -rf %{buildroot}%{_infodir}/dir
%{__rm} -f %{buildroot}%{_bindir}/label
%{__rm} -rf %{buildroot}%{_bindir}/label
%find_lang %{name}
@ -109,6 +99,10 @@ fi
%{_libdir}/pkgconfig/libparted.pc
%changelog
* Wed Jan 02 2008 David Cantrell <dcantrell@redhat.com> - 1.8.8-1
- Upgraded to GNU parted-1.8.8
- License for GNU parted is now GPLv3+
* Thu Dec 13 2007 David Cantrell <dcantrell@redhat.com> - 1.8.6-13
- Modify parted man page to indicate which flags are valid for which
disk labels (#242711)

View File

@ -1 +1 @@
03c967ae0e915e08da90605d68ba93d7 parted-1.8.6.tar.bz2
607ab4c3cfd8455af6588b97d99ad0ba parted-1.8.8.tar.bz2