- drop ldconfig, it no longer needs to be called on un/install (bcl)
- Fix msdos-overlap py3 conversion (bcl)
This commit is contained in:
parent
30d99a722c
commit
c0bbbd4bbe
@ -1,4 +1,4 @@
|
||||
From a0494446d44f00fbd47c1081186678d26c331a51 Mon Sep 17 00:00:00 2001
|
||||
From 073c24b5d2361857b8ce8b5dcd81a3e26fc05b96 Mon Sep 17 00:00:00 2001
|
||||
From: "Brian C. Lane" <bcl@redhat.com>
|
||||
Date: Wed, 27 Jun 2018 13:45:09 -0700
|
||||
Subject: [PATCH 91/92] Modify gpt-header-move and msdos-overlap to work with
|
||||
@ -64,7 +64,7 @@ index 05cdc65..3dda5cb 100755
|
||||
-file.write("\0" * (512 * 33))
|
||||
+file.write(b"\0" * (512 * 33))
|
||||
diff --git a/tests/msdos-overlap b/tests/msdos-overlap
|
||||
index 5bddfb0..48cfa7f 100755
|
||||
index 5bddfb0..d6ae8d6 100755
|
||||
--- a/tests/msdos-overlap
|
||||
+++ b/tests/msdos-overlap
|
||||
@@ -14,12 +14,11 @@ BAD_ENTRY = (0x72, 0xf5, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
|
||||
@ -79,7 +79,7 @@ index 5bddfb0..48cfa7f 100755
|
||||
with open(sys.argv[1], "rb+") as f:
|
||||
f.seek(OFFSET, 0)
|
||||
- f.write(data)
|
||||
+ f.write(bytes(BAD_ENTRY))
|
||||
+ f.write(bytes(bytearray(BAD_ENTRY)))
|
||||
|
||||
sys.exit(0)
|
||||
--
|
||||
|
@ -1,4 +1,4 @@
|
||||
From f37716966aaa5bde3b2636249944e9cdfdf2f82a Mon Sep 17 00:00:00 2001
|
||||
From 38badae4d6b858da713b383b9bc7bdad6294ca1b Mon Sep 17 00:00:00 2001
|
||||
From: "Brian C. Lane" <bcl@redhat.com>
|
||||
Date: Wed, 27 Jun 2018 13:47:33 -0700
|
||||
Subject: [PATCH 92/92] Switch gpt-header-move and msdos-overlap to python3
|
||||
@ -19,7 +19,7 @@ index 3dda5cb..18f58d0 100755
|
||||
# open img file, subtract 33 from altlba address, and move the last 33 sectors
|
||||
# back by 33 sectors
|
||||
diff --git a/tests/msdos-overlap b/tests/msdos-overlap
|
||||
index 48cfa7f..4f48005 100755
|
||||
index d6ae8d6..b2b03e6 100755
|
||||
--- a/tests/msdos-overlap
|
||||
+++ b/tests/msdos-overlap
|
||||
@@ -1,4 +1,4 @@
|
||||
|
12
parted.spec
12
parted.spec
@ -4,7 +4,7 @@
|
||||
Summary: The GNU disk partition manipulation program
|
||||
Name: parted
|
||||
Version: 3.2
|
||||
Release: 35%{?dist}
|
||||
Release: 36%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/System
|
||||
URL: http://www.gnu.org/software/parted
|
||||
@ -135,10 +135,8 @@ Buildrequires: python3
|
||||
BuildRequires: gperf
|
||||
BuildRequires: make
|
||||
|
||||
Requires(post): /sbin/ldconfig
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
Requires(postun): /sbin/ldconfig
|
||||
|
||||
# bundled gnulib library exception, as per packaging guidelines
|
||||
# https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
|
||||
@ -208,7 +206,6 @@ make check
|
||||
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
if [ -f %{_infodir}/parted.info.gz ]; then
|
||||
/sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir || :
|
||||
fi
|
||||
@ -218,9 +215,6 @@ if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc AUTHORS NEWS README THANKS
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
@ -245,6 +239,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 19 2018 Brian C. Lane <bcl@redhat.com> - 3.2-36
|
||||
- drop ldconfig, it no longer needs to be called on un/install (bcl)
|
||||
- Fix msdos-overlap py3 conversion (bcl)
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2-35
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user